Screen Setup Wizards cause FE to freeze

For discussion of topics specific to MythTV on Raspberry Pi devices
Post Reply
mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Screen Setup Wizards cause FE to freeze

Post by mtbdrew » Sat Jun 27, 2020 6:06 pm

Raspberry Pi3 running Raspberry Pi OS Lite, Have installed Mythtv-light v31 using these steps:

sudo raspi-config
sudo apt update
sudo apt -y full-upgrade
sudo reboot
sudo apt install git
git clone https://github.com/MikeB2013/pi-utils.git
sudo apt-get install --no-install-recommends xserver-xorg
cd pi-utils
./pi-setup_mythtv_31.sh
reboot and it will start up in mythfrontend

After reboot Mythtv FE runs automatically but does not completely fill TV screen (1" black border all the way around). If I attempt to run the Screen Setup Wizards the FE locks up requiring login via SSH run HTOP and kill "mythscreenwizard --verbose general --logpath /tmp --loglevel info--quiet" to regain FE functions.

User avatar
pgbennett
Developer
Posts: 347
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: Screen Setup Wizards cause FE to freeze

Post by pgbennett » Sun Jun 28, 2020 3:56 pm

The black border is probably from the raspberry pi overscan settings. Edit the /boot/config.txt and set or uncomment disable_overscan=1
and comment out lines overscan_left, overscan_right, overscan_top and overscan_bottom.

If this does not completely solve it you can comment the disable_overscan and try different values for the four overscan settings. I think this is a better method than trying to use the screen wizard.

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: Screen Setup Wizards cause FE to freeze

Post by mtbdrew » Sun Jun 28, 2020 4:53 pm

Thanks that fixed the issue.

Post Reply