RPi3 running V31 crashes with any V4L2 coding selection

For discussion of topics specific to MythTV on Raspberry Pi devices
mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Tue Jun 23, 2020 1:51 am

Upgraded from v30 to v31 and tried to use the settings recommended here:

https://www.mythtv.org/wiki/Raspberry_Pi#RPi3_Specific

But any time I select V4L2 profiles or V4L2 decoder the frontend crashes when attempting to play HD video. Only the MMAL profile using MMAL acceleration (decode only) or standard works so far but video is very jerky with either of the working profiles.

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Wed Jun 24, 2020 2:24 pm

No one has any suggestions? Are there drivers or something that need to be added for V4L2 support?

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Wed Jun 24, 2020 2:50 pm

I just confirmed that my RPI3B+ running mythfrontend v31-0.54 does work great with v4l2 decoding only on MPEG2 OTA ATSC USA HD recordings and .m4v videos. I setup my RPI3B+ with MPEG2 license and I use the pi-setup script from MikeB https://github.com/MikeB2013/pi-utils

So, I'm running from the command line. My current RPi3 setup is as follows:

I set a profile with 2 entries. The first is as follows:

Video Formats: mpeg2video
Decoder: v4l2 decode only
Max CPUs: 4
Deblocking Filter: checked
Video Renderer: OpenGL YV12
Deinterlacer quality (single rate): Low quality
Prefer OpenGL deinterlacers: checked
Prefer driver deinterlacers: unchecked
Deinterlacer quality (double rate): Low quality
Prefer OpenGL deinterlacers: checked
Prefer driver deinterlacers: unchecked

Second entry:
Decoder: v4l2 decode only
Max CPUs: 4
Deblocking Filter: checked
Video Renderer: OpenGL YV12
Deinterlacer quality (single rate): low quality
Prefer OpenGL deinterlacers: checked
Prefer driver deinterlacers: checked
Deinterlacer quality (double rate): low quality
Prefer OpenGL deinterlacers: checked
Prefer driver deinterlacers: checked

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Wed Jun 24, 2020 8:59 pm

My movies are all .mkv files and played very well under v30 with openMax profile.

I have a thumb drive setup with Libreelec Kodi and this also plays the movies even better than v30. I would like to get the mythtv setup booting straight into the frontend but so far have not been able to get this to function.

Will v30 frontend on this connect to the backend running v31?

Is there are project similar to the old mythbuntu but for raspbian os to load just the bare minimum os needed to load into mythfrontend?

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Wed Jun 24, 2020 9:30 pm

mtbdrew wrote:
Wed Jun 24, 2020 8:59 pm
Will v30 frontend on this connect to the backend running v31?

Is there are project similar to the old mythbuntu but for raspbian os to load just the bare minimum os needed to load into mythfrontend?
v30 frontend will not work with v31 backend.

get the pi-utils from https://github.com/MikeB2013/pi-utils
pi-setup_mythtv_31.sh is the command to setup the pi for mythfrontend v31 running from the command line.

I always start with Raspberry PI OS (32bit), do all the upgrades and then install using pi-setup_mythtv_31.sh I have only used the Desktop version of PI OS, but I don't know why Lite wouldn't work as well. If I can find another old rp3B+ laying around I'll test it.

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Wed Jun 24, 2020 10:07 pm

So I found an old RPi3B+ and flashed a microSD with the latest Raspberry PI OS Lite (32bit) using the new Raspberry PI Imager.
I booted it, used sudo raspi-config to set all the localization items, and then did a sudo apt update and sudo full-upgrade.

Then sudo apt install git
Then I did:
git clone https://github.com/MikeB2013/pi-utils.git
sudo apt-get install --no-install-recommends xserver-xorg
pi-utils/pi-setup_mythtv_v31.sh
reboot and it will start up in mythfrontend

If it doesn't find your database do the search at the bottom and it should connect.

I checked the audio and video settings and then it worked fine.

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Thu Jun 25, 2020 4:06 pm

Will I need to re-install the MPEG-2 License Key?

So does the pi-utils/pi-setup_mythtv_v31.sh install mythtv-light?

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Thu Jun 25, 2020 4:10 pm

mtbdrew wrote:
Thu Jun 25, 2020 4:06 pm
Will I need to re-install the MPEG-2 License Key?

So does the pi-utils/pi-setup_mythtv_v31.sh install mythtv-light?
yes

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Thu Jun 25, 2020 4:13 pm

mtbdrew wrote:
Thu Jun 25, 2020 4:06 pm
Will I need to re-install the MPEG-2 License Key?
not on a RPi3B+. It sets a bit internally when it's installed. you can check with the vcgencmd command to see if you have a license

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Thu Jun 25, 2020 4:26 pm

Cool thanks.

Besides setting the GPU memory to 256 and enabling SSH, do I need to do anything else in rasp-config like enable GL driver G2 or G3?

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Thu Jun 25, 2020 4:28 pm

The pi-setup_mythtv_v31.sh should set the 256M gpu memory and the fake GL drivers
just edit the /boot/config.txt and look at the bottom after running the script

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Thu Jun 25, 2020 4:35 pm

great thanks again.

mtbdrew
Junior
Posts: 30
Joined: Tue Jul 22, 2014 1:10 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by mtbdrew » Thu Jun 25, 2020 5:38 pm

Well that went pretty smoothly and now the V4L2 decodes work for the .mkv files. However there are a couple of issues now:

1) Screen resolution is not 1920x1080

2) De-interlacing doesn't appear to be working on the recorded TV shows.

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Thu Jun 25, 2020 6:04 pm

jfabernathy wrote:
Thu Jun 25, 2020 4:13 pm
mtbdrew wrote:
Thu Jun 25, 2020 4:06 pm
Will I need to re-install the MPEG-2 License Key?
not on a RPi3B+. It sets a bit internally when it's installed. you can check with the vcgencmd command to see if you have a license
For the record to see if you still have the MPEG-2 license do:

Code: Select all

vcgencmd codec_enabled MPG2

User avatar
jfabernathy
Senior
Posts: 245
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: RPi3 running V31 crashes with any V4L2 coding selection

Post by jfabernathy » Thu Jun 25, 2020 6:06 pm

mtbdrew wrote:
Thu Jun 25, 2020 5:38 pm
Well that went pretty smoothly and now the V4L2 decodes work for the .mkv files. However there are a couple of issues now:

1) Screen resolution is not 1920x1080

2) De-interlacing doesn't appear to be working on the recorded TV shows.
If you are using the default theme, then while playing the recorded TV show, hit 'm' for menu and then look at the playback data. Lots of data including interlacing

Post Reply