[Solved] Building Mythtv 31.x on Catalina

For discussion of topics specific to MythTV on OSX
User avatar
pvr4me
Senior
Posts: 713
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: [Solved] Building Mythtv 31.x on Catalina

Post by pvr4me » Thu May 14, 2020 2:16 pm

That too would be a markk issue. I would expect he'd want a mythfrontend log, probably with '-v playback'. Maybe the code needs a tweak to deal with Retina screens.

BTW, when I bashed my head 1.5 years ago trying to make version 29 work, there were problems with only 1/4 of the screen being displayed (cropped). Using override settings on the command line would help to get around the issue; more details at [1]. However, I believe there were others that got 29 to work without this crazy workaround. It was never clear what was different between their systems and mine. It can't hurt to try setting the GUI and Video dimensions to appropriate values for your system.

In addition, there was the problem of Myth becoming unresponsive to key strokes; requiring a mouse click to bring the window back to focus. Since then, I've noticed several code changes that might possibly be related Eg [2]. I've never tested to see if these changes help or not. You might want to read the old description and see if you can still reproduce.

[1] viewtopic.php?f=26&t=2216&start=60#p14335
[2] https://code.mythtv.org/trac/ticket/13544#comment:7

BTW, both markk and dhampton have become active in the MythTV project since I hit the wall with 29. They've both expressed that they're willing to work to keep the Mac implementation functional. This fills a big gap that was there in the 28 - 29 timeframe.

Craig
The MacPorts guy.

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Thu May 14, 2020 10:04 pm

Thanks for the links! I'll try playing around this weekend and see if I can get it working.

I'll also get around to writing a Trac Bug report once I better wrap my head around the problem.

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Fri May 15, 2020 11:42 am

@Craig, I'm going to move the screen debugging to a new thread. After playing around this AM, I suspect there is a bug (or new feature) buried somewhere.

User avatar
pvr4me
Senior
Posts: 713
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: [Solved] Building Mythtv 31.x on Catalina

Post by pvr4me » Fri May 15, 2020 1:25 pm

I saw the new thread. Symptoms are different than I previously saw but this is 2 years later.

From the log, I noticed that Myth is complaining about a missing font. I'm not quite sure where it would need to be installed in the app bundle, but Dejavu is available from MacPorts if you want:

https://ports.macports.org/port/dejavu-fonts/summary

Another one of the themes uses liberation:

https://ports.macports.org/port/liberat ... ts/summary

Craig
The MacPorts guy.

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Fri May 15, 2020 4:06 pm

Thanks Craig. I'll get them in my next ansible patch once I work through any required mods for High Sierra. So far only the fonts and libX11 are missing (and are probabaly optional to some extent).

User avatar
bill6502
Developer
Posts: 1588
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by bill6502 » Fri May 15, 2020 4:15 pm

If you need different ports added, you can make them version dependent. If you haven't
already tried: ansible --module-name setup | less shows everything available. I don't
have a minor version in *buntu, for example. Maybe there's an ansible_some_variable
that will show Catalina or High Sierra etc.

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Fri May 15, 2020 4:18 pm

Bill, I'll take a look.

Right now, the fonts and libX11 are the only items I've noticed that were different (I really thought there would be more...). The Catalina build needs the fonts where as the call to libX11 won't hurt and may fix some undiscovered "features"

User avatar
pvr4me
Senior
Posts: 713
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: [Solved] Building Mythtv 31.x on Catalina

Post by pvr4me » Fri May 15, 2020 5:38 pm

Is this the X11 missing item you're mentioning?

Code: Select all

ld: warning: directory not found for option '-L/opt/X11/lib'
Myth on macOS shouldn't need X11 at all. I think this is just an extraneous linker option that has crept in. Strangely, I checked on the 31/fixes buildbot and it does not seem to report this warning. I didn't try to investigate any further.

Craig
The MacPorts guy.

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Fri May 15, 2020 10:41 pm

It is. I added the port to ansible anyways as it was available and didn't seem to hurt anything. Bill should be pushing another ansible fix in a bit that also includes the missing fonts.

User avatar
pvr4me
Senior
Posts: 713
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Building Mythtv 31.x on Catalina

Post by pvr4me » Tue Jun 16, 2020 12:55 pm

jhoyt wrote:
Fri Apr 17, 2020 7:09 pm
...
6) The '--extra-cflags="-fno-stack-check" --extra-cxxflags="-fno-stack-check" ' is new to me. How did you determine this? What happens without?
I got these out of the ffmpeg trac. Basically compiling the latest ffmpeg causes similar "stack_not_16_byte_aligned_error" (trac.ffmpeg.org/ticket/8073). Given this and myth's use of ffmpeg code, I was hopeful for a fix. It didn't work...
FYI, I noticed that a simple change has been commited that may address the stack alignment problems you were seeing:

https://github.com/MythTV/mythtv/commit ... 894b4508f7

At the moment, it appears this has only been commited to master but it would not be hard to extract and apply in your build. ;)

Craig
The MacPorts guy.

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Tue Jun 16, 2020 1:58 pm

Craig, thanks for the heads up! I'll give it a go this weekend (busy work week).

Unfortunately my system just auto-upgraded my Xcode to 11.5 which I fear introduced some new issues. I'll have to back that out (or spin up a Catalina VM) to test.

scram69
Newcomer
Posts: 5
Joined: Mon Feb 25, 2019 4:56 am
Guinea

Re: [Solved] Building Mythtv 31.x on Catalina

Post by scram69 » Mon Jun 29, 2020 1:02 am

Just upgraded to .31, so I grabbed the most recent build from John on Sourceforge for my two frontends.
Catalina frontend: works great! Brilliant work!
High Sierra frontend: not so much. Two issues-
-Can I get rid of the Mac OS title bar at the top of the screen (i.e. run fullscreen)?
-Playback was fine on this machine under the 0.29 frontend, but is suffering now (for HD, buffer fills up in < 1 minute). What would be the recommended playback settings for 0.31 for a "low-end" (GeForce 9400) 10.13.6 machine?

Thanks-

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Tue Jun 30, 2020 9:20 am

Apologies, my systems are all running Catalina, and I only have High Sierra running via VM to compile. Unfortunately I can't reproduce either error. I'd suggest starting a new post on the forum or try the mailing list. There are quite a few folks on the mailing list that run High Sierra that may be able to help out.

scram69
Newcomer
Posts: 5
Joined: Mon Feb 25, 2019 4:56 am
Guinea

Re: [Solved] Building Mythtv 31.x on Catalina

Post by scram69 » Thu Jul 02, 2020 9:50 pm

John,
Thanks for the reply. I had been messing around with nVidia drivers, and have probably done irreversible damage, so will do a fresh install and start again. If I'm still struggling, I'll start a new thread.
Can you let me know which of the builds you have posted on sourceforge were built with High Sierra vs built with Catalina?

jhoyt
Junior
Posts: 59
Joined: Thu Aug 27, 2015 10:11 am
United States of America

Re: [Solved] Building Mythtv 31.x on Catalina

Post by jhoyt » Thu Jul 02, 2020 10:38 pm

All of the 31 builds were built on High Sierra via VM. You'll also need Xcode 10.0. The most recent version has a bunch of fixes Mark Kendal implemented to fix screen resolution issues on monitors with better than 1080p resolution. I'd suggest trying that one first.

The Nvidia drivers may be the issue - I was only testing on macs / VMs that used the intel drivers. Unfortunately I don't have anything (besides an ubuntu system) that has an nVidia card in it.

Post Reply