[solved] mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Do you want advice about what hardware to buy for use with MythTV? Ask here.

Moderator: Forum Moderators

Post Reply
jeremytourville
Newcomer
Posts: 5
Joined: Thu Nov 21, 2019 2:27 pm
United States of America

[solved] mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by jeremytourville » Thu Nov 21, 2019 3:38 pm

I built a brand new backend last night following the directions here viewtopic.php?t=3114 . I haven't loaded anything else and followed the directions from MikeB2013 verbatim.
Everything worked very smoothly and the database is up and running except getting the system to find my tuner. I am a long time user of mythtv since about .21 and mythbuntu 8. My past experience has been that it "just works" with just a little configuration in the database.

I did find some info about checking for hdhomerun support - viewtopic.php?t=3100
I will confirm that this evening, however, I presume that since I just built it, it would/should be present in my build. We'll see if my assumption is bad.

Are there any other additional steps needed?

HDHomeRun CONNECT DUO (P/N: HDHR5-2US)
Last edited by jeremytourville on Fri Nov 29, 2019 2:24 am, edited 3 times in total.

MikeB2013
Senior
Posts: 433
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by MikeB2013 » Thu Nov 21, 2019 5:15 pm

Lubuntu 18.04 with mythtv 30 from ppa:mythbuntu/30 works for me out of the box with HDHomerun Connect Quattro (Model: HDHR5-4DT, Device ID: 1251E907, Firmware: 20190621).

I presume it is mythtv-setup Capture Card that is not finding the HDhomerun device.

Probably worth checking with command line hdhomerun_config utility that your HDHomerun device is found , install it as follows:

Code: Select all

sudo apt update
sudo apt install hdhomerun-config 
then run hdhomerun_config discover

Code: Select all

mike@mike-GL62-7QF:~$ hdhomerun_config discover
hdhomerun device 1251E907 found at 192.168.0.214

There is another utility hdhomerun-config-gui which allows you to test the HDHomerun device outside of mythtv and view any channel using VLC

After the HomeRun device has been configured in mythtv-setup you may have an issue where mythbackend starts before the network is fully up (symptom is tuner error) see post https://lists.gt.net/mythtv/users/625986#625986

Mike

jeremytourville
Newcomer
Posts: 5
Joined: Thu Nov 21, 2019 2:27 pm
United States of America

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by jeremytourville » Fri Nov 22, 2019 12:21 pm

I was able to work through a few things last night. Here is what I have figured out so far.

$mythbackend --version | grep using_hdhomerun
The value is present so my assumption is correct.

hdhomerun_config utiltiy was already present
$hdhomerun_config discover
hdhomerun device 106569B4 found at 172.30.42.3

The input connections in the DB is what is making me say the card is not found.
2. Capture Cards > Card Type: HDHomerun Networked Tuner
3. Recording Profiles > Use defaults
4. Video Sources > I created "OTA" using EIT data for the sake of simplicity. I can change it later once the tuner is working.
5.Input connections >
Input Name: The only option I have is MPEG2TS.
Video Source: OTA
Scan for channels > scan "Programmer Error: No Device"

So If I recall correctly you should have two devices for each tuner listed in the DB such as:
Hdhomerun:1
HDhomerun:2
:3, :4, etc.

I did review the notes about getting the timing of services working properly. I'll work through that tonight, I simply ran out of time last evening. I am going to presume that is the issue for now. (that and the behavior observed when working with input connections) I just wanted to give a quick status update. Thanks for your input.

MikeB2013
Senior
Posts: 433
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by MikeB2013 » Fri Nov 22, 2019 12:55 pm

I can reproduce Scan for channels > scan "Programmer Error: No Device" by going into mythtv-setup>Capture Card>select HDHOMERUN>Card Type at which point you should see an option:
Use HDHomeRun <id> (type) make sure the box at right of screen is selected (tick in the box) if unchecked channel scan will fail with the "Programmer Error: No Device" message

Mike

jeremytourville
Newcomer
Posts: 5
Joined: Thu Nov 21, 2019 2:27 pm
United States of America

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by jeremytourville » Sat Nov 23, 2019 12:10 am

In Card Type I see an option for HDHomerun but I don't see <id> (type) or any sort of checkbox as you described. So once I have selected HDHomerun I see and entry [HDHomerun: } in the list of capture card devices.

Like I was trying to say earlier, (and if I remember correctly) you should see :1 :2 for each individual tuner. I don't see anything except [HDHomerun: ] Anything after the colon is blank. It's sort of like finding the parent device and not the child devices (where anything before the colon is the parent and anything after is a child device) if that makes sense.

:)

jeremytourville
Newcomer
Posts: 5
Joined: Thu Nov 21, 2019 2:27 pm
United States of America

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by jeremytourville » Sat Nov 23, 2019 1:30 am

I did one additional test and ran the setup configuration on my Windows machine. I was able to scan for channels, etc. After that I want back to mythtv backend and tried to add the tuner. I still got the same results.

MikeB2013
Senior
Posts: 433
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by MikeB2013 » Sat Nov 23, 2019 7:34 pm

jeremytourville wrote:
Sat Nov 23, 2019 12:10 am
In Card Type I see an option for HDHomerun but I don't see <id> (type) or any sort of checkbox as you described. So once I have selected HDHomerun I see and entry [HDHomerun: } in the list of capture card devices.

Like I was trying to say earlier, (and if I remember correctly) you should see :1 :2 for each individual tuner. I don't see anything except [HDHomerun: ] Anything after the colon is blank. It's sort of like finding the parent device and not the child devices (where anything before the colon is the parent and anything after is a child device) if that makes sense.

:)
When Card Type is displayed try using right arrow key, the screen should show > which indicates further settings are available (this is a User Interface change starting at mythtv 29 (earlier versions of mythtv had a different used a different interface, I remember the new interface took a little getting used to when coming from the earlier version). The various screen shots in the mythtv wiki have yet to be updated to show the revised User Interface.

Also the way HDHomeRuns are configured has changed due the implementation of tuner pooling see https://github.com/MythTV/mythtv/commit/57a0ad8

jeremytourville
Newcomer
Posts: 5
Joined: Thu Nov 21, 2019 2:27 pm
United States of America

Re:[SOLVED] mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by jeremytourville » Tue Nov 26, 2019 11:47 pm

That's it! I got it to work. The new user interface threw me for a loop. Everything is working as expected now. Thanks! :D

User avatar
Steve Goodey
Moderator
Posts: 90
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: mythtv v30 & HDHR5-2US running on Lubuntu 18.04.3 LTS

Post by Steve Goodey » Wed Nov 27, 2019 7:20 am

Hello,

If you're happy with the fix could you possibly added [Solved] to the subject line in the first post?

Ta.

Post Reply