Kubuntu 19.10 upgrade breaks mysql/mariadb

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
halucigenia
Junior
Posts: 92
Joined: Tue Nov 11, 2014 11:03 am
Great Britain

Kubuntu 19.10 upgrade breaks mysql/mariadb

Post by halucigenia » Tue Oct 29, 2019 3:49 pm

Hi, I have just upgraded my master backend to Kubuntu 19.10 and it seems to brake mysql/mariadb so I can't get my mythconverg database running.
Any Ideas, anyone?

halucigenia
Junior
Posts: 92
Joined: Tue Nov 11, 2014 11:03 am
Great Britain

Re: Kubuntu 19.10 upgrade breaks mysql/mariadb

Post by halucigenia » Tue Oct 29, 2019 7:16 pm

Well, I have managed to uninstall and reinstall mariadb with some dificulty because of dependencies. I had to uninstall and reinstall mythtv amongst other things.
Back to the same issue of not being able to start the service.

Code: Select all

sudo systemctl start mariadb.service
Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xe" for details.

Code: Select all

sudo systemctl status mariadb.service
Failed to start MariaDB 10.3.17 database server.

Code: Select all

journalctl -xe
The unit mariadb.service has entered the 'failed' state with result 'exit-code'.
Oct 29 19:11:51 kb01 systemd[1]: Failed to start MariaDB 10.3.17 database server.
-- Subject: A start job for unit mariadb.service has failed
-- Defined-By: systemd

User avatar
bill6502
Developer
Posts: 1367
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Kubuntu 19.10 upgrade breaks mysql/mariadb

Post by bill6502 » Wed Oct 30, 2019 2:36 am

Maybe /var/log/mysql/error.log will have more details on the job that failed.

halucigenia
Junior
Posts: 92
Joined: Tue Nov 11, 2014 11:03 am
Great Britain

Re: Kubuntu 19.10 upgrade breaks mysql/mariadb

Post by halucigenia » Wed Oct 30, 2019 11:48 am

Thanks bill6502 I did check /var/log/mysql/error.log but it did not help much.

Eventually, after a bit more un-installing, purging of various dependencies and re-installing of mariadb and running 'sudo mysql_secure_installation' (at first that would not even run) I did get it working.

Post Reply