[Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
jweida
Newcomer
Posts: 2
Joined: Sat Sep 07, 2019 9:24 pm
United States of America

[Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by jweida » Sat Sep 07, 2019 9:58 pm

I’ve been using MythTV for 11 years and it’s been great. Thanks to all who have contributed to this truly amazing project. Through MythTV I have learned a lot about linux, networking, OTA broadcasting, database and system migration, virtual machines, headless servers…. It’s been a great hobby with practical results. This one has me stumped today.

Summary: I deleted and re-configured capture cards, now I have no guide data or scheduled recording capability.

Detail: There is an OTA channel lineup update yesterday in my market (Atlanta), so I was trying to re-scan to ensure any channel changes were captured. At least one channel has changed frequencies (WSB 39->32), I think there are others as well. I also recently upgraded from .27 to .30 a week ago, which went fine and the system has been fine in the interim.
First thing I tried was to enter mythtv-setup->5. Input Connections-><input connection>-> Scan. This didn’t appear to work, and my first round of googling led me to believe the best course of action was to start from scratch, given my recent update and all. So, in mythtv-setup, I did the following:
  • 2. Capture Cards > “(Delete all capture cards)”
  • 4. Video Sources > “(Delete all video sources)”
  • 5. Input connections > verified it was empty
I figure here I am at a clean point to re-run the setup now. So I did this:
  • 2. Capture Cards > “(New capture card)”>”HDHomeRun networked tuner”>tick the box next to “Use HDHomeRun nnnnnnnn (hdhomerun_atsc xxx.yyy.1.60”)>untick the box under Recording options for active EIT scan.
    Repeated the step above for the second tuner in the HDHR, so now I have two identical entries under 2. Capture Cards. (NOTE: This is a change from how it worked in .27 where each tuner gets an index after the serial number of the HDHR, but this appears to be design intent now).
  • 3. Recording Profiles>verified the HDHomeRun shows up as a recorder, did not change any settings.
  • 4. Video Sources > “(New video source)” > set up the new source for Schedules Direct, named it “SchedDirect”
  • 5. Input Connections > Select first entry
    Input Name: Press ENTER and select the only choice: “MPEG2TS”
    Display name (optional): empty
    Video Source: Press ENTER and select the only choice: “SchedDirect”
    Scan for channels > Scan … wait for scan to complete, found expected channels (including the updated one)
    Fetch channels from listings source: Press ENTER but there is no user visible response
    Starting channel is auto populated to 2_1
    Interactions between inputs > set Max recordings to 2 (so this tuner can record on the same transport)
    Back out to 5. Input Connections > repeat above for the second entry
  • 6. Channel Editor > verified all my expected channels appear with “SchedDirect” as the video source.
    Exit mythtv-setup, say yes to the prompt “would you like to run mythfilldatabase?”
    At this point, it seems like everything went well. But after mythfilldatabase completes, I navigate to mythweb and I get no guide data under listings. I’ve repeated the process 3 times, with a variance or two here and there, rebooted the server, but each time, I get the same result. Anyone have any pointers as to where to begin diagnosing this one?

Code: Select all

jweida@mythbackend:~$ mythutil --version
Please attach all output as a file in bug reports.
MythTV Version : v30.0
MythTV Branch :
Network Protocol : 91
Library API : 30.20181231-1
QT Version : 5.9.5
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_vbox using_ceton using_hdpvr using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl using_opengl_video using_opengl_themepainter using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_x11 using_xnvctrl using_xnvctrl_external using_libbluray_external using_xrandr using_xv using_profiletype using_systemd_notify using_systemd_journal using_bindings_perl using_bindings_python using_bindings_php using_freetype2 using_mythtranscode using_opengl using_vaapi using_vaapi2 using_vdpau using_ffmpeg_threads using_mheg using_libass using_libxml2 using_libmp3lame

Code: Select all

jweida@mythbackend:~$ mythfilldatabase
2019-09-07 17:28:05.645394 C  mythfilldatabase version:  [v30.0] 
2019-09-07 17:28:05.645410 C  Qt version: compile: 5.9.5, runtime: 5.9.5
2019-09-07 17:28:05.645414 N  Enabled verbose msgs:  general
2019-09-07 17:28:05.645423 N  Setting Log Level to LOG_INFO
2019-09-07 17:28:05.656757 I  Setup Interrupt handler
2019-09-07 17:28:05.656766 I  Setup Terminated handler
2019-09-07 17:28:05.656774 I  Setup Segmentation fault handler
2019-09-07 17:28:05.656783 I  Setup Aborted handler
2019-09-07 17:28:05.656787 I  Setup Bus error handler
2019-09-07 17:28:05.656793 I  Setup Floating point exception handler
2019-09-07 17:28:05.656797 I  Setup Illegal instruction handler
2019-09-07 17:28:05.656804 I  Setup Real-time signal 0 handler
2019-09-07 17:28:05.656808 I  Setup Hangup handler
2019-09-07 17:28:05.656894 N  Using runtime prefix = /usr
2019-09-07 17:28:05.656899 N  Using configuration directory = /home/jweida/.mythtv
2019-09-07 17:28:05.656944 I  Assumed character encoding: en_US.UTF-8
2019-09-07 17:28:05.657194 I  Empty LocalHostName. This is typical.
2019-09-07 17:28:05.657198 I  Using a profile name of: 'mythbackend' (Usually the same as this host's name.)
2019-09-07 17:28:05.657254 I  Start up testing connections. DB localhost, BE , attempt 0, status dbAwake, Delay: 2000
2019-09-07 17:28:05.657786 I  Added logging to the console
2019-09-07 17:28:06.677562 N  Setting QT default locale to en_US
2019-09-07 17:28:06.677572 I  Current locale en_US
2019-09-07 17:28:06.677615 N  Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
2019-09-07 17:28:06.685079 I  Loading en_us translation for module mythfrontend
2019-09-07 17:28:06.687066 I  Current MythTV Schema Version (DBSchemaVer): 1350
2019-09-07 17:28:06.689977 I  MythCoreContext::ConnectCommandSocket(): Connecting to backend server: 192.168.1.200:6543 (try 1 of 1)
2019-09-07 17:28:06.691483 I  MythCoreContext::CheckProtoVersion(): Using protocol version 91 BuzzOff
2019-09-07 17:28:06.691939 I  Opening blocking connection to master backend
2019-09-07 17:28:06.693251 I  Updating source #1 (SchedDirect) with grabber schedulesdirect1
2019-09-07 17:28:06.693560 I  No channels are configured to use grabber.
2019-09-07 17:28:06.693628 I
2019-09-07 17:28:06.693633 I  Checking day @ offset 0, date: Sat Sep 7 2019
2019-09-07 17:28:06.694278 I  Data refresh needed because no data exists for day @ offset 0 from 8PM - midnight.
2019-09-07 17:28:06.694282 N  Refreshing data for Sat Sep 7 2019
2019-09-07 17:28:06.695671 I  Retrieving datadirect data.
2019-09-07 17:28:06.695707 I  Grabbing data for Sat Sep 7 2019 offset 0
2019-09-07 17:28:06.695718 I  From 2019-09-07T00:00:00Z to 2019-09-08T00:00:00Z (UTC)
2019-09-07 17:28:06.695737 I  DataDirect: Grabbing listing data
2019-09-07 17:28:06.695855 I  Downloading DataDirect feed
2019-09-07 17:28:10.398446 I  Downloaded 274466 bytes
2019-09-07 17:28:10.398458 I  Uncompressing DataDirect feed
2019-09-07 17:28:10.418157 I  Uncompressed to 2273578 bytes
2019-09-07 17:28:10.418168 I  Writing to temporary file: [/tmp/mythtv_ddp_xP67wt/mythtv_ddp_zOrOgY]
2019-09-07 17:28:10.429373 I  New static DB connectionDataDirectCon
2019-09-07 17:28:10.481664 I  DataDirect: Your subscription expires on Fri Apr 10 2020 3:51 PM
2019-09-07 17:28:10.528981 I  DataDirect: sourceid 1 has lineup type: LocalBroadcast
2019-09-07 17:28:13.993868 I  Grab complete.  Actual data from 2019-09-07T00:00:00Z to 2019-09-08T00:00:00Z (UTC)
2019-09-07 17:28:13.994441 I  Main temp tables populated.
2019-09-07 17:28:13.994443 I  Updating MythTV channels.
2019-09-07 17:28:14.154927 I  Channels updated.
2019-09-07 17:28:14.222940 I  Did not find any new program data.
2019-09-07 17:28:14.222969 I
2019-09-07 17:28:14.222975 I  Checking day @ offset 1, date: Sun Sep 8 2019
2019-09-07 17:28:14.222977 I  Data Refresh always needed for tomorrow
2019-09-07 17:28:14.222979 N  Refreshing data for Sun Sep 8 2019
2019-09-07 17:28:14.223959 I  Retrieving datadirect data.
2019-09-07 17:28:14.223966 I  Grabbing data for Sat Sep 7 2019 offset 1
2019-09-07 17:28:14.223973 I  From 2019-09-08T00:00:00Z to 2019-09-09T00:00:00Z (UTC)
2019-09-07 17:28:14.223981 I  DataDirect: Grabbing listing data
2019-09-07 17:28:14.223997 I  Downloading DataDirect feed
2019-09-07 17:28:16.234359 I  Downloaded 258412 bytes
2019-09-07 17:28:16.234370 I  Uncompressing DataDirect feed
2019-09-07 17:28:16.252151 I  Uncompressed to 2160070 bytes
2019-09-07 17:28:16.252161 I  Writing to temporary file: [/tmp/mythtv_ddp_xP67wt/mythtv_ddp_zOrOgY]
2019-09-07 17:28:16.302580 I  DataDirect: Your subscription expires on Fri Apr 10 2020 3:51 PM
2019-09-07 17:28:19.580894 I  Grab complete.  Actual data from 2019-09-08T00:00:00Z to 2019-09-09T00:00:00Z (UTC)
2019-09-07 17:28:19.581421 I  Main temp tables populated.
2019-09-07 17:28:19.627155 I  Did not find any new program data.
2019-09-07 17:28:19.627176 I
2019-09-07 17:28:19.627181 I  Checking day @ offset 2, date: Mon Sep 9 2019
2019-09-07 17:28:19.627676 I  Data refresh needed because no data exists for day @ offset 2 from 8PM - midnight.
2019-09-07 17:28:19.627680 N  Refreshing data for Mon Sep 9 2019
2019-09-07 17:28:19.628612 I  Retrieving datadirect data.
2019-09-07 17:28:19.628619 I  Grabbing data for Sat Sep 7 2019 offset 2
2019-09-07 17:28:19.628626 I  From 2019-09-09T00:00:00Z to 2019-09-10T00:00:00Z (UTC)
2019-09-07 17:28:19.628659 I  DataDirect: Grabbing listing data
2019-09-07 17:28:19.628677 I  Downloading DataDirect feed
2019-09-07 17:28:22.038193 I  Downloaded 270932 bytes
2019-09-07 17:28:22.038204 I  Uncompressing DataDirect feed
2019-09-07 17:28:22.056268 I  Uncompressed to 2305550 bytes
2019-09-07 17:28:22.056279 I  Writing to temporary file: [/tmp/mythtv_ddp_xP67wt/mythtv_ddp_zOrOgY]
2019-09-07 17:28:22.124896 I  DataDirect: Your subscription expires on Fri Apr 10 2020 3:51 PM
2019-09-07 17:28:25.670598 I  Grab complete.  Actual data from 2019-09-09T00:00:00Z to 2019-09-10T00:00:00Z (UTC)
2019-09-07 17:28:25.671131 I  Main temp tables populated.
2019-09-07 17:28:25.720108 I  Did not find any new program data.
2019-09-07 17:28:25.720135 I
2019-09-07 17:28:25.720140 I  Checking day @ offset 3, date: Tue Sep 10 2019
2019-09-07 17:28:25.720676 I  Data refresh needed because no data exists for day @ offset 3 from 8PM - midnight.
…. Identical repeats here for days 4-12 ….
2019-09-07 17:29:22.744919 I  Checking day @ offset 13, date: Fri Sep 20 2019
2019-09-07 17:29:22.745474 I  Data refresh needed because no data exists for day @ offset 13 from 8PM - midnight.
2019-09-07 17:29:22.745477 N  Refreshing data for Fri Sep 20 2019
2019-09-07 17:29:22.746454 I  Retrieving datadirect data.
2019-09-07 17:29:22.746461 I  Grabbing data for Sat Sep 7 2019 offset 13
2019-09-07 17:29:22.746469 I  From 2019-09-20T00:00:00Z to 2019-09-21T00:00:00Z (UTC)
2019-09-07 17:29:22.746477 I  DataDirect: Grabbing listing data
2019-09-07 17:29:22.746494 I  Downloading DataDirect feed
2019-09-07 17:29:24.351487 I  Downloaded 249267 bytes
2019-09-07 17:29:24.351498 I  Uncompressing DataDirect feed
2019-09-07 17:29:24.367265 I  Uncompressed to 2206598 bytes
2019-09-07 17:29:24.367277 I  Writing to temporary file: [/tmp/mythtv_ddp_xP67wt/mythtv_ddp_zOrOgY]
2019-09-07 17:29:24.425888 I  DataDirect: Your subscription expires on Fri Apr 10 2020 3:51 PM
2019-09-07 17:29:28.024702 I  Grab complete.  Actual data from 2019-09-20T00:00:00Z to 2019-09-21T00:00:00Z (UTC)
2019-09-07 17:29:28.025225 I  Main temp tables populated.
2019-09-07 17:29:28.071162 I  Did not find any new program data.
2019-09-07 17:29:28.071500 E  Failed to fetch some program info
2019-09-07 17:29:28.071510 I  Adjusting program database end times.
2019-09-07 17:29:28.071646 I      0 replacements made
2019-09-07 17:29:28.071649 I  Marking generic episodes.
2019-09-07 17:29:28.071900 I      Found 0
2019-09-07 17:29:28.071903 I  Extending non-unique programids with multiple parts.
2019-09-07 17:29:28.072200 I      Found 0
2019-09-07 17:29:28.072203 I  Fixing missing original airdates.
2019-09-07 17:29:28.072714 I      Found 0 with programids
2019-09-07 17:29:28.073135 I      Found 0 without programids
2019-09-07 17:29:28.073138 I  Marking repeats.
2019-09-07 17:29:28.073856 I      Found 0
2019-09-07 17:29:28.073860 I  Unmarking new episode rebroadcast repeats.
2019-09-07 17:29:28.074077 I      Found 0
2019-09-07 17:29:28.074230 I  Marking episode first showings.
2019-09-07 17:29:28.074863 I      Found 0
2019-09-07 17:29:28.074867 I  Marking episode last showings.
2019-09-07 17:29:28.075538 I      Found 0
2019-09-07 17:29:28.076781 I  DataDirect: Grabbing next suggested grabbing time
2019-09-07 17:29:28.478892 I  Suggested Time data: 613 bytes
2019-09-07 17:29:28.482322 I  DataDirect: BlockedTime is: 2019-09-07T22:29:28Z
2019-09-07 17:29:28.482436 I  DataDirect: nextSuggestedTime is: 2019-09-08T22:46:28Z
2019-09-07 17:29:28.484259 I
===============================================================
| Attempting to contact the master backend for rescheduling.  |
| If the master is not running, rescheduling will happen when |
| the master backend is restarted.                            |
===============================================================
2019-09-07 17:29:28.488423 N  mythfilldatabase run complete.
2019-09-07 17:29:28.488492 I  Waiting for threads to exit.
Ubuntu Server 18.04.3 LTS on VMWare Windows 10 host
2 TB RAID2 Windows share,HD Homerun Dual,Raspberry Pi 4 (mythtv-light)

jweida
Newcomer
Posts: 2
Joined: Sat Sep 07, 2019 9:24 pm
United States of America

Re: Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by jweida » Sun Sep 08, 2019 7:01 pm

OK, after some more searching, it looks like by updating my system to use XMLTV instead of the old Schedules Direct Data Direct method that's built in to mythtv I am now able to get guide data. For others reference, I used this wiki page (wiki/XMLTV#Schedules_Direct_Setup). There's a lot of info there, but after I parsed through it, here's my distilled version of instructions:
  • XMLTV via Schedules Direct is now the preferred way to do things. As of v30.0, it’s not included by default in the mythtv package. Do the following:

    Code: Select all

    apt install xmltv
  • Configure xmltv “Schedules Direct JSON API” via the command line (using instructions on wiki at wiki/XMLTV#Setup_with_tv_grab_zz_sdjson). I picked the JSON API over the Multinational since it appears simpler. I looked at configuring via mythtv-setup, but it was not smooth since you need to interact. Instead, use this command line:

    Code: Select all

    tv_grab_zz_sdjson --configure --config-file $HOME/.mythtv/<name of source>.xmltv
    <name of source> is whatever you selected in mythtv-setup for the video source name.
    Go through the setup prompts. You’ll have to login and add a lineup. Since I'm OTA only, I selected antenna for my region. I added the entire lineup vs. individual channels.
  • Once you're finished configuring the sdjson grabber, run mythtv-setup to link it as your video source:
    "4. Video Sources" > <name of source> > Listings grabber: Schedules Direct JSON API (xmltv)
  • Say yes to run mythfilldatabase when exiting mythtv-setup. It took my system over 5 minutes to complete, it looked like it was hanging on writing data to the <name of source>.xmltv, but it eventually finished. I got loads of errors about “Unknown xmltv channel identifier”. Haven’t yet diagnosed this, but I did end up with a full listings data!
Hopfully this helps save someone some time.
Ubuntu Server 18.04.3 LTS on VMWare Windows 10 host
2 TB RAID2 Windows share,HD Homerun Dual,Raspberry Pi 4 (mythtv-light)

User avatar
bill6502
Developer
Posts: 1438
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by bill6502 » Sun Sep 08, 2019 7:23 pm

Thanks for posting your solution.

The key line in the log contained: '... No channels are configured to use grabber.' and happens
when no xmltvid exists in the channel table.

Note that in v31, DataDirect support will be removed. https://www.mythtv.org/wiki/Release_Not ... or_Changes
(and it's already been removed in v31-Pre.)

cerickson
Newcomer
Posts: 4
Joined: Sun Aug 20, 2017 11:02 pm
United States of America

Re: [Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by cerickson » Fri Sep 20, 2019 7:46 pm

Is DataDirect the same as Schedules Direct? Why would that be removed? It is so much easier than xmltv.

User avatar
bill6502
Developer
Posts: 1438
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: [Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by bill6502 » Fri Sep 20, 2019 8:12 pm

Both DataDirect and tv_grab_zz_sdjson_sqlite (for example) get information from
SchedulesDirect, just in different formats.

The grabber provides more days (right now I have 17) and channel icons.

DataDirect is the odd-man-out as other sources use grabbers. Doesn't make sense
maintaining the extra code (not that it's mine, but I agree with the others.)

mathog
Junior
Posts: 69
Joined: Thu Dec 15, 2016 5:22 pm
United States of America

Re: [Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by mathog » Sun Feb 16, 2020 6:16 am

I hit this problem today. The system is updated from time to time but I had not run a channel scan in nearly a year. After doing so mythfilldatabase ran but the program guide and program selector were completely empty. Looking at the mythfilldatabase log file there was "no channels are configured to use grabber". So after futzing around for a while I found this thread. Unfortunately nothing has worked yet to resolve it. This is mythtv 30.

apt install xmltv
tv_grab_zz_sdjson --configure --config-file ~USERNAME/.mythtv/sd.xmltv
1 (date and time)
sd_username
sd_password
add
USA
zip
32 (antenna)
lineups
yes

after the password in the file created it had:

Code: Select all

mode=lineup
lineup=USA-OTA-91006
Note, it saves the password in plain text in the file. Not such great security, but pressing on...

mythtv-setup
video source
delete source (sd)
add source
sd
schedules direct JSON API (xmltv)
chan freq table: us-bcast
network id: -1

channels
delete
video source sd
scan (finds a bunch)

exit

Note, while exit from the menu options to the main menu works, exit from mythtv-setup itself hangs if I make any changes at all. This is being viewed over ssh/X11 on another machine. This locks the screen on the other machine, essentially, but alt-F1 lets me open a terminal, login, and kill the mythtv-setup process to regain control.

mythfilldatabase
still has "no channels are configured for grabber" but it runs for a long time grabbing things.

Exit mythfrontend, restart mythfrontend, go to program guide. channels are there but no scheduling information. The program listing is also empty. Select a channel in the guide and the current time slot and it can be watched.

Try running tv_grab_zz_sdjson again. This time instead of antenna select channels and then all. Run mythtv-setup again but channel editor has scan greyed out. Back out and in from mythfrontend and this time the guide has no channels either!
The resulting file has after passwords these records:

the sd.xmltv has after password these records

Code: Select all

mode=channels
channels=USA-OTA-91006
channel=19567
channel=88571
channel=112431
...
channel=88582
Here is part of the mythfilldatabase log using the downloaded channels:

Code: Select all

2020-02-15 21:49:35.229160 C  mythfilldatabase version:  [v30.0] www.mythtv.org
2020-02-15 21:49:35.229212 C  Qt version: compile: 5.9.5, runtime: 5.9.5
2020-02-15 21:49:35.229227 N  Enabled verbose msgs:  general
2020-02-15 21:49:35.229249 N  Setting Log Level to LOG_INFO
2020-02-15 21:49:35.241982 I  Setup Interrupt handler
2020-02-15 21:49:35.242016 I  Setup Terminated handler
2020-02-15 21:49:35.242050 I  Setup Segmentation fault handler
2020-02-15 21:49:35.242072 I  Setup Aborted handler
2020-02-15 21:49:35.242102 I  Setup Bus error handler
2020-02-15 21:49:35.242123 I  Setup Floating point exception handler
2020-02-15 21:49:35.242153 I  Setup Illegal instruction handler
2020-02-15 21:49:35.242192 I  Setup Real-time signal 0 handler
2020-02-15 21:49:35.242373 I  Setup Hangup handler
2020-02-15 21:49:35.242486 I  Added logging to the console
2020-02-15 21:49:35.242863 N  Using runtime prefix = /usr
2020-02-15 21:49:35.242892 N  Using configuration directory = /home/david/.mythtv
2020-02-15 21:49:35.243175 I  Assumed character encoding: en_US.UTF-8
2020-02-15 21:49:35.246807 I  Empty LocalHostName. This is typical.
2020-02-15 21:49:35.246857 I  Using a profile name of: 'mediahog' (Usually the same as this host's name.)
2020-02-15 21:49:35.247280 I  Start up testing connections. DB localhost, BE , attempt 0, status dbAwake, Delay: 2000
2020-02-15 21:49:36.287573 N  Setting QT default locale to en_US
2020-02-15 21:49:36.287608 I  Current locale en_US
2020-02-15 21:49:36.287723 N  Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
2020-02-15 21:49:36.302201 I  Loading en_us translation for module mythfrontend
2020-02-15 21:49:36.305854 I  Current MythTV Schema Version (DBSchemaVer): 1350
2020-02-15 21:49:36.310697 I  MythCoreContext::ConnectCommandSocket(): Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
2020-02-15 21:49:36.314185 I  MythCoreContext::CheckProtoVersion(): Using protocol version 91 BuzzOff
2020-02-15 21:49:36.315175 I  Opening blocking connection to master backend
2020-02-15 21:49:36.318456 I  Updating source #1 (sd) with grabber tv_grab_zz_sdjson
2020-02-15 21:49:36.319245 I  No channels are configured to use grabber.
2020-02-15 21:49:36.331743 I  Starting IO manager (write)
2020-02-15 21:49:36.331931 I  Starting process signal handler
2020-02-15 21:49:36.332106 I  Starting IO manager (read)
2020-02-15 21:49:36.332230 I  Starting process manager
2020-02-15 21:49:37.534570 I  Grabber has capabilities: baseline manualconfig preferredmethod 
2020-02-15 21:49:38.786568 I  Grabber prefers method: allatonce
2020-02-15 21:49:38.790066 I  XMLTV config file is: /home/david/.mythtv/sd.xmltv
2020-02-15 21:55:38.047249 I  New static DB connectionDataDirectCon
2020-02-15 21:55:56.334856 N  Unknown xmltv channel identifier: I100092.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.335753 N  Unknown xmltv channel identifier: I100352.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.336373 N  Unknown xmltv channel identifier: I101396.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.336964 N  Unknown xmltv channel identifier: I101397.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.337648 N  Unknown xmltv channel identifier: I101974.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.338227 N  Unknown xmltv channel identifier: I102014.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.339733 N  Unknown xmltv channel identifier: I105925.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.340092 N  Unknown xmltv channel identifier: I105926.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.340454 N  Unknown xmltv channel identifier: I106857.json.schedulesdirect.org - Skipping channel.
...
2020-02-15 21:55:56.449040 N  Unknown xmltv channel identifier: I99836.json.schedulesdirect.org - Skipping channel.
2020-02-15 21:55:56.449067 I  Updated programs: 0 Unchanged programs: 0
2020-02-15 21:55:57.967804 I  Updating source #2 () with grabber schedulesdirect1
2020-02-15 21:55:57.968798 I  No channels are configured to use grabber.
2020-02-15 21:55:57.974685 I  
2020-02-15 21:55:57.974741 I  Checking day @ offset 0, date: Sun Feb 16 2020
2020-02-15 21:55:58.000049 I  Data refresh needed because no data exists for day @ offset 0 from 8PM - midnight.
2020-02-15 21:55:58.000107 N  Refreshing data for Sun Feb 16 2020
2020-02-15 21:55:58.081689 I  Retrieving datadirect data.
2020-02-15 21:55:58.081764 I  Grabbing data for Sun Feb 16 2020 offset 0
2020-02-15 21:55:58.082193 I  From 2020-02-16T00:00:00Z to 2020-02-17T00:00:00Z (UTC)
2020-02-15 21:55:58.101722 I  DataDirect: Grabbing listing data
...
2020-02-15 21:55:57.974741 I  Checking day @ offset 0, date: Sun Feb 16 2020
2020-02-15 21:55:58.000049 I  Data refresh needed because no data exists for day @ offset 0 from 8PM - midnight.
2020-02-15 21:55:58.000107 N  Refreshing data for Sun Feb 16 2020
2020-02-15 21:55:58.081689 I  Retrieving datadirect data.
2020-02-15 21:55:58.081764 I  Grabbing data for Sun Feb 16 2020 offset 0
2020-02-15 21:55:58.082193 I  From 2020-02-16T00:00:00Z to 2020-02-17T00:00:00Z (UTC)
2020-02-15 21:55:58.101722 I  DataDirect: Grabbing listing data
2020-02-15 21:55:58.122106 I  Downloading DataDirect feed
2020-02-15 21:55:59.748883 E  DataDirect: Failed to get data: Download error
2020-02-15 21:55:59.749279 E  Encountered error in grabbing data.
I tried running the mysql_table.sh script and it didn't find any errors.
The "Failed to get data: Download error" suggested a username/password problem, but I cut and pasted from the sd.xml to schedulesdirect login page and they worked.

In short, this mythtv configuration seems to be royally hosed. I'm going to update everything (in case it is some odd library mismatch), reboot and try again using the antenna setting for the grabber.

In the meantime, can anybody suggest a way to get out of this mess???

Thanks.

mathog
Junior
Posts: 69
Joined: Thu Dec 15, 2016 5:22 pm
United States of America

Re: [Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by mathog » Sun Feb 16, 2020 7:20 am

Well this is odd:

Code: Select all

mysql --host=localhost --user=mythtv --password mythconverg --execute="SELECT sourceid,name,xmltvgrabber,userid,password FROM videosource"
Enter password: 
+----------+------+-------------------+--------+----------+
| sourceid | name | xmltvgrabber      | userid | password |
+----------+------+-------------------+--------+----------+
|        1 | sd   | tv_grab_zz_sdjson |        | NULL     |
|        2 |      | schedulesdirect1  |        | NULL     |
+----------+------+-------------------+--------+----------+
First it does not seem to have a userid/password for sd. Second it has a 2nd sourceid when one does not appear in in mythtv-setup.

Fir the sd line userid/password should match those for the SchedulesDirect account, yes? They are in the sd.xmltv file, but were not apparently entered into the database by the script that made that.

mathog
Junior
Posts: 69
Joined: Thu Dec 15, 2016 5:22 pm
United States of America

Re: [Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by mathog » Sun Feb 16, 2020 8:33 am

OK, I see part of this. Previously root or my user account could be used interchangeably with mythfilldatabase. That is no longer true. The grabber was set up for the user account and so when mythfilldatabase is now run as root it doesn't have the SD login credentials. Did this from the user account:

Code: Select all


cd 
mkdir hold
cd hold
~/hold$ /usr/bin/perl -w /usr/bin/tv_grab_zz_sdjson --config-file /home/david/.mythtv/sd.xmltv --output myth_from_sd
Name "Params::Validate::NO_VALIDATION" used only once: possible typo at /usr/bin/tv_grab_zz_sdjson line 238.
Initializing...
** POST https://json.schedulesdirect.org/20141201/token ==> 200 OK
** GET https://json.schedulesdirect.org/20141201/status ==> 200 OK (1s)
Updating lineups...
Indexing channels...
Updating schedules...
** POST https://json.schedulesdirect.org/20141201/schedules/md5 ==> 200 OK (77s)
Updating programs...
Removing old cache entries...
Writing output...
Done
That file holds what appears to be valid channel and lineup info.

Now run mythfilldatabase on it (as root)

Code: Select all

mythfilldatabase --file --sourceid 1 --xmlfile myth_from_sd -v most 2>&1 | tee md2.log
and that is logging reasonable looking messages like:

Code: Select all

2020-02-16 00:28:49.122773 I  Inserting new program    : 2020-03-03T13:30:00Z - 2020-03-03T14:00:00Z I43286.json.schedulesdirect.org Dragnet
So there were apparently (at least) two problems:

1. run as root failed XML download due to lack of credentials.
2. subsequent part of mythfilldatabase failed to load a downloaded xml from the user account..

I have not yet run the 2nd one separately, but since the grabber worked from that account it pretty much has to be the case.

When mythtv runs the backend belongs to user "mythtv" and everything else belongs to my user account. When mythtv automatically runs the SD grabber which account will it be using? If it is "mythtv" that will fail because it won't have the sd.xmltv file, and if my user account it will fail because for some reason the 2nd have of mythfilldatabase won't run.

Yes, my user account is in the mythtv group.

mythfilldatabase is still running, but there are now programs in the program guide. So some progress.

mathog
Junior
Posts: 69
Joined: Thu Dec 15, 2016 5:22 pm
United States of America

Re: [Solved] Re-scan with clean setup under .30 -> "NO DATA" in guide

Post by mathog » Sun Feb 16, 2020 10:16 pm

Yesterday all the 13.* channels (including KCOP) were not scanning with those names on either the TV or in MythTV. Some of them were found, but they were strange somehow and were not identifiable. Today they are back in both of those scans. In my user account (not root) did

Code: Select all

mythtv-setup
channel editor
scan
#(accept changes)
#this time it exited normally, which it was not doing yesterday
#mythbackend is running, ownership is mythtv
mythfilldatabase
# in the log file it now says:
2020-02-16 13:53:29.067817 I  Found 120 channels for source 1 which use grabber
So for completely unknown reasons the "no channels are configured for grabber"" message is gone and the mythfilldatabase worked normally. The 13.* stations now show the right names and have programming information.

So I really don't know what was going on yesterday but the database updates are working now using the json grabber.

In other news, the channel up/down buttons were not jumping up and down a page at at time in the Program Guide yesterday, but they are once again doing so now.

I think this box may have gremlins. Anyway, it seems to be working again. I have a sneaking suspicion that I could have skipped doing all the work yesterday, waited 24 hours, and it would have cleaned itself up.

Post Reply