Mythweb CONTENT_LENGTH_MISMATCH

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
mred
Newcomer
Posts: 2
Joined: Sat Aug 31, 2019 10:08 am
France

Mythweb CONTENT_LENGTH_MISMATCH

Post by mred » Sat Aug 31, 2019 11:20 am

Hello,

I recently upgrade mythweb to 29.1+git.20180525.6a6eb1a4-lp151.1.1 (opensuse 15.1).
Now, when I connect to mythweb, I got (in the browser console) ERR_CONTENT_LENGTH_MISMATCH. It's funny because when I connect to my web server (apache 2.4) through https, everything is OK. Situation in http gone better when I include deflate.
So it seems the parameter CONTENT_LENGTH in the http header is not correctly set and when data are encoded or deflated, this header is reset to a right value. Of course png/jpg files are not deflated so the result is, with deflate on, I don't have any icon on the pages :-(.
Same issue with opera and firefox. I use php 7.2.5.

To sum up, I think CONTENT_LENGTH is wrongly set by mythweb.

Can somebody help me?
It could be related to the "foreach()" error wich appear since a long time or a module in php or apache I didn't load...

KR,
MrEd

mred
Newcomer
Posts: 2
Joined: Sat Aug 31, 2019 10:08 am
France

Re: Mythweb CONTENT_LENGTH_MISMATCH

Post by mred » Wed Sep 11, 2019 5:32 am

Hello,

Unfortunately (or not :lol: ) the issue seems not related to mythweb, because I've this error with other access to my Apache server :-( (even almost plain text document with 2 lines css).
My next lead is the module loading order... If anyone has an idea...

KR,
MrEd

Post Reply