Ubuntu 18.10 [packages have unmet dependencies] Solved

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
phillbrett68
Newcomer
Posts: 6
Joined: Fri May 15, 2015 6:41 am
Australia

Ubuntu 18.10 [packages have unmet dependencies] Solved

Post by phillbrett68 » Thu Jun 27, 2019 7:43 am

i am attempting to put Mythtv back on my ubuntu 18.10 box but no matter what i try i get error messages regarding the repository or it would say i have broken packages that need to be fixed or when i try to install i get the following message Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mythtv : Depends: mythtv-database but it is not going to be installed
Depends: mythtv-frontend but it is not going to be installed
Depends: mythtv-backend but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
does anyone know what might be wrong at all or how to fix it let me know thanks
Last edited by phillbrett68 on Fri Jun 28, 2019 10:38 pm, edited 1 time in total.

User avatar
pgbennett
Developer
Posts: 319
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: Ubuntu 18.10

Post by pgbennett » Thu Jun 27, 2019 3:24 pm

I recommend remove all mythtv packages and then install mythtv. You can get a list of the packages you have installed with "dpkg --list | grep myth". This will list your mythtv packages. Note it also lists mythes and libmythes which are not mythtv. Remove all the packages listed except for the mythes and libmythes. Use "sudo apt remove <packagename>" . Once all are removed try installing mythtv.

wesnewell
Senior
Posts: 504
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Ubuntu 18.10

Post by wesnewell » Thu Jun 27, 2019 6:10 pm

Synaotic package manager has a fix broken packages option under the Edit menu. Try that to fix your broken packages, and then reinstall the main mythtv package. I think it will install all you need, front/back end, database, etc.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

phillbrett68
Newcomer
Posts: 6
Joined: Fri May 15, 2015 6:41 am
Australia

Re: Ubuntu 18.10 Solved

Post by phillbrett68 » Fri Jun 28, 2019 10:38 pm

thanks all solved it installed fine

Post Reply