Mythtv 30, hdhomerun, tuner offline issue

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
raydude
Newcomer
Posts: 6
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Mythtv 30, hdhomerun, tuner offline issue

Post by raydude » Tue Jun 25, 2019 4:15 am

Mythtv 30 works fine for a few days, but after that the hdhomerun goes "offine" and recordings fail, unless I restart the backend.

I have a standard mythbackend log, but I don't see any error messages around the time the recording was supposed to record. There are no "offline" messages or anything about the hdhomerun.

There is this message though:

Code: Select all

019-06-22 15:13:55.627985 E [3008/3008] CoreContext mmulticastsocketdevice.cpp:61 (MMulticastSoc>
                        eno: No such device (19)
2019-06-22 15:13:55.628431 E [3008/3008] CoreContext mmulticastsocketdevice.cpp:61 (MMulticastSoc>
                        eno: No such device (19)
2019-06-22 15:13:58.618565 I [3008/3440] Scheduler scheduler.cpp:2356 (HandleReschedule) - Resche>
2019-06-22 15:13:58.653221 E [3008/3609] TaskQueue mmulticastsocketdevice.cpp:61 (MMulticastSocke>
                        eno: No such device (19)
I upgraded hardware recently and I wonder if there's some confusion about the networking going on.

I'm running on Gentoo.

Any advice would be appreciated.

Thanks in advance.

User avatar
bill6502
Developer
Posts: 1335
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Mythtv 30, hdhomerun, tuner offline issue

Post by bill6502 » Thu Jun 27, 2019 2:32 pm

You might try some of the tests in viewtopic.php?f=36&t=3212
There isn't any hdhomerun text in the log, watch for HDHRSH as mentioned ^^^.

A full log in a pastebin would help, if the above is of no help.

Lost Dog
Newcomer
Posts: 7
Joined: Sat Feb 08, 2014 4:18 pm
United States of America

Re: Mythtv 30, hdhomerun, tuner offline issue

Post by Lost Dog » Fri Jun 28, 2019 3:38 pm

raydude wrote:
Tue Jun 25, 2019 4:15 am
Mythtv 30 works fine for a few days, but after that the hdhomerun goes "offine" and recordings fail, unless I restart the backend.

I'm running on Gentoo.

Any advice would be appreciated.

Thanks in advance.
I'm running 30 on Linux Mint 19.1 and I have the same issue. I've not had the time to dig in and track down the problem however. I've had no hardware or software changes on my HTPC and the only difference was going from Myth 0.29-fixes to 0.30-fixes.

The only thing that seems to correlate is rebooting my router. It's almost as if there is some networking hickup between the two if the router is rebooted... Again, I've not taken the time to investigate but when I start noticing broken recordings (I don't watch much TV so it may take several days before I notice) it's often right around the time I've updated my router firmware or rebooted it for one reason or another.

Yeah, not very helpful but at least someone else feels your pain!

User avatar
bill6502
Developer
Posts: 1335
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Mythtv 30, hdhomerun, tuner offline issue

Post by bill6502 » Fri Jun 28, 2019 6:46 pm

v30 had significant changes that allow locking the HDHR devices and establishing a pool, if desired.

Ref: [57a0ad8]

Using the tools in viewtopic.php?f=36&t=3212
May help.

If sharing is in play, it would be good to note if other devices are using the HDHR
and how MythTV has been configured to best use it.

raydude
Newcomer
Posts: 6
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Mythtv 30, hdhomerun, tuner offline issue

Post by raydude » Sat Jun 29, 2019 9:56 pm

I think I know what my issue was. I'm running gentoo and the version of libhdhomerun was significantly out of date.

The current version in gentoo is: 20150826. I updated to 20190621 and I think it's working.

Post Reply