trouble starting my mythtv backend

For discussion of topics specific to MythTV on linux
Post Reply
necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

trouble starting my mythtv backend

Post by necbot » Tue May 14, 2019 2:24 am

Hi there,

I'm trying to setup a MythTV backend on Lubuntu 18.04. I've made it through most of the configuration setups but I cannot start the backend. When I run "journalctl -xe I see this...

Code: Select all

-- The start-up result is RESULT.
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: C thread_unknown mythcommandlineparser.cpp:2607 (ConfigureLogging) mythbackend version:  [v30.0] www.mythtv.org
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: C thread_unknown mythcommandlineparser.cpp:2609 (ConfigureLogging) Qt version: compile: 5.9.5, runtime: 5.9.5
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: N thread_unknown mythcommandlineparser.cpp:2611 (ConfigureLogging) Enabled verbose msgs:  general
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: N thread_unknown logging.cpp:734 (logStart) Setting Log Level to LOG_INFO
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Interrupt handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Terminated handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Segmentation fault handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Aborted handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Bus error handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Floating point exception handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Illegal instruction handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Real-time signal 0 handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Hangup handler
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: N thread_unknown mythdirs.cpp:203 (InitializeMythDirs) Using runtime prefix = /usr
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: N thread_unknown mythdirs.cpp:205 (InitializeMythDirs) Using configuration directory = /home/mythtv/.mythtv
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythcorecontext.cpp:272 (Init) Assumed character encoding: en_US.UTF-8
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythcontext.cpp:641 (LoadDatabaseSettings) Empty LocalHostName. This is typical.
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythcontext.cpp:650 (LoadDatabaseSettings) Using a profile name of: 'ubuntu' (Usually the same as this host's name.)
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythcontext.cpp:900 (TestDBconnection) Start up testing connections. DB localhost, BE , attempt 0, status dbAwake, Delay: 2000
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I Logger logging.cpp:296 (run) Added logging to the console
May 13 22:06:42 ubuntu mythbackend[1205]: mythbackend[1205]: I LogForward loggingserver.cpp:246 (SyslogLogger) Added syslogging
May 13 22:06:42 ubuntu kernel: random: crng init done
May 13 22:06:43 ubuntu mythbackend[1205]: No setting found for this machine's BackendServerIP.
May 13 22:06:43 ubuntu mythbackend[1205]: Please run setup on this machine and modify the first page
May 13 22:06:43 ubuntu mythbackend[1205]: of the general settings.
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: N CoreContext mythcorecontext.cpp:1780 (InitLocale) Setting QT default locale to en_US
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythcorecontext.cpp:1813 (SaveLocaleDefaults) Current locale en_US
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: N CoreContext mythlocale.cpp:123 (LoadDefaultsFromXML) Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythtranslation.cpp:64 (load) Loading en_us translation for module mythfrontend
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext schemawizard.cpp:120 (Compare) Current MythTV Schema Version (DBSchemaVer): 1350
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: I CoreContext mythtranslation.cpp:64 (load) Loading en_us translation for module mythfrontend
May 13 22:06:43 ubuntu mythbackend[1205]: mythbackend[1205]: E CoreContext mythsocket.cpp:413 (ConnectToHost) MythSocket(55d746c76110:-1): Unable to lookup:
May 13 22:06:43 ubuntu systemd[1]: mythtv-backend.service: Main process exited, code=exited, status=138/n/a
May 13 22:06:43 ubuntu systemd[1]: mythtv-backend.service: Failed with result 'exit-code'.
May 13 22:06:45 ubuntu systemd[1]: mythtv-backend.service: Service hold-off time over, scheduling restart.
May 13 22:06:45 ubuntu systemd[1]: mythtv-backend.service: Scheduled restart job, restart counter is at 7.
It tries to restart about 10 times and the quits. The line ...

CoreContext mythsocket.cpp:413 (ConnectToHost) MythSocket(55d746c76110:-1): Unable to lookup:

seems to indicate some sort of connection error, right? I kept my ports at their default settings and my host IP is set to 127.0.0.1 Any ideas what I might be doing wrong? Thanks!

User avatar
paulh
Developer
Posts: 436
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: trouble starting my mythtv backend

Post by paulh » Tue May 14, 2019 10:39 am

Code: Select all

May 13 22:06:43 ubuntu mythbackend[1205]: Please run setup on this machine and modify the first page
Did you run mythtv-setup before trying to start the backend?

necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Re: trouble starting my mythtv backend

Post by necbot » Tue May 14, 2019 11:23 am

Of course. But good catch because I did not notice that line and when I searched for it I stumbled on this....

https://www.mythtv.org/wiki/Troubleshoo ... ndServerIP

It says....

The user running 'mythbackend' is different to the user who ran 'mythtv-setup' - fix by 'su'ing to the mythtv user and rerunning setup.

So do I have to run the myth-setup logged in as mythtv user? I was logged in as myself, but I added myself to the mythtv group

necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Re: trouble starting my mythtv backend

Post by necbot » Wed May 15, 2019 12:23 am

Managed to get it working. I had to change my IP address form 127.0.0.1 to my local IP.

Post Reply