upgrading to MythTV 30

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

Post Reply
halucigenia
Junior
Posts: 79
Joined: Tue Nov 11, 2014 11:03 am
Great Britain

upgrading to MythTV 30

Post by halucigenia » Sun Apr 14, 2019 4:56 pm

I managed to update my secondary backend to MythTV v30 while updating other software, so I bit the bullet and upgraded my main backend and frontend.
I got the "You are enabling the development version of MythTV... HERE BE DRAGONS" message after

Code: Select all

sudo apt-add-repository ppa:mythbuntu/30
sudo apt upgrade
I thought that V30 was the current version?
Did I get the wrong PPA?

MikeB2013
Senior
Posts: 337
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: upgrading to MythTV 30

Post by MikeB2013 » Sun Apr 14, 2019 5:13 pm

30 is the current version.
You have the correct ppa.
It is just the text on ppa 30 page, it has not yet been updated (it was correct when 0.29 was the current release).

Note: if running 0.29 and upgrading via the mythbuntu 30 ppa you need to run "sudo apt dist-upgrade" instead of "sudo apt upgrade".
This is only necessary when upgrading from one version to the next.

Mike

User avatar
paulh
Developer
Posts: 401
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: upgrading to MythTV 30

Post by paulh » Sun Apr 14, 2019 8:39 pm

I've asked the MythBuntu developers to change that description it's just been overlooked. As Mike said 30 is the current version.

halucigenia
Junior
Posts: 79
Joined: Tue Nov 11, 2014 11:03 am
Great Britain

Re: upgrading to MythTV 30

Post by halucigenia » Mon Apr 15, 2019 6:08 am

MikeB2013 wrote:
Sun Apr 14, 2019 5:13 pm
30 is the current version.
You have the correct ppa.
It is just the text on ppa 30 page, it has not yet been updated (it was correct when 0.29 was the current release).
Thanks for the reassurance .
MikeB2013 wrote:
Sun Apr 14, 2019 5:13 pm
Note: if running 0.29 and upgrading via the mythbuntu 30 ppa you need to run "sudo apt dist-upgrade" instead of "sudo apt upgrade".
This is only necessary when upgrading from one version to the next.

Mike
Strange I did not have to do "sudo apt dist-upgrade" and am sure that I tried after "sudo apt upgrade" but I see that "sudo apt dist-upgrade" now states:-

"The following packages will be upgraded:
libmyth libmyth-python libmythtv-perl mythtv mythtv-backend mythtv-common mythtv-database mythtv-dbg mythtv-frontend mythtv-transcode-utils mythweb php-mythtv"

Mythtv frontend 'About' says I am on 30 though. I will continue the upgrade as soon as I have the chance.

Post Reply