Intel NUC - Fail

Do you want advice about what hardware to buy for use with MythTV? Ask here.

Moderator: Forum Moderators

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Intel NUC - Fail

Post by kbocek » Tue Feb 26, 2019 12:08 am

Bought an Intel NUC - NUC6CAYH as a frontend. Pretty nice. Small, silent, built-in IR receiver. But I cannot get video playback to work. Any of the enhanced playback profiles cause stuttering. The Intel drivers are installed:

Code: Select all

libva info: VA-API version 0.39.4
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.39 (libva 1.7.3)
vainfo: Driver version: Intel i965 driver for Intel(R) Broxton - 1.7.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointVLD
I'm having to use the regular 'Normal' profile and I cannot figure this out.

User avatar
heyted
Senior
Posts: 100
Joined: Sun Jun 08, 2014 2:14 am
Location: South Florida
Contact:
United States of America

Re: Intel NUC - Fail

Post by heyted » Tue Feb 26, 2019 1:58 am

Have you taken a look at https://www.mythtv.org/wiki/VAAPI? Did you set Painter to Auto or OpenGL and not Qt in MythFrontend -> Setup -> Appearance?
Ted | My blog

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Tue Feb 26, 2019 6:45 pm

Yup, Yup and Yup. Tried both OpenGL and Auto for the painter.

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Wed Feb 27, 2019 12:31 am

Tried looking at my memory. It's a memory module I had lying around. It is the correct spec for this hardware but is *not* on Intel's compatibility list. I had it in the wrong slot but moving it did not fix my problem.

beppo
Senior
Posts: 151
Joined: Sun Feb 09, 2014 8:12 am
Germany

Re: Intel NUC - Fail

Post by beppo » Wed Feb 27, 2019 7:32 am

I had to tweak the xorg.conf to get tear free playback.
Change your device section to look like this and give it a try.

Code: Select all

Section "Device"
  Identifier "Device0"
  Driver "intel"
  VendorName "INTEL Corporation"
  Option "DRI" "3"
  Option "TearFree" "true"
  Option "TripleBuffer" "true"
EndSection
Viele Grüße Beppo

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Wed Feb 27, 2019 4:07 pm

Thanks Beppo I was unaware of the TripleBuffer option. I do need the TearFree option and have it set. Alas, stuttering is still present. Have you played with Accel and AccelMethod?

Here's a weird one. This is on a 4K display. When I turn on VAAPI, the bit of 4K video I have plays great. But Live TV stutters. If I set the playback to Normal, TV plays great but the 4K video stutters.

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Thu Feb 28, 2019 1:00 am

Well thank you Beppo. Maybe it was the TripleBuffer. Maybe it was the DRI. VAAPI is on and video is playing well, recordings are playing well.

Except...

Live TV is stuttering. Now if I select 'make recording' and then go back and play that recording, everything plays fine. This is all recording off an HDHomerun. Is there a LiveTV setting I missed somewhere?

My xorg.conf Intel section looks like:

Code: Select all

Section "Device"
        Identifier "Intel Graphics"
        Driver "intel"
        Option "TearFree" "true"
        Option "Accel" "true"
        Option "AccelMethod" "sna"
#       Option "AccelMethod" "uxa"
        Option "TripleBuffer" "true"
        Option "DRI" "3"
EndSection

beppo
Senior
Posts: 151
Joined: Sun Feb 09, 2014 8:12 am
Germany

Re: Intel NUC - Fail

Post by beppo » Thu Feb 28, 2019 7:25 am

He kbocek,

regarding 4K, I think the limitation is not your system. Mythtv needs to be rewritten for this use case.
At https://github.com/MythTV/mythtv/tree/devel/2019-render you can follow the "zero copy" efforts but it is not ready yet.

Regarding the live tv stuttery, if you use AVSync2, you have to increase the readahead to 300 ms. That works for me.
By the way which version of mythtv are you using?
Viele Grüße Beppo

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Thu Feb 28, 2019 3:02 pm

29.1. How do you set read ahead?

beppo
Senior
Posts: 151
Joined: Sun Feb 09, 2014 8:12 am
Germany

Re: Intel NUC - Fail

Post by beppo » Thu Feb 28, 2019 5:49 pm

He,

the latest version v30.0 brings a lot improvements in the area of vaapi and the option to use
AVSync2.
Please see
https://www.mythtv.org/wiki/Release_Notes_-_30
for further information.

Is it possible for you to upgrade?
Viele Grüße Beppo

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Thu Feb 28, 2019 6:22 pm

Meh. I spent so much time getting to 29.1. BTW, now that I have VAAPI working, 4K is displaying just fine. I have a short 4K clip that I played for my wife and daughter. Nobody can see any difference over my 1080P content. Even on an 82" screen.

You mentioned ReadAhead. I know how to set that on a block device. I would think Myth would be more network bound (I have split front and back ends.) Is there a Myth setting I don't know about?

beppo
Senior
Posts: 151
Joined: Sun Feb 09, 2014 8:12 am
Germany

Re: Intel NUC - Fail

Post by beppo » Fri Mar 01, 2019 7:29 am

the readahead is an option of AVSync2 and it comes with version 30.0.
what did you futher do to get 4K playing smooth?
Viele Grüße Beppo

beppo
Senior
Posts: 151
Joined: Sun Feb 09, 2014 8:12 am
Germany

Re: Intel NUC - Fail

Post by beppo » Fri Mar 01, 2019 7:43 am

Screenshot_20190301_084145.png
Screenshot_20190301_084145.png (116.53 KiB) Viewed 757 times
Viele Grüße Beppo

kbocek
Senior
Posts: 112
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Intel NUC - Fail

Post by kbocek » Fri Mar 01, 2019 4:18 pm

I'm not seeing that. Under Setup - Video - playback there is no Advanced option.

beppo
Senior
Posts: 151
Joined: Sun Feb 09, 2014 8:12 am
Germany

Re: Intel NUC - Fail

Post by beppo » Fri Mar 01, 2019 7:54 pm

You've got me wrong, your myth installation is version 29.1
and the AVSync2 option comes with version 30.0.
Viele Grüße Beppo

Post Reply