Despite editing irrelevant frames shown

For discussion of topics specific to MythTV on linux
Post Reply
lowlandmyth
Newcomer
Posts: 4
Joined: Tue Oct 30, 2018 3:51 pm
Netherlands

Despite editing irrelevant frames shown

Post by lowlandmyth » Sat Dec 15, 2018 1:53 pm

Hi,
I do have a strange problem with the mythtv software, in my case the mythtv in knoppmyth (which is unsupported since a long time).
Maybe any of you had this problem too, I don't know how to seek on the Mythtv forum nor the Linhes forum which deals with old Knoppmyth tips, other than reading each and every message.

Description of the problem.
(I am running in a linux environment, do my recording from DVB-S (satellite) using a Technisat card.

I schedule a recording of a tv-program, and let the recording start 4 minutes earlier and ending 4 minutes later to overcome fluctuations on onset and ending on the broadcaster sode/
After the recording is on my Mythtv computer, I can edit the recording and cut away the front and rear 'extensions' of the recording.
This works fine for many years now.
The cuts are made that way, the recording starts with te first frame of the wanted tv-program, and ends with the last frame.
When i let the edited recording run in my Mythtv computer (that who made the recordingl is front and backend at the same time) the recording shows up fine: starting and ending at the chose frames.
Next I make an iso-file of that recording, using the tools the Mythtv program gives me.
I send the resulting iso-file to another linux computer and play the file using the VLC-player.
The movie shows up fine, and starts/ends with the first and last frame as chosen above. Everything fine until now...
After that I burn the iso-file to a writable DVD (using K3b) and play that DVD in a stand-alone dvd-player.
Now comes the problem: the recording starts at the first frame (good), but goes on after the last frame in a strange manner:
after the last frame (of the tv-program) a shot (frame) is shown which is part of (in fact is the end-frame) of the 4 minute extension on the very end I scheduled to record in the recording process.
I can find this frame when I inspect that 4 minute 'edited-away' part!!!!!!!!!!!!!
How can this happen??
Strange aspect: this happens not on every recording I make using exactly this procedure, let's say in 10% of the cases it does..

Anyone who recognises this?
Anyone with a method to make this not happen?

Thanks,
lowlandmyth

bakasan
Newcomer
Posts: 2
Joined: Thu Dec 27, 2018 9:06 pm
Australia

Re: Despite editing irrelevant frames shown

Post by bakasan » Sat Dec 29, 2018 8:54 pm

Is the final frame cut on a keyframe?

Post Reply