Cannot get SBS channel group EPG data

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Cannot get SBS channel group EPG data

Post by Tonyr63 » Wed Nov 21, 2018 11:39 pm

I am using XMLTV EPG grabber in South Australia however I am not getting any SBS channel group EPG showing as unknown.

I can watch SBS live TV and watching live TV tuned to SBS and associated channels ViceLand etc but this has not triggered the sending of program data to facilitate recording scheduling.

When I run Myth Fill Database the resulted run off screen too fast to review. Does his write to a log file I can review?

Can I setup MythTv to capture failure of EPG events and if so how? It would be good if the user was alerted to what is causing EPG to be incomplete as it has such a detrimental effect on core functionality.

I read the following post:
"
I followed Expert Novice's advice and change the call sign for SBS Viceland from SBS VICELAND to SBSVICELAND using Mythweb Settings>TV>Channelinfo and that solved the problem, not just for the Viceland channel but for all SBS channels."

From <https://forums.whirlpool.net.au/archive/2587409>

However I don't seem to have MythWeb installed although I though it came automatically with the main package. How do I retrospectively install MythWeb?

How should I resolve my EPG issue or do I need to also add Shephard?

User avatar
bill6502
Developer
Posts: 1160
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Cannot get SBS channel group EPG data

Post by bill6502 » Thu Nov 22, 2018 5:01 pm

Some partial help:

Almost all myth* programs have additional logging features. To capture the output
in a file, append --logpath /tmp (or whatever directory you want the log to go to.)
The log will be the program's name plus data/time. Try: mythSomeProgramName -h

mythweb is a separate package. If you'll mention your distribution, someone may
tell you how to get it. In *buntu, it's: sudo apt install mythweb (apt-get for older
versions.)

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Re: Cannot get SBS channel group EPG data

Post by Tonyr63 » Wed Jan 30, 2019 8:28 am

Hello

I have tried to run the following procedure.
I went to Mythbackend Setup > Channel Editor > Scan for Channels > then scan existing transport (know the frequency for SBS), ignore time out and search new transports checked > then after its finished update transports.

Unfortunately I got the error "Failed to open card"
I don't understand why because it is not recording anything and idle.
The installation can still run Live TV but cannot open the card on a channel scan? How can this be?

User avatar
bill6502
Developer
Posts: 1160
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Cannot get SBS channel group EPG data

Post by bill6502 » Wed Jan 30, 2019 10:00 pm

Make sure you stop the backend before doing the scan. Some distributions/setups
aren't configured to stop it properly. The backend has the tuners even if they aren't
recording.

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Re: Cannot get SBS channel group EPG data

Post by Tonyr63 » Wed Jan 30, 2019 10:12 pm

Hi
When I opened the Backend I was prompted to close the backend service which I did. How should I test to make sure it actually stopped the services and if I see it is not stopped what should I do to stop it?

wesnewell
Senior
Posts: 426
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Cannot get SBS channel group EPG data

Post by wesnewell » Wed Jan 30, 2019 11:06 pm

Depends on your system.
man kill
man killall
man systemctl
User must be able to run the command. Sudo or root may have to do it, again, depending on your system.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Re: Cannot get SBS channel group EPG data

Post by Tonyr63 » Thu Jan 31, 2019 4:49 am

OK
I used sudo systemctl stop mythtv-backend which worked showing that indeed the backend was not properly stopping. This must be a fresh bug as I have not seen this problem before. I'm still struggling to understand the solution advise I reviewed specifically "then scan existing transport (know the frequency for SBS), ignore time out and search new transports checked > then after its finished update transports.

This contains a lot of assumed knowledge.

I can see follow exactly the 1st part - Setup > Channel Editor > Scan for Channels >
from here it get a bit foggy trying to relate the instruction to the UI in front of me.

I see Channel Scan - which I was now finally able to run
Icon Download
Edit Transports
from where do I "scan the existing transport?
In Edit transports I have a list of Transports but how to I trigger a transpoty scan.

Can someone please guide me through the process of fixing this pointing out the exact path to the required commands.

wesnewell
Senior
Posts: 426
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Cannot get SBS channel group EPG data

Post by wesnewell » Thu Jan 31, 2019 5:55 am

There could be several reasons why it doesn't shut down properly when you run setup. First look at these settings with mythweb and set them accordingly.for your system.
BackendStartCommand systemctl start mythtv-backend
BackendStopCommand systemctl stop mythtv-backend
Also make sure the mythtv user has permission to run them. Usually, user mythtv is the user.
For scanning individual transports. Instructions should be in the wiki. I've never had to do it that I recall.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Re: Cannot get SBS channel group EPG data

Post by Tonyr63 » Thu Jan 31, 2019 12:05 pm

Running the scan channels recovered EPG for channel 31 SBS Viceland HD & 34 SBS food.
Still no EPG for Channels 3 SBS One, 30 SBS One HD, 32 SBS Viceland, 34 NITV and 44 Adelaide.

I don't know why some SBS EPG has come through and not all. I have made sure I have started all the channels in Live TV and program information is show in them all. This seems to have triggered some EPG but not all. But of course this should just work and not take so much effort and time troubleshoot.

Please advise what I shod do next?

wesnewell
Senior
Posts: 426
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Cannot get SBS channel group EPG data

Post by wesnewell » Thu Jan 31, 2019 2:12 pm

I have no idea. Perhaps someone from the UK can help.I don't even know what SBS is or how they operate over there.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Re: Cannot get SBS channel group EPG data

Post by Tonyr63 » Mon Feb 04, 2019 12:11 am

Hello

The very first line of this thread advised the location: - "I am using XMLTV EPG grabber in South Australia however I am not getting any SBS channel group EPG showing as unknown." I don't know why I have been referred to the UK? The Kodi Mythtv client can see all the EPG providing me with a work a round although I don't see in Kodi a way to do a series record schedule. I need to investigate Kodi further.

SBS is a TV channel broadcasting in Australia and to my extreme frustration the channel that provides 90% of the content I want and the channel group that myth refuses to give up EPG data for. Now it appears I get partial channel group data - go figure.

It is really disappointing to see Mythtv still so flaky and difficult to configure and achieve full operational functionality after so many years. Bugs like the prompt to stop the backend not working simply should not happen. Most people who are not expert in Linux and Myth really struggle as has been widely reported however it appears that the developers never look to improve and reform the ponderous counter intuitive UI which would make configuration so much easier.

User avatar
Steve Goodey
Moderator
Posts: 68
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: Cannot get SBS channel group EPG data

Post by Steve Goodey » Mon Feb 04, 2019 4:06 am

Maybe your wiki user location flag of Ireland confused the poster hence the UK suggestion?

You mentioned in your post a fix from someone else and a wish to install mythweb. Did you get anywhere with that?

I don't think I can see in your posts any answer to the request as to the operating system/mythtv versions.

Unfortunately MythTV is a complicated beast, getting it to work with all the different hardware/TV system available can be daunting for most of us. I can only say once it is working it is a very good system. Sorry you're having difficulties.

Seeing the commits that appear on the mythtv-commits mailing list, MythTV is constantly being worked on by developers who give their free time, unpaid, to improve this free product. The UI can be a bit tricky to navigate.

It's odd that you say you get partial channel group data. Is it possible for you to supply an example to help others see the problem? Also perhaps posting your problem in the troubleshooting or regional/Australia sections of the wiki might help?

As a last resort have you thought of a clean install? Start from fresh.

Good luck.

wesnewell
Senior
Posts: 426
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Cannot get SBS channel group EPG data

Post by wesnewell » Mon Feb 04, 2019 5:09 am

Tonyr63 wrote:
Mon Feb 04, 2019 12:11 am
Hello

The very first line of this thread advised the location: - "I am using XMLTV EPG grabber in South Australia however I am not getting any SBS channel group EPG showing as unknown." I don't know why I have been referred to the UK?
Because that's where you set your location to, Ireland. If you are in Australia, please correct your profile location.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Tonyr63
Junior
Posts: 57
Joined: Thu Sep 03, 2015 2:14 pm
Location: South Australia
Ireland

Re: Cannot get SBS channel group EPG data

Post by Tonyr63 » Wed Feb 06, 2019 12:44 am

Hi

I can report that now SBS EPG data is coming through for all SBS channels. Two days after the last configuration attempts the missing SBS EPG came through. I wish i know definitively why it was resolved but I cannot which is a shame in case anyone else has the same problem.

I could not understand the instruction to "scan for Transports" as queried above. Is an Input connection a transport?

Under Input connections you can scan for channels and also in Channel Editor. Are these different scans as implied by the advise I was following?
If so perhaps running the scan in channel editor woke it up although despite several dB fills it did not initially come through. i ran live TV on all the SBS channels and got EPG from the subset I reported immediately following that with the rest coming 2 days later.

In channel editor if I want to delete just one single channel how do I do that as i only see a "Delete All Channels" button with a warning that it will delete all channels even if you have selected just one?

We are delighted to now be able to schedule programs on the SBS channel group becuase it has so much content we are interested in and for so long this has been broken. Our sincere thanks to everyone who assisted.

wesnewell
Senior
Posts: 426
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Cannot get SBS channel group EPG data

Post by wesnewell » Wed Feb 06, 2019 6:57 am

In the mean time, correct your location flag in your profile.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Post Reply