Compiling Mythtv 29 on Ubuntu 18.04 Error

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Fri Oct 19, 2018 1:11 am

Thanks for taking the time to look at my post any help is appreciated.

OS: Ubuntu 18.04 desktop fresh install
MythTV: 29

This is my first go at compiling mythtv instead of taking the repo. To be honest I tried the repo and well ran into gksu issues as that has been deprecated. So I figured I give compiling a go. I have followed the instructions on the wiki and made sure the dependencies have been met. I'm using the default configure command (./configure) followed by the make command. But the make fails with this error. Which appears that qt5 is not installed, but it is installed. Where is mythtv expecting these files to be located? I had to remove the dot from libmythbase-29(dot)so.29.0.0 because it was being flagged as a url and since I'm new I can't post urls.

Code: Select all


/usr/bin/ld: cannot find -lQt5Widgets
/usr/bin/ld: cannot find -lQt5Gui
/usr/bin/ld: cannot find -lQt5Network
/usr/bin/ld: cannot find -lQt5Core
collect2: error: ld returned 1 exit status
Makefile:428: recipe for target libmythbase-29 so.29.0.0 failed
make[2]: *** libmythbase-29 so.29.0.0 Error 1
make[2]: Leaving directory '/home/zeroeffect/build/mythtv/mythtv/libs/libmythbase'
Makefile:79: recipe for target sub-libmythbase-make_first failed
make[1]: *** [sub-libmythbase-make_first] Error 2
make[1]: Leaving directory /home/zeroeffect/build/mythtv/mythtv/libs
Makefile:67: recipe for target 'libs' failed
make: *** [libs] Error 2

####@mythtv-svr:~/build/mythtv/mythtv$ sudo find / -name qt5
[sudo] password for ####:
/usr/include/x86_64-linux-gnu/qt5
/usr/share/qt5
/usr/lib/i386-linux-gnu/qt5
/usr/lib/x86_64-linux-gnu/qt5
/usr/lib/qt5

thank you again for your time and help.

Paul

User avatar
bill6502
Developer
Posts: 1098
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by bill6502 » Fri Oct 19, 2018 2:27 am

Could be how Qt5 is installed. Try adding the: --qmake=qmake-qt5 switch
to ./configure.

I'm assuming you used ansible to make sure you've got all
the required packages.

https://www.mythtv.org/wiki/Build_from_ ... th_Ansible

Here's a very old note of mine:

Code: Select all

Sun Mar 2, 2015

    Use:
        sudo apt-get install qt5-default
    Or:
        cd /usr/bin
        sudo ln -s ../lib/x86_64-linux-gnu/qt5/bin/qmake qmake5
        add the configure switch: --qmake=qmake5

    And:
        sudo apt-get install libqt5script5 libqt5scripttools5 qtscript5-dev
        sudo apt-get install libqt5webkit5-dev
        sudo apt-get install libqt5sql5-mysql

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Fri Oct 19, 2018 12:49 pm

Thanks for your response.

I have tried the following.

I reran ansible and configure

I followed the other suggestions too, created the link and then clear the git build (git clean -xfd) and then ran the configure again.

Code: Select all

./configure -qmake=qmake-qt5 

make -j 5

Code: Select all

/local/lib -lQt5Widgets -lQt5Gui -lQt5Xml -lQt5Sql -lQt5Network -lQt5Core -lpthread -lGL
/usr/bin/ld: cannot find -lQt5Widgets
/usr/bin/ld: cannot find -lQt5Gui
/usr/bin/ld: cannot find -lQt5Network
/usr/bin/ld: cannot find -lQt5Core
collect2: error: ld returned 1 exit status
Makefile:428: recipe for target 'libmythbase-29(dot)so.29.0.0' failed
make[2]: *** [libmythbase-29(dot)so.29.0.0] Error 1
make[2]: Leaving directory '/home/zeroeffect/build/mythtv/mythtv/libs/libmythbase'
Makefile:79: recipe for target 'sub-libmythbase-make_first' failed
make[1]: *** [sub-libmythbase-make_first] Error 2
make[1]: Leaving directory '/home/zeroeffect/build/mythtv/mythtv/libs'
Makefile:67: recipe for target 'libs' failed
make: *** [libs] Error 2
Is there a make log? I didn't see one in /var/log.

User avatar
bill6502
Developer
Posts: 1098
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by bill6502 » Fri Oct 19, 2018 3:29 pm

The make output you pasted above is the only thing I'm aware of.

Here's what I get from dpkg and locate on Ubuntu 18.04:

Code: Select all

$ dpkg -l libqt5widgets5 libqt5network5 libqt5gui5 libqt5core5a
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name               Version        Architecture   Description
+++-==================-==============-==============-==========================================
ii  libqt5core5a:amd64 5.9.5+dfsg-0ub amd64          Qt 5 core module
ii  libqt5gui5:amd64   5.9.5+dfsg-0ub amd64          Qt 5 GUI module
ii  libqt5network5:amd 5.9.5+dfsg-0ub amd64          Qt 5 network module
ii  libqt5widgets5:amd 5.9.5+dfsg-0ub amd64          Qt 5 widgets module

$ locate Qt5Widgets Qt5Gui Qt5Network Qt5Core
/usr/lib/x86_64-linux-gnu/libQt5Core.prl
/usr/lib/x86_64-linux-gnu/libQt5Core.so
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Gui.prl
/usr/lib/x86_64-linux-gnu/libQt5Gui.so
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Network.prl
/usr/lib/x86_64-linux-gnu/libQt5Network.so
/usr/lib/x86_64-linux-gnu/libQt5Network.so.5
/usr/lib/x86_64-linux-gnu/libQt5Network.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Network.so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Widgets.prl
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5.9
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5.9.5
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui
/usr/lib/x86_64-linux-gnu/cmake/Qt5Network
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CTestMacros.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfigExtras.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreMacros.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui/Qt5GuiConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui/Qt5GuiConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Network/Qt5NetworkConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Network/Qt5NetworkConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsConfigExtras.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsMacros.cmake
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Core.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Gui.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Network.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Widgets.pc

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Fri Oct 19, 2018 6:40 pm

I'll be able to look at this a bit more when I get out of work but here is my output of the same commands you ran.

Code: Select all

zeroeffect@mythtv-svr:~/build/mythtv/mythtv$ dpkg -l libqt5widgets5 libqt5network5 libqt5gui5 libqt5core5a
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                    Version          Architecture     Description
+++-=======================-================-================-===================================================
ii  libqt5core5a:amd64      5.9.5+dfsg-0ubun amd64            Qt 5 core module
ii  libqt5core5a:i386       5.9.5+dfsg-0ubun i386             Qt 5 core module
ii  libqt5gui5:amd64        5.9.5+dfsg-0ubun amd64            Qt 5 GUI module
ii  libqt5gui5:i386         5.9.5+dfsg-0ubun i386             Qt 5 GUI module
ii  libqt5network5:amd64    5.9.5+dfsg-0ubun amd64            Qt 5 network module
ii  libqt5network5:i386     5.9.5+dfsg-0ubun i386             Qt 5 network module
ii  libqt5widgets5:amd64    5.9.5+dfsg-0ubun amd64            Qt 5 widgets module
ii  libqt5widgets5:i386     5.9.5+dfsg-0ubun i386             Qt 5 widgets module
zeroeffect@mythtv-svr:~/build/mythtv/mythtv$ locate Qt5Widgets Qt5Gui Qt5Network Qt5Core
/usr/lib/i386-linux-gnu/libQt5Core(dot)so.5
/usr/lib/i386-linux-gnu/libQt5Core(dot)so.5.9
/usr/lib/i386-linux-gnu/libQt5Core(dot)so.5.9.5
/usr/lib/i386-linux-gnu/libQt5Gui(dot)so.5
/usr/lib/i386-linux-gnu/libQt5Gui(dot)so.5.9
/usr/lib/i386-linux-gnu/libQt5Gui(dot)so.5.9.5
/usr/lib/i386-linux-gnu/libQt5Network(dot)so.5
/usr/lib/i386-linux-gnu/libQt5Network(dot)so.5.9
/usr/lib/i386-linux-gnu/libQt5Network(dot)so.5.9.5
/usr/lib/i386-linux-gnu/libQt5Widgets(dot)so.5
/usr/lib/i386-linux-gnu/libQt5Widgets(dot)so.5.9
/usr/lib/i386-linux-gnu/libQt5Widgets(dot)so.5.9.5
/usr/lib/i386-linux-gnu/sse2/libQt5Core(dot)so.5
/usr/lib/i386-linux-gnu/sse2/libQt5Core(dot)so.5.9
/usr/lib/i386-linux-gnu/sse2/libQt5Core(dot)so.5.9.5
/usr/lib/i386-linux-gnu/sse2/libQt5Gui(dot)so.5
/usr/lib/i386-linux-gnu/sse2/libQt5Gui(dot)so.5.9
/usr/lib/i386-linux-gnu/sse2/libQt5Gui(dot)so.5.9.5
/usr/lib/x86_64-linux-gnu/libQt5Core.prl
/usr/lib/x86_64-linux-gnu/libQt5Core(dot)so
/usr/lib/x86_64-linux-gnu/libQt5Gui.prl
/usr/lib/x86_64-linux-gnu/libQt5Gui(dot)so
/usr/lib/x86_64-linux-gnu/libQt5Network.prl
/usr/lib/x86_64-linux-gnu/libQt5Network(dot)so
/usr/lib/x86_64-linux-gnu/libQt5Widgets.prl
/usr/lib/x86_64-linux-gnu/libQt5Widgets(dot)so
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui
/usr/lib/x86_64-linux-gnu/cmake/Qt5Network
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CTestMacros.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfigExtras.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Core/Qt5CoreMacros.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui/Qt5GuiConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Gui/Qt5GuiConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Network/Qt5NetworkConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Network/Qt5NetworkConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsConfigExtras.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/Qt5Widgets/Qt5WidgetsMacros.cmake
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Core.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Gui.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Network.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/Qt5Widgets.pc

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Mon Oct 22, 2018 11:59 pm

I took a look over the weekend, compared your post to mine and while I have more entries I see that I have entries that are the same as yours. any more thoughts? is there a switch that will give me more verbose logging?

User avatar
bill6502
Developer
Posts: 1098
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by bill6502 » Fri Oct 26, 2018 2:58 pm

I would suggest the full output from the configure command line
until the error (put in a pastebin, with a link to it here.)

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Sat Oct 27, 2018 1:09 am

I ran both configure and make commands. Here is the output. There wasn't an error during the config command, only error I ofund was with the make.

Here is the paste bin.

https://paste.ubuntu.com/p/kWQWj6vpvK/

Thanks again for your help.

User avatar
bill6502
Developer
Posts: 1098
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by bill6502 » Sat Oct 27, 2018 3:17 pm

Hmmm, I'm approaching stumped. My qmake line is identical to yours:
qmake /usr/lib/x86_64-linux-gnu/qt5/bin/qmake

Looks like the 1st error is: Makefile:231: recipe for target 'libmythfreemheg-29.so.29.0.0' failed

I don't see a specific permissions error, but check with:
find . ! -user $USER -ls (to see if something can't be
overwritten.)

I'd do a: make distclean (the git clean you did earlier is something
I use too, but not often.)

Then: ccache --clear

Followed by the configure and make

busbee
Junior
Posts: 15
Joined: Sun Oct 14, 2018 12:07 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by busbee » Sun Oct 28, 2018 1:16 pm

Side Note:
Im on Ubuntu 18.04.01 LTS and have been running MythTv from maintainers and it seems to be working great (hope I am not missing anything):
Package: mythtv
Version: 2:29.1+fixes.20180414.329c235-0ubuntu3
Priority: optional
Section: multiverse/graphics
Origin: Ubuntu

I admire your courage in compiling and I wish you the best. Let me know if I can be of assistance.

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Tue Oct 30, 2018 12:45 pm

bill6502 wrote:
Sat Oct 27, 2018 3:17 pm
Hmmm, I'm approaching stumped. My qmake line is identical to yours:
qmake /usr/lib/x86_64-linux-gnu/qt5/bin/qmake

Looks like the 1st error is: Makefile:231: recipe for target 'libmythfreemheg-29.so.29.0.0' failed

I don't see a specific permissions error, but check with:
find . ! -user $USER -ls (to see if something can't be
overwritten.)

I'd do a: make distclean (the git clean you did earlier is something
I use too, but not often.)

Then: ccache --clear

Followed by the configure and make

I gave this a go and I don't see any access issues and I still get the same error. I may try and start completely over and reinstall the OS.

I don't know enough about the maintainers and how to set them up to give them a go. I'll read up on that.

busbee
Junior
Posts: 15
Joined: Sun Oct 14, 2018 12:07 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by busbee » Fri Nov 02, 2018 2:17 am

I think I did a simple:
sudo add-apt-repository universe
sudo apt update
sudo apt install mythtv

pre-compiled

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Fri Nov 02, 2018 12:11 pm

Ahh, I thought/was thinking containers (docker). busbee, this was what I tried first and the backend won't/wouldn't start I get the same LibQT5 error and mythconverg.settings db not found errors.

Now I have tried to trouble shoot these but could not get it to work which is why I went with compiling my own. I used to run mythbuntu but since they are going away I wanted to set it up on my own. I have another machine here I can use as a dev machine. I'll start with a clean install of Ubuntu 18.04 and document everything step to get it working then rebuild my main machine.

PaulR
Newcomer
Posts: 8
Joined: Fri Oct 19, 2018 12:53 am
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by PaulR » Sat Nov 03, 2018 3:40 pm

Just wanted to give an update.

Using another system, I did the following.

Code: Select all

ubuntu 18.04 desktop minimal install
install ssh

'connect from another system because I don't have enough desk space.

apt-get update
apt-get upgrade
apt-get install git
git clone https://github.com/MythTV/ansible
apt-get install ansible
cd ansible
ansible-playbook -i hosts qt5.yml
cd ..
mkdir ~/build 
cd ~/build
git clone https://github.com/MythTV/mythtv.git mythtv
cd mythtv
git branch -a
git checkout fixes/29
git clean -xfd
cd mythtv
./configure
make -j 5
sudo make install

'on the dev system, open a terminal and run

/usr/bin/mythtv-setup
This time compiling worked and I got mythtv compiled and installed.

I ran the mythtv-setup and couldn't connect to the database. I haven't looked into that but it seems to be just a user name and password issue. I am going to keep track of all commands run and config changes to complete this post. Once everything is 100% successful I will rebuild my current system. I'd like to know what happed on the old system but I don't think I'll ever know. I still have to install mythweb and get that configured. so far so good.

User avatar
bill6502
Developer
Posts: 1098
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Compiling Mythtv 29 on Ubuntu 18.04 Error

Post by bill6502 » Sat Nov 03, 2018 5:07 pm

FYI, there was a recent mailing list thread and the user kept track of his commands here:
https://mythtvinstall.blogspot.com/2018 ... nd-on.html

Post Reply