Error: Channel ID is invalid when editing default recording rule.

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
fossum
Newcomer
Posts: 2
Joined: Sat Sep 29, 2018 2:36 pm
United States of America

Error: Channel ID is invalid when editing default recording rule.

Post by fossum » Sat Sep 29, 2018 4:08 pm

I thought I corrupted my setup when I upgraded from 28 to 29 a while back, so I purged the apt packages and dropped the MySQL tables. Starting fresh, I installed the packages below and used the mc.sql to fill my database. Then ran mythtv-setup to set everything. This seems to be working and I get live TV.

I then tried to set my default recording rules in MythWeb. I can go to the recording rules page and click edit, but when I do I get a blank page. Checking the logs I see there is some Channel ID is invalid error (pasted below). What could cause this? How do I fix it?

Log output:
Sep 29 07:26:10 DVR mythbackend: mythbackend[18862]: E HttpServer52 serverSideScripting.cpp:402 (EvaluatePage) Error calling QSP File: /usr/share/mythtv/html/tv/schedule.qsp(394) - Error: Channel ID is invalid
My setup:
  • Ubunut 18.04 container
  • Pass-through 2250 tuner
  • Separate MySQL host

Manually Installed Packages:
  • mythtv-backend
  • mythtv-transcode-utils
  • mythweb

User avatar
bill6502
Developer
Posts: 1112
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Error: Channel ID is invalid when editing default recording rule.

Post by bill6502 » Sat Sep 29, 2018 5:35 pm

1st the cause: A channel id < 1 is being passed (probably a 0) to
the Services API.

I think you're using WebFrontend, not mythweb (e.g. maybe you're
going to: http://yourbackend:6544) Please correct me if that's not
the case.

The Default recording rule's chanid is 0, same for Power Searches.

Since WebFrontend is still in development, I'd use mythfrontend or
mythweb to change Default rule(s.)

fossum
Newcomer
Posts: 2
Joined: Sat Sep 29, 2018 2:36 pm
United States of America

Re: Error: Channel ID is invalid when editing default recording rule.

Post by fossum » Mon Oct 01, 2018 9:19 pm

bill6502 wrote:
Sat Sep 29, 2018 5:35 pm
A channel id < 1 is being passed (probably a 0) to
the Services API.
Seems like it should be easy to fix. How do I pass something else?
bill6502 wrote:
Sat Sep 29, 2018 5:35 pm
I think you're using WebFrontend, not mythweb
Yeah, I think you're right. The titlebar says webfrontend. Is that better than mythweb? Should I just uninstall mythweb?
bill6502 wrote:
Sat Sep 29, 2018 5:35 pm
I'd use mythfrontend
I did that to change the template, but after setting a few recordings I noticed they all had the default rule set.

User avatar
bill6502
Developer
Posts: 1112
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Error: Channel ID is invalid when editing default recording rule.

Post by bill6502 » Wed Oct 03, 2018 2:19 am

The -1 is from any Template in the DB, you don't want to change it.

WebFrontend/mythweb is really your choice. mythweb is on life support,
WebFrontend is still in development.

Both can live together, WebFrontend isn't an option, it's 'just there'.

Right, changing any Template only affects new rules, not existing ones. I'm not clear
how you made the change in the last line above. E.g. were the few recordings mentioned,
set to use the Template that was changed, as opposed to the Default Template?

Post Reply