(Solved) mytharchive script failing after upgrade to 0.28

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
phackmann
Newcomer
Posts: 6
Joined: Sun Aug 05, 2018 9:08 pm
United States of America

(Solved) mytharchive script failing after upgrade to 0.28

Post by phackmann » Sun Aug 05, 2018 9:30 pm

Hello everyone. I've recently updated from Ubuntu 14.04 to 16.04. I've also updated to MythTV 0.28. I've gotten everything else working except MythArchive. It is failing with what appears to be a database connection setup issue according to the mythburn log. This is all there is in the log file.

Untitled.png
Untitled.png (26.39 KiB) Viewed 125 times

So, I am guessing either a problem with the python-mysqldb library, or maybe the MythTV Python bindings. Has anyone seen this before? Any ideas on what to check for next?

Thanks.
Last edited by Steve Goodey on Thu Aug 09, 2018 2:21 am, edited 1 time in total.
Reason: Added (Solved) to Title.

daraden
Senior
Posts: 160
Joined: Tue Feb 23, 2016 7:33 am
United States of America

Re: mytharchive script failing after upgrade to 0.28

Post by daraden » Tue Aug 07, 2018 2:01 pm

do you have a working .mythtv/config.xml in the users home directory?

phackmann
Newcomer
Posts: 6
Joined: Sun Aug 05, 2018 9:08 pm
United States of America

Re: mytharchive script failing after upgrade to 0.28

Post by phackmann » Wed Aug 08, 2018 3:03 am

That was a good call! I have 2 users on my mythtv box, and the active one is the mythtv user. It does have a valid copy of config.xml in it's user home directory. I copied that same file to the folder in the secondary user (which had an empty config.xml file in it), and then mytharchive started working. How could mytharchive be looking in the wrong user folder?

phackmann
Newcomer
Posts: 6
Joined: Sun Aug 05, 2018 9:08 pm
United States of America

Re: mytharchive script failing after upgrade to 0.28

Post by phackmann » Wed Aug 08, 2018 11:38 pm

Nevermind. It was logging in as the other user. That explains the problem. Thanks for the help daraden!

Post Reply