[Solved] Missing libmythxxx.so files

For discussion of topics specific to MythTV on linux
Post Reply
peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

[Solved] Missing libmythxxx.so files

Post by peteh » Mon Jun 11, 2018 4:45 pm

I've just compiled myth-29 (not the arch version) on manjaro and it was missing library files. I checked and they were all there (/usr/local/lib) so I assumed that for some reason mythfrontend was looking in the wrong place.
I copied all the files from /usr/local/lib to /usr/lib and myth now works perfectly.
Is there an easy way to point myth in the right direction? I've got it working, as I said, but it seems a bit over the top to copy all those files. Copying, of course, was easier than linking but I wonder why the configure/make/make install installs all the files in /usr/local but then looks elsewhere for the libmyths once running.
Pete

User avatar
bill6502
Developer
Posts: 1052
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Missing libmythxxx.so files

Post by bill6502 » Mon Jun 11, 2018 5:13 pm

Hi,

Don't recall doing anything manually, but see if this gives you a start:

Code: Select all

$ cat /etc/ld.so.conf.d/libc.conf 
# libc default configuration
/usr/local/lib
That's from my mythbuntu and Ubuntu hosts.

peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

Re: Missing libmythxxx.so files

Post by peteh » Mon Jun 11, 2018 6:59 pm

Thanks bill6502. I'll try that later and let you know.
Pete

peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

Re: Missing libmythxxx.so files

Post by peteh » Tue Jun 12, 2018 4:56 pm

All my main library files are in /usr/lib/ in manjaro. I've installed myth-29 from source on 3 systems now and all myth lib files are placed in /usr/local/lib but it's only manjaro that doesn't see them there.
bill6502, I think your code covers all lib files but it's only libmythxxx on manjaro that gets it wrong.
I don't know if you've tried manjaro but they have all lib files in /usr/lib/ and then symlink /lib, /lib64, /usr/lib64 to /usr/lib, so I think this anomaly is part of the manjaro system.
It seems my original solution is the correct one unless I symlink all the libmyth files - a rather laborious task.
Pete

User avatar
bill6502
Developer
Posts: 1052
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Missing libmythxxx.so files

Post by bill6502 » Tue Jun 12, 2018 5:39 pm

I don't use manjaro. Wondering if this will help:

Code: Select all

$ ldconfig  --print-cache|grep myth
	libmythupnp-30.so.30 (libc6,x86-64) => /usr/local/lib/libmythupnp-30.so.30
	libmythupnp-30.so (libc6,x86-64) => /usr/local/lib/libmythupnp-30.so
	libmythui-30.so.30 (libc6,x86-64) => /usr/local/lib/libmythui-30.so.30
...
You may need to rebuild the cache after adding the .conf file above. Try
sudo ldconfig .

MikeB2013
Senior
Posts: 286
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: Missing libmythxxx.so files

Post by MikeB2013 » Tue Jun 12, 2018 6:00 pm

Don't know about manjaro, but assuming you built from source using ./configure it uses prefix of /usr/local unless you tell ./configure otherwise e.g. use ./configure --prefix=/usr

Note if using ccache you need to clear it (ccache -C) and fully clean you git tree.

Mike

peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

Re: Missing libmythxxx.so files

Post by peteh » Wed Jun 13, 2018 2:29 pm

I didn't change anything in the ./configure and all the libmythxxx files are installed correctly - ie /usr/local/lib. But what's happening, only in manjaro, is that mythfrontend looks in /usr/lib/. I've fixed it my way, it's just curious what causes it.
I've installed from source in opensuse (leap and tumbleweed) with no issues.
Pete

User avatar
bill6502
Developer
Posts: 1052
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Missing libmythxxx.so files

Post by bill6502 » Wed Jun 13, 2018 3:51 pm

I assume you tried the sudo ldconfig, but just didn't mention it.
Could need to remove all the stuff in /usr/lib 1st, I really don't
know how duplicates are handled.

Check this, to see if the directory I mentioned earlier is even used:

Code: Select all

$ cat /etc/ld.so.conf
include /etc/ld.so.conf.d/*.conf
There's this: http://tldp.org/HOWTO/Program-Library-H ... aries.html
especially 3.3.1 that could be added at runtime. Setting LD_LIBRARY_PATH
would be better than copying everything.

Beyond that, I'm officially stumped.

peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

Re: Missing libmythxxx.so files

Post by peteh » Wed Jun 13, 2018 5:03 pm

I'm not in manjaro at the moment so I'll look later and recheck that cat /etc/ld.so.conf... and ldconfig.
Pete

peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

Re: Missing libmythxxx.so files

Post by peteh » Wed Jun 13, 2018 5:51 pm

This what I get from ldconfig

Code: Select all

sudo ldconfig --print-cache | grep myth
[sudo] password for root: 
	libmythupnp-29.so.29 (libc6,x86-64) => /usr/lib/libmythupnp-29.so.29
	libmythui-29.so.29 (libc6,x86-64) => /usr/lib/libmythui-29.so.29
	libmythtv-29.so.29 (libc6,x86-64) => /usr/lib/libmythtv-29.so.29
	libmythswscale.so.4 (libc6,x86-64) => /usr/lib/libmythswscale.so.4...etc
Trying 'cat /etc/ld-so.conf ...' gets no such file.
So, as you can see, the original libmyth files are not being seen in manjaro /usr/local/lib/ even though myth put them there.
It's working fine with the copies in /usr/lib so I'll carry on that way.
Pete

User avatar
bill6502
Developer
Posts: 1052
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Missing libmythxxx.so files

Post by bill6502 » Wed Jun 13, 2018 6:15 pm

Sorry to hear that. Guess I'd create the file and directory, then put the path
in a .conf file.) Then run sudo ldconfig to update the cache.

But, I'll go away now.

peteh
Junior
Posts: 17
Joined: Tue Jun 05, 2018 5:10 pm
Location: West Yorkshire
Great Britain

Re: Missing libmythxxx.so files

Post by peteh » Wed Jun 13, 2018 10:24 pm

You were right bill6502. I created the conf with /usr/local/lib/ added, removed all the copy files from /usr/lib/ and ran ldconfig. Mythtv now works as it should. The strange thing is that neither of the opensuse systems needed that ld.so.conf.d file.
Thanks.
Pete

User avatar
bill6502
Developer
Posts: 1052
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Missing libmythxxx.so files

Post by bill6502 » Wed Jun 13, 2018 10:30 pm

Thanks for testing that! Sounds like the other boxen include it as a default, or it's just magic.

Post Reply