PVR-150 low volume after upgrade to MythTV 29

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
chunter2
Newcomer
Posts: 10
Joined: Tue Mar 04, 2014 7:53 pm
Canada

PVR-150 low volume after upgrade to MythTV 29

Post by chunter2 » Wed Jun 06, 2018 1:30 pm

I just upgraded to MythTV 29 from 0.28 on my system and my parents system both running Mythbuntu 16.04. I used the Mythbuntu PPA to do the upgrade. Both have PVR-150's recording off a satellite box. Since the upgrade the volume level in the recordings are all really low. I thought it may have been something with the frontend but playing back recording from MythTV 0.28 still sound fine. Also, recordings off my HDHomerun are fine before and after the upgrade. I poked around mythtv-setup but didn't notice anything to do with recording volume. Have I missed something?

wesnewell
Senior
Posts: 370
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: PVR-150 low volume after upgrade to MythTV 29

Post by wesnewell » Wed Jun 06, 2018 6:18 pm

Go through the audio setup and test again to find which options give you the best/loudest results.
BE/FE-AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

chunter2
Newcomer
Posts: 10
Joined: Tue Mar 04, 2014 7:53 pm
Canada

Re: PVR-150 low volume after upgrade to MythTV 29

Post by chunter2 » Thu Jun 07, 2018 2:43 am

It's the recordings themselves that have low volume, not the playback from the frontend. One recording was when the backend was at 0.28 and the audio is "loud". The other recording was after the upgrade, so version 29 and the audio is low. I could play them with a different media player and see the same issue. Is there any backend audio settings?

chunter2
Newcomer
Posts: 10
Joined: Tue Mar 04, 2014 7:53 pm
Canada

Re: PVR-150 low volume after upgrade to MythTV 29

Post by chunter2 » Tue Jun 12, 2018 11:57 pm

I just looked at the wiki and found this page.

https://www.mythtv.org/wiki/Setup_Recording_Profiles

Looks like this doesn't match version 29. If you look at the IVTV MPEG-2 Encoders section it talks about Audio Quality settings. The only setting that's left in Myth 29 is the codec. Any idea where the other settings went for audio?

chunter2
Newcomer
Posts: 10
Joined: Tue Mar 04, 2014 7:53 pm
Canada

Re: PVR-150 low volume after upgrade to MythTV 29

Post by chunter2 » Wed Jun 13, 2018 12:40 am

Running the following on the command line fixes the current recording but it reverts back on new recordings.

v4l2-ctl --set-ctrl=volume=63500 -d /dev/video0

I could put it in my channel change script but this seems like a hack. Any other ideas?

Post Reply