LIRC 10.0-2 bug?

For discussion of topics specific to MythTV on linux
Post Reply
wesnewell
Senior
Posts: 372
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

LIRC 10.0-2 bug?

Post by wesnewell » Fri May 25, 2018 4:28 am

ubuntu 18.04lts upgraded from mythbuntu 16.04lts
kernel 4.15
lirc 10.0-2
Remote doesn't work in mythtv or with irw unless during boot I keep pushing remote button until i get to frontend. Once I exit to desktop, remote doesn't work with irw or if I restart the frontend it doesn't work. I can get it working again by going to terminal, stopping lircd with systemctl stop lircd and starting it again with systemctl start lircd. Then irw and/or frontend will work again Rinse and repeat for same results. Here's lirc_options.conf file. Anyone know how to fix this?
[lircd]
nodaemon = False
driver = default
device = /dev/lirc0
output = /var/run/lirc/lircd
pidfile = /var/run/lirc/lircd.pid
plugindir = /usr/lib/x86_64-linux-gnu/lirc/plugins
permission = 666
allow-simulate = No
repeat-max = 600
#effective-user =
#listen = [address:]port
#connect = host[:port]
#loglevel = 6
#release = true
#release_suffix = _EVUP
#logfile = ...
#driver-options = ...

[lircmd]
uinput = False
nodaemon = False

# [modinit]
# code = /usr/sbin/modprobe lirc_serial
# code1 = /usr/bin/setfacl -m g:lirc:rw /dev/uinput
# code2 = ...


# [lircd-uinput]
# add-release-events = False
# release-timeout = 200
# release-suffix = _EVUP
BE/FE-AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

wesnewell
Senior
Posts: 372
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: LIRC 10.0-2 bug?

Post by wesnewell » Sat May 26, 2018 4:03 am

Upgraded another frontend machine tonight and has the exact same problem, although I found that on either machine, if I keep pushing buttons on the remote, it eventually starts working. But this takes up to 5 minutes. All seems to work well after that. Very disheartening after using lirc for over 10 years without a problem.
BE/FE-AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Mythological
Newcomer
Posts: 5
Joined: Mon Jun 02, 2014 9:12 pm
Canada

Re: LIRC 10.0-2 bug?

Post by Mythological » Wed Jul 25, 2018 8:49 am


wesnewell
Senior
Posts: 372
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: LIRC 10.0-2 bug?

Post by wesnewell » Wed Jul 25, 2018 9:26 pm

Don't know. Mute point now that I switched to ir-keytable and no regrets.
BE/FE-AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Post Reply