Hauppauge HD-PVR2 / Colossus2 support

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Sat Feb 16, 2019 4:45 pm

ibedonc wrote:
Sat Feb 16, 2019 4:29 pm
do I need to turn up the log level ?
Yes please. Run mythbackend with "-v channel,record".

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Feb 19, 2019 2:30 pm

logs.zip
(5.28 KiB) Downloaded 3 times
finally was able to do a new test with debug

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Tue Feb 19, 2019 3:53 pm

Hi ibedonc. Does it work for recordings?

MythTV's "Live TV" is problematic, and that could be your problem. At some point I may try to carve out some time to improve it.

This should not be your problem, but I also noticed some warnings about "Found multiple visible channels for 135", which means that MythTV is having to randomly pick which one to use.

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Feb 19, 2019 4:00 pm

I will have to check recordings
when I get home today

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Feb 19, 2019 4:02 pm

I will try and clean up the multiple channels ,, what about the segfault ?

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Tue Feb 19, 2019 5:39 pm

ibedonc wrote:
Tue Feb 19, 2019 4:02 pm
what about the segfault ?
I would need to see a backtrace. Please open a ticket. You can find instructions here: https://code.mythtv.org/trac/wiki/TicketHowTo

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Thu Feb 21, 2019 4:20 pm

I have not had much time to mess with this , but it looks like recordings are working
it just crashes in Livetv

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Mon Feb 25, 2019 4:03 pm

works in recordings , crashing in live , I also use the hdhrrecording blackbox for Premium TV and it works in Livetv

I had to install mythtv-dbg , I removed it for shorter upgrade times , I will try to get a dump soon

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Mon Feb 25, 2019 4:05 pm

The issue is probably due to some timeout somewhere. The Hauppauge USB stuff can be slow to initialize.

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Mon Feb 25, 2019 5:39 pm

I also have a HDPVR 1212 working , was wanting to replace it with another Colossus2

I am see livetv fail with this
TVRecEvent tv_rec.cpp:3949 (TuningSignalCheck) TVRec[21]: TuningSignalCheck: SignalMonitor failed
Feb 24 19:34:07 myth-be-01b mythbackend: mythbackend[7999]: I TVRecEvent tv_rec.cpp:4419 (ClearFlags) TVRec[21]: ClearFlags(NeedToStartRecorder,) -> FrontendReady,RunMainLoop,CancelNextRecording,WaitingForSignal,SignalMonitorRunning,DummyRecorderRunning,RingBufferReady, @ tv_rec.cpp:3951
Feb 24 19:34:07 myth-be-01b mythbackend: mythbackend[7999]: I TVRecEvent tv_rec.cpp:730 (SetRecordingStatus) TVRec[21]: SetRecordingStatus(Recording->Recorder Failed) on line 4012


then if I leave change the channel , I get

ExternSH recorders/ExternalStreamHandler.cpp:95 (Ready) poll error
Feb 24 19:34:22 myth-be-01b mythbackend: mythbackend[7999]: C CoreContext signalhandling.cpp:305 (handleSignal) Received Segmentation fault: Code 1, PID 32, UID 0, Value 0x00000000

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Fri Mar 01, 2019 12:58 pm

I got a core dump , I will open a ticket

ibedonc
Junior
Posts: 36
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Fri Mar 01, 2019 1:55 pm

#13418 new Bug Report - Crash

Post Reply