LinuxMint18 Make Install Errors

For discussion of topics specific to MythTV on linux
Post Reply
tdborbas
Newcomer
Posts: 1
Joined: Sat Feb 17, 2018 6:14 pm
United States of America

LinuxMint18 Make Install Errors

Post by tdborbas » Sat Feb 17, 2018 7:02 pm

Here is what I got during a MythTV install using make at a terminal session.

make[2]: Leaving directory '/home/timmy/Downloads/mythtv-fixes-29/mythtv/libs/libmythbase'
cd libmythservicecontracts/ && ( test -e Makefile || /usr/lib/x86_64-linux-gnu/qt5/bin/qmake /home/timmy/Downloads/mythtv-fixes-29/mythtv/libs/libmythservicecontracts/libmythservicecontracts pro QMAKE=/usr/lib/x86_64-linux-gnu/qt5/bin/qmake -o Makefile ) && make -f Makefile
Project ERROR: Unknown module(s) in QT: script
Makefile:102: recipe for target 'sub-libmythservicecontracts-make_first' failed
make[1]: *** [sub-libmythservicecontracts-make_first] Error 3
make[1]: Leaving directory '/home/timmy/Downloads/mythtv-fixes-29/mythtv/libs'
Makefile:67: recipe for target 'libs' failedMythTV
make: *** [libs] Error 2

Can anybody please tell me what can I do to fix this error.
Thank you kindly - Timothy

User avatar
paulh
Developer
Posts: 348
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: LinuxMint18 Make Install Errors

Post by paulh » Sat Feb 17, 2018 10:18 pm

My guess would be you are haven't got QtScript or it's development counterpart installed. Don't now about Mint but they will be probably be called something like qtscript5 and qtscript5-dev.

Greg_Muth
Newcomer
Posts: 1
Joined: Fri May 18, 2018 2:35 am
United States of America

Re: LinuxMint18 Make Install Errors

Post by Greg_Muth » Fri May 18, 2018 2:38 am

I got this same error building on Ubuntu 18. Installing qtscript5-dev fixed the problem.

Post Reply