[Solved] Trouble installing V30

For discussion of topics specific to MythTV on linux
Post Reply
204015953JEZ
Newcomer
Posts: 3
Joined: Thu Mar 14, 2019 3:15 am
United States of America

[Solved] Trouble installing V30

Post by 204015953JEZ » Thu Mar 14, 2019 3:36 am

I am having trouble getting Mythtv up an running on Linux Ubuntu 18.04. I had V0.29 installed and I was configuring the application. Things were working, and then my Linux distro asked if I wanted to install an update - and it wiped out V0.29.

Now I am trying to install Mythtv V30 and It is saying that I do not have dependencies installed.

My System
Dell Inspiron AMD
Ubuntu 18.04.2 LTS

PPA: /mythbuntu/30/ubuntu bionic

Error Code - when trying sudo apt-get install mythtv

The following packages have unmet dependencies:
mythtv : Depends: mythtv-database but it is not going to be installed
Depends: mythtv-frontend but it is not going to be installed
Depends: mythtv-backend but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Any suggestions?
Regards

wesnewell
Senior
Posts: 508
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Trouble installing V30

Post by wesnewell » Thu Mar 14, 2019 2:56 pm

http://www.iasptk.com/ubuntu-fix-broken ... -solution/
synaptic also has a selection to fix broken packages under the Edit menu.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

User avatar
paulh
Developer
Posts: 436
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: Trouble installing V30

Post by paulh » Thu Mar 14, 2019 3:59 pm

Sometimes doing a

Code: Select all

sudo apt-get dist-upgrade
beforehand is enough to clean things up and allow the install to go cleanly

204015953JEZ
Newcomer
Posts: 3
Joined: Thu Mar 14, 2019 3:15 am
United States of America

Re: Trouble installing V30

Post by 204015953JEZ » Fri Mar 15, 2019 3:03 am

Thank you for the suggestions. I tried both, but I still ran into the same problem when trying "sudo apt-get install mythtv".

So I tried to install the dependancies it was saying were missing. I installed the following:
sudo apt-get install mythtv-common
sudo apt-get install mythtv-backend
sudo apt-get install mythtv-frontend
sudo apt-get install mythtv-database

Good News is that the GUI setup screens are available.

Bad News - the Database would not create when I ran "sudo dpkg-reconfigure mythtv-database"

Failed to connect to database (incorrect admin password)
ERROR 2003 (HY000): Can't connect to MySQL server on 'Localhost' (111)
ERROR 2003 (HY000): Can't connect to MySQL server on 'Localhost' (111)
ERROR 2003 (HY000): Can't connect to MySQL server on 'Localhost' (111)
ERROR 2003 (HY000): Can't connect to MySQL server on 'Localhost' (111)
ERROR 2003 (HY000): Can't connect to MySQL server on 'Localhost' (111)
Failed to create or modify database (incorrect admin username/password?)
Try:
sudo dpkg-reconfigure mythtv-database


I am not sure how to change the admin username/password -- an suggestions?

thank you in advance for your help.

User avatar
bill6502
Developer
Posts: 1358
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Trouble installing V30

Post by bill6502 » Fri Mar 15, 2019 10:46 pm

Never had the issue, but this may work:

sudo dpkg-reconfigure mysql-server-5.1 (or whatever your version and/or DB is.)

I believe the username/password in play here is in: sudo cat /etc/mysql/debian.cnf,
and that file has a warning to never touch the data in it.

204015953JEZ
Newcomer
Posts: 3
Joined: Thu Mar 14, 2019 3:15 am
United States of America

Re: Trouble installing V30 (SOLVED)

Post by 204015953JEZ » Mon Mar 25, 2019 1:58 am

I solved issue by removing mysql and reinstalling mysql version 7.5 (not the newest one). I was then able to install mythbackend and configure the system.

Thanks to those who provided some advice.

Post Reply