Hauppauge HD-PVR2 / Colossus2 support

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Sat Feb 16, 2019 4:45 pm

ibedonc wrote:
Sat Feb 16, 2019 4:29 pm
do I need to turn up the log level ?
Yes please. Run mythbackend with "-v channel,record".

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Feb 19, 2019 2:30 pm

logs.zip
(5.28 KiB) Downloaded 33 times
finally was able to do a new test with debug

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Tue Feb 19, 2019 3:53 pm

Hi ibedonc. Does it work for recordings?

MythTV's "Live TV" is problematic, and that could be your problem. At some point I may try to carve out some time to improve it.

This should not be your problem, but I also noticed some warnings about "Found multiple visible channels for 135", which means that MythTV is having to randomly pick which one to use.

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Feb 19, 2019 4:00 pm

I will have to check recordings
when I get home today

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Feb 19, 2019 4:02 pm

I will try and clean up the multiple channels ,, what about the segfault ?

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Tue Feb 19, 2019 5:39 pm

ibedonc wrote:
Tue Feb 19, 2019 4:02 pm
what about the segfault ?
I would need to see a backtrace. Please open a ticket. You can find instructions here: https://code.mythtv.org/trac/wiki/TicketHowTo

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Thu Feb 21, 2019 4:20 pm

I have not had much time to mess with this , but it looks like recordings are working
it just crashes in Livetv

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Mon Feb 25, 2019 4:03 pm

works in recordings , crashing in live , I also use the hdhrrecording blackbox for Premium TV and it works in Livetv

I had to install mythtv-dbg , I removed it for shorter upgrade times , I will try to get a dump soon

User avatar
jpoet
Developer
Posts: 19
Joined: Fri Feb 07, 2014 4:32 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by jpoet » Mon Feb 25, 2019 4:05 pm

The issue is probably due to some timeout somewhere. The Hauppauge USB stuff can be slow to initialize.

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Mon Feb 25, 2019 5:39 pm

I also have a HDPVR 1212 working , was wanting to replace it with another Colossus2

I am see livetv fail with this
TVRecEvent tv_rec.cpp:3949 (TuningSignalCheck) TVRec[21]: TuningSignalCheck: SignalMonitor failed
Feb 24 19:34:07 myth-be-01b mythbackend: mythbackend[7999]: I TVRecEvent tv_rec.cpp:4419 (ClearFlags) TVRec[21]: ClearFlags(NeedToStartRecorder,) -> FrontendReady,RunMainLoop,CancelNextRecording,WaitingForSignal,SignalMonitorRunning,DummyRecorderRunning,RingBufferReady, @ tv_rec.cpp:3951
Feb 24 19:34:07 myth-be-01b mythbackend: mythbackend[7999]: I TVRecEvent tv_rec.cpp:730 (SetRecordingStatus) TVRec[21]: SetRecordingStatus(Recording->Recorder Failed) on line 4012


then if I leave change the channel , I get

ExternSH recorders/ExternalStreamHandler.cpp:95 (Ready) poll error
Feb 24 19:34:22 myth-be-01b mythbackend: mythbackend[7999]: C CoreContext signalhandling.cpp:305 (handleSignal) Received Segmentation fault: Code 1, PID 32, UID 0, Value 0x00000000

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Fri Mar 01, 2019 12:58 pm

I got a core dump , I will open a ticket

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Fri Mar 01, 2019 1:55 pm

#13418 new Bug Report - Crash

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Mon Apr 08, 2019 1:14 am

interesting , since there is no more Silicon Dust PTV , I removed the external recorders for that and now yours now works in livetv

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Jul 16, 2019 2:08 am

I am v30 now and using / testing 2 Colossus2's
they work , even with livetv , but with some issues
like when I change channels in livetv , it will go back to the menu , I watch recordings , but my wife watches nothing but livetv
any settings I need to check in mythtv-setup ?

I am getting in syslog
ul 15 20:50:01 myth-be-01b CRON[26696]: (root) CMD ([ -x /usr/sbin/mythtv-update-motd ] && /usr/sbin/mythtv-update-motd > /dev/null)
Jul 15 20:52:40 myth-be-01b mythtv: changing dish1 to 9490 on SCI
Jul 15 20:52:40 myth-be-01b upowerd[5407]: unhandled action 'unbind' on /sys/devices/pci0000:00/0000:00:03.0/0000:05:00.0/usb5/5-1/5-1:1.0
Jul 15 20:52:41 myth-be-01b kernel: [11984.706111] usb 7-1: reset high-speed USB device number 3 using xhci_hcd
Jul 15 20:52:41 myth-be-01b upowerd[5407]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:03.2/0000:06:00.0/usb7/7-1/7-1:1.0
Jul 15 20:54:48 myth-be-01b mythtv: changing dish3 to 9490 on SCI
Jul 15 20:54:49 myth-be-01b upowerd[5407]: unhandled action 'unbind' on /sys/devices/pci0000:00/0000:00:03.2/0000:06:00.0/usb7/7-1/7-1:1.0
Jul 15 20:54:49 myth-be-01b kernel: [12112.778663] usb 5-1: reset high-speed USB device number 3 using xhci_hcd
Jul 15 20:54:49 myth-be-01b upowerd[5407]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:03.0/0000:05:00.0/usb5/5-1/5-1:1.0

I have not found anything in google yet that helps with those
I see a lot of USB resets
system is a supermicro X10SDV-7TP4F which is a 8 core cpu and 128gb of ECC dr4 ram
ubuntu 18.04-2

ibedonc
Junior
Posts: 50
Joined: Wed Dec 14, 2016 3:54 pm
United States of America

Re: Hauppauge HD-PVR2 / Colossus2 support

Post by ibedonc » Tue Jul 16, 2019 5:41 pm

also why am I seeing
[68709.174800] usb 7-1: reset high-speed USB device number 3 using xhci_hcd
[68709.622807] usb 5-1: reset high-speed USB device number 3 using xhci_hcd

when ever the hauppauge2 is run
even with hauppauge2 -l

Post Reply