[Solved] Error in trying to build MythTV v 0.29 in Debian 9.6

For discussion of topics specific to MythTV on linux
kross
Newcomer
Posts: 3
Joined: Sun Dec 30, 2018 4:27 am
United States of America

Re: Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kross » Sun Dec 30, 2018 9:17 pm

I modified the changelog . in (and maybe changelog, don't remember now) in the debian folder by just appending -kevin to the version in the changelog, and did a local git commit (otherwise it gets overwritten). I then deleted the mythtv folder, and let the build script recreate it. It then proceeded to build as normal.

Hope this helps!
-- Kevin

kommiisar6
Junior
Posts: 15
Joined: Thu Dec 13, 2018 12:36 am
Zimbabwe

Re: Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kommiisar6 » Mon Dec 31, 2018 7:41 pm

What is the command to perform a local git commit?

kross
Newcomer
Posts: 3
Joined: Sun Dec 30, 2018 4:27 am
United States of America

Re: Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kross » Mon Dec 31, 2018 9:23 pm

git add <files>
git commit

kommiisar6
Junior
Posts: 15
Joined: Thu Dec 13, 2018 12:36 am
Zimbabwe

Re: Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kommiisar6 » Wed Jan 02, 2019 8:28 pm

You da man. That worked. I edited /build/packaging/deb/debian/changelog.in and added a "-stretch" to the end of the myth version on the first line.

i.e.

mythtv (2:29.1+fixes-stretch) bionic; urgency=medium

then

$ git add changelog.in
$ git commit

I then changed to correct build directory

$ cd /build/packaging/deb/
$ ./build-debs.sh fixes/29

This successfully completed the building of the debs.

kbocek
Junior
Posts: 80
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kbocek » Sat Jan 19, 2019 10:36 pm

Thank you for the detailed instructions kommiisar6. Being a CentOS man, I'm finding myself pushed into Debian because of my Raspberry Pis. A good thing to have a more up-to-date OS than CentOS. I was trying to get Myth installed on a ECS Liva and was disappointed to discover there are no prebuilt packages for AMD64.

It's happily compiling now.

...and happily compiled.

kommiisar6
Junior
Posts: 15
Joined: Thu Dec 13, 2018 12:36 am
Zimbabwe

Re: Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kommiisar6 » Tue Jan 22, 2019 11:30 am

Credit goes to kross for figuring this out, not me.

kbocek
Junior
Posts: 80
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: [Solved] Error in trying to build MythTV v 0.29 in Debian 9.6

Post by kbocek » Thu Jan 24, 2019 8:26 pm

Well then thanks kross. Kommiisar6 I withdraw my appreciation ;)

Post Reply