trouble creating transports new install 0.29 and old 0.28

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
briggella
Newcomer
Posts: 14
Joined: Tue Jun 05, 2018 11:52 am
New Zealand

trouble creating transports new install 0.29 and old 0.28

Post by briggella » Tue Jun 05, 2018 7:06 pm

Had an old 0.28 system which had been upgraded several times running on xfce on which I needed to edit the transports after an upgrade. When trying to do so I received the error message. “The Video sources to which this transport is connected are incompatible. Please create separatevideo sources for these cards.” Having done that then deleting the sources, then not being able to create new transports on the new sources due to the same error message, I decided to reinstall and move up to 0.29.

I have now upgraded after the usual difficulties with a Myth install and am now on Xubuntu. I have restored my old database so can watch old recordings but when trying to create new transports I get the same error message. The logs are unhelpful merely saying this message repeatedly from mythtv-setup.log

“Mythbox mythtv-setup.real: mythtv-setup[2608]: E CoreContext videosource.cpp:3608 (sourceFetch) Skipping channel fetch, you need to scan for channels first.”


There is nothing online about this. Any ideas. I am stuck.
mythtv-setup-last200lines_log.txt
Managed to attach the last 200 lines of mythtv-setup.log to see if that helps anyone.
(29.86 KiB) Downloaded 8 times
Further info

having dug a bit further, it appears that the firmwares
dvb-demod-m88ds3103.fw
dvb-demod-m88rs6000.fw
dvb-demod-si2168-02.fw
NXP7164-2010-03-10.1.fw
v4l-saa7164-1.0.2-3.fw
v4l-saa7164-1.0.3-3.fw

were missing from the install even though i could setup the tuner cards which seemed strange. I have now installed these and setup 3 tuners and now have transports which do detect a signal but no channels even though they have the correct parameters. All I get with the satellite card is 'error parsing parameters' and with terrestrial there are no channels and all I get in the logs is the following

Jun 10 20:44:03 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 68
Jun 10 20:44:04 Mythbox mythtv-setup.real: mythtv-setup[2055]: I ScreenLoad recorders/vboxutils.cpp:49 (probeDevices) VBox: Using UPNP to search for Vboxes (3 secs)
Jun 10 20:44:07 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 68
Jun 10 20:44:07 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 68
Jun 10 20:44:08 Mythbox mythtv-setup.real: mythtv-setup[2055]: I ScreenLoad recorders/vboxutils.cpp:49 (probeDevices) VBox: Using UPNP to search for Vboxes (3 secs)
Jun 10 20:44:11 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 77
Jun 10 20:44:11 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 68
Jun 10 20:44:11 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 77
Jun 10 20:44:11 Mythbox mythtv-setup.real: mythtv-setup[2055]: W ScreenLoad diseqc.cpp:395 (Load) DiSEqCDevTree: No device tree for cardid 77

briggella
Newcomer
Posts: 14
Joined: Tue Jun 05, 2018 11:52 am
New Zealand

Re: trouble creating transports new install 0.29 and old 0.28

Post by briggella » Thu Jun 14, 2018 10:46 am

Found the above is due to incorrect permissions being set on the /dev/dvb/adaptor(0-7) tuner cards
In the end as i seem to be getting nowhere i have abandoned this and just reinstalled with a simplified installation and it has installed properly. However I am now stuck at channel scanning not finding any channels but I may post that elsewhere.

The original error message was caused by each tuner card wanting its own video source file.
In terms of Feedback, I have been in installing mythtv for 10 years now and this has got to be the most difficult install yet. It seems to be getting harder rather than easier.

Post Reply