Master/0.28 is moving to QT 5.2

Master/0.28 is moving to QT 5.2

Postby stuartm » Sun Mar 01, 2015 1:09 pm

Within the next couple of weeks we will be switching the minimum QT version
from 4.8 to 5.2*

QT 4 goes End of Life at the end of this year and so we want our next release,
the one users will be using past this deadline to be built on QT 5. Having
access to some of the features of QT 5 is also a nice benefit.

*5.2 was selected as the minimum version as this is the lowest version offered
by all distros we surveyed. We won't rule out a move to a more recent version,
i.e. 5.4 which is already available for most distros sometime before the
release.

We're on the hunt for bugs caused by the switch to QT 5 and this is something
you can help us with. So please make sure you're ready for the switch, the
earlier you start the transition to QT 5 the smoother the process will be.
User avatar
Great Britainstuartm
Developer
 
Posts: 125
Joined: Wed Feb 05, 2014 5:17 pm

Re: Master/0.28 is moving to QT 5.2

Postby stuarta » Mon Mar 02, 2015 3:51 pm

Please be aware that whilst 0.27 will build against Qt5, there are many things that DO NOT WORK properly. This is an unsupported configuration. Due to the complexity of the changes, we will not be backporting Qt5 fixes to 0.27
User avatar
Great Britainstuarta
Developer
 
Posts: 172
Joined: Wed Feb 05, 2014 5:13 pm

Re: Master/0.28 is moving to QT 5.2

Postby treblid » Tue Apr 14, 2015 4:56 am

Just a headsup for folks running Master and using icewm as window manager. You'd need to use icewm v1.3.8+ else the Qt5 GUI will not load (For all Qt5 apps, not just MythTV).

Some basic info here: Linky.

I'm using Ubuntu LTS and the latest icewm is still 1.7.x. Manually updating to v1.3.8 and mythfrontend starts up fine now...

Hopefully this will help someone in a similar situation.
Australiatreblid
Newcomer
 
Posts: 1
Joined: Tue Feb 11, 2014 5:33 am


Return to General Development



Who is online

Users browsing this forum: No registered users and 2 guests