leanfront requirements

For discussion of topics specific to MythTV on Android devices
Post Reply
crabb
Newcomer
Posts: 3
Joined: Sun Dec 20, 2020 3:35 am
United States of America

leanfront requirements

Post by crabb » Sun Dec 20, 2020 3:55 am

Does the leanfront frontend have any particular android requirements? I'm trying to run it on a Fire TV 2nd gen (pendant style, not stick), which is based on android 5.1.1 with API level 22. I installed leanfront-v0-239-g7770891. When I launch it, the screen blanks and then it drops right back to home screen. I am able to run the official mythfrontend and kodi on the same device. So I'm wondering if the leanfront frontend needs a later version of android or the API?

Otherwise, any tips for debugging?

thanks.

User avatar
jfabernathy
Senior
Posts: 366
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: leanfront requirements

Post by jfabernathy » Sun Dec 20, 2020 12:29 pm

I originally had a FireTV stick that was not 4K and none of the mythtv apps work very well on it at all; really unusable for HD programming.

The FireTV 4K and FireTV Cube will run mythtv-leanfront and mythtv-frontend nicely.

I just tested leanfront-v0-239-g7770891 on my FireTV 4K stick and it works nicely. Fire TV OS 6.2.7.7

User avatar
pgbennett
Developer
Posts: 416
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: leanfront requirements

Post by pgbennett » Sun Dec 20, 2020 2:23 pm

Minimum api version is 21, so it should run.

I have tested leanfront on a fire stick second gen, but not recently. I will test it again to see if it still works. However, the fire stick second gen does not handle MPEG2 well, it stops and starts. Also it does not deinterlace. So if you only have H264 content not interlaced it would be workable.

If you capture the output of adb log in a file, I will take a look to see what is happening. Please open a ticket on github, at https://github.com/bennettpeter/android ... ont/issues and attach the adb log or a link to pastebin with the adb log.

User avatar
pgbennett
Developer
Posts: 416
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: leanfront requirements

Post by pgbennett » Sun Dec 20, 2020 7:29 pm

OK I found the problem. The latest version is not working with the fire stick. I will get a fix done.

crabb
Newcomer
Posts: 3
Joined: Sun Dec 20, 2020 3:35 am
United States of America

Re: leanfront requirements

Post by crabb » Sun Dec 20, 2020 7:59 pm

Ack! I just created a new ticket on github before I saw your second reply. Thanks for checking it out!

User avatar
pgbennett
Developer
Posts: 416
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: leanfront requirements

Post by pgbennett » Sun Dec 20, 2020 8:18 pm

Fix in v0-240-g97a6708. Let me know if there are still problems.

User avatar
pgbennett
Developer
Posts: 416
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: leanfront requirements

Post by pgbennett » Sun Dec 20, 2020 8:31 pm

Trying leanfront again on the fire stick gen2, MPEG2 as well as H264 seem to work well now. The only problem I see is that there is no deinterlace.

User avatar
heyted
Senior
Posts: 204
Joined: Sun Jun 08, 2014 2:14 am
Location: South Florida
Contact:
United States of America

Re: leanfront requirements

Post by heyted » Sun Dec 20, 2020 11:48 pm

Leanfront on non-4K 3rd gen Fire TV Stick with Comcast cablecard HD appears to be working fine. I just bought one and tried it.

Edit: Fixed grammar
Last edited by heyted on Tue Dec 22, 2020 12:48 pm, edited 1 time in total.
Ted | My blog

crabb
Newcomer
Posts: 3
Joined: Sun Dec 20, 2020 3:35 am
United States of America

Re: leanfront requirements

Post by crabb » Mon Dec 21, 2020 2:55 am

The new version, v0-240-g97a6708, fixes my problem. Thanks again for the quick fix!

Post Reply