Shield TV Frontend crashing randomnly

For discussion of topics specific to MythTV on Android devices
Post Reply
jksj
Senior
Posts: 125
Joined: Thu Feb 13, 2014 7:53 pm
Great Britain

Shield TV Frontend crashing randomnly

Post by jksj » Wed Sep 16, 2020 10:08 am

version mythfrontend-20200716-arm-v31.0-79-g89d1991ef2
Shield TV version 8.2
I am using a recently purchased (2 weeks) Shield TV to run the frontend in the UK for watching FreeSAT.
Cant use Leanfront as this won't play UK dvb 1080i 25 Hz format with any degree of reliability.
The frontend runs flawlessly usuing Opengl High Quality but seems to randomly die every 3-4 hours.
During playback the frontend seems to just instantly exit and the Shield shows the home screen.
The adb log shows only the next run, so is presumably cleared, I will try monitoring all the time.
I vaguely remember there was an issue where android randomly killed processes it didn't like, can anyone remember the fix.

jksj
Senior
Posts: 125
Joined: Thu Feb 13, 2014 7:53 pm
Great Britain

Re: Shield TV Frontend crashing randomnly

Post by jksj » Thu Sep 17, 2020 9:09 pm

Just an update
Turning on "Stay awake" in android "Developer options" has got me one night of trouble free viewings.
Will report again.

jksj
Senior
Posts: 125
Joined: Thu Feb 13, 2014 7:53 pm
Great Britain

Re: Shield TV Frontend crashing randomnly (suspect screensaver)

Post by jksj » Tue Sep 22, 2020 8:35 am

Update - 3 days reliable operation then one incident. May just be a period of good luck but I still suspect the Android screensaver. The TV itself which is displaying the output from the Shield also runs Android TV and used to prompt for 'press any key 'on its own remote after 4 hours. I haven't seen this message since using the Shield, so setting "Stay awake" in android "Developer options" on the TV as well.

There must be a less obscure option for killing the screensaver?

jksj
Senior
Posts: 125
Joined: Thu Feb 13, 2014 7:53 pm
Great Britain

Re: Shield TV Frontend crashing randomnly

Post by jksj » Fri Sep 25, 2020 10:39 am

Crashed twice on me last night in the first hour so definitely not screensaver related. So the issue must be related to the broadcast content which is UK DVB-S2 HD 1080i. I suspect the encoding on Channel 4 HD. Anyway the issue is none repeatable so relegating the Shield to a bedroom TV. Will try the Firestick 4k, which sadly is not quite as good.

For the record Software Decoding with
SetDeinterlacing VideoOutput: SetDeinterlacing (Doublerate 1): Single High|CPU|GLSL Double High|CPU|GLSL
and
SetDeinterlacing VideoOutput: SetDeinterlacing (Doublerate 1): Single None Double None
both fail randomnly but do give a perfect picture :x

Post Reply