Solved: Audio Sync issues - Nvidia Shield TV, mythfrontend

For discussion of topics specific to MythTV on Android devices
Post Reply
loddonlily
Junior
Posts: 40
Joined: Sun Mar 31, 2019 10:03 am
Great Britain

Solved: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by loddonlily » Mon Jan 09, 2023 6:06 pm

Sooo... my HTPC just blew up so I figured it might be time to revert to my Nvidia Shield TV, which had been working fine until a year ago when I foolishly allowed it to upgrade itself to v9 sw. So I upgrade the Shield to the latest software (9.1.something), get the latest mythfrontend (32+fixes), and see what I can get going.

It's mostly working - I can connect to the database and play recordings (generally UK DVB-T2). I have two problems, one of which I'll leave for another thread.

In this thread I want to explore audio sync - its annoyingly out and although I've rootled around the settings and fiddled with everything I can think of, nothing seems to work. I've looked in the wiki but unfortunately the detailed options given are not current for either mythfrontend or the Shield.

I also installed a recent leanfront mythtv client for comparison: the audio sync is much better, though I really don't want to use this client. I also have Kodi installed and its audio sync is fine. Consequence of that is that I don't want to make a blanket sync adjustment on either the Shield or my TV because that will just throw everything else out. The Shield is connected to a LG TV and from there on to a Sonos sound bar.

Can anyone point me to what I might be able to do in mythfrontend to fix my audio sync issue?


TIA.
Last edited by loddonlily on Tue Jan 10, 2023 6:33 pm, edited 1 time in total.

User avatar
jfabernathy
Senior
Posts: 514
Joined: Wed Feb 18, 2015 2:37 pm
Location: Raleigh, NC
United States of America

Re: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by jfabernathy » Mon Jan 09, 2023 7:34 pm

I used to use mythfrontend on the Shield TV but it was never really good enough for me. There Is a 'M' key function that allows you to do a lot of things and audio sync is one of them. However you need a Keyboard on your Shield TV. I used a Bluetooth keyboard to do a lot of setup on the Frontend.

Once I got a new Sony TV with Google TV builtin, I use that instead of the Shield. With the current state of Leanfront, that's all my wife and I use on both TVs. Her's is a Samsung with FireTV 4K. Because the picture with Leanfront is perfect, I forced myself to learn how to use it properly. Now that Commercial skip is working and I know how to manage recordings with it, I rarely use mythfrontend except for special functions.

loddonlily
Junior
Posts: 40
Joined: Sun Mar 31, 2019 10:03 am
Great Britain

Re: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by loddonlily » Mon Jan 09, 2023 10:52 pm

Thanks for the reply, though "not good enough" wasn't what I was hoping for!

I've carried on bashing options to see what happens, and provisionally I may have hit upon an answer.

In the Shield Settings, Device Preferences / Display & Sound / Advanced Sound Settings ... set "Match content audio resolution" to ON.

I will want to exercise this more before calling it solved, but thought I should note progress!

spearson
Newcomer
Posts: 5
Joined: Mon Aug 15, 2022 3:23 pm
United States of America

Re: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by spearson » Tue Jan 10, 2023 3:44 pm

I too have been trying forever to fix my audio sync issues and I've settled on a setup where my recordings are watchable again. I have two shields, one 2017 that was on v8 with no sync issues, and the 2019 that had no sync issues until I updated it to version 9. At the time I was running myth v31.

my setup was:
MythTV v31
nvidia shield hdmi to cheap costco Samsung 4k tv
tv digital out to old samsung 2.1 sound bar

mine is now:
MythTV v32
nvidia shield hdmi to TV
TV hdmi-arc to sound bar

I realized I was using old hdmi cables so I bought these new high speed cables:
https://www.amazon.com/gp/product/B08BS181P2/

TV settings:
- audio options weren't set for passthrough, so I changed that (had no noticeable effect)

MythTV settings:
- using AudioTrack
- my sound bar only supports Dolby Digital and DTS so I only have those two checked in Digital Audio Capabilities
- even though it's a 2.1 system I have my speaker configuration set to 5.1
- I have upconvert stereo to 5.1 checked
- upmix quality best
- use internal volume controls unchecked
- I use HDHR CC and xfinity

Shield settings:
match content audio resolution: checked
match dolby/pcm audio levels: unchecked
dolby audio processing: unchecked

from what I understand - what you have checked in Digital Audio Capabilities will passthrough those formats up, dolby audio processing while not a passthrough setting is still doing something to the audio track and many people were reporting issues resolved when unchecked, my TV should now pass through to the sound bar, and the sound bar accurately shows it's using Dolby Digital.

Disabling dolby audio processing had a huge effect on correcting my audio sync. Along with the audio being out, the video would sometimes act like it's trying to speed up, that's all gone now. I did have to adjust the audio sync slider in the shieldtv audio settings, but now all my recordings are watchable again. The only outstanding issues is live tv is still terribly off and some channels are worse than others, though pausing and playing can sometimes correct it, and I get audio pops when pausing a recording.

Dolby Audio Processing has had something fixed with it on each new 9+ release and I haven't tried re-enabling after the latest 9.1.1 update.

spearson
Newcomer
Posts: 5
Joined: Mon Aug 15, 2022 3:23 pm
United States of America

Re: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by spearson » Tue Jan 10, 2023 4:04 pm

Also, there is a ton of information out there on mythtv's audio functions (especially the android audiotrack implementation), but it's all buried here or in the mailing list or the wiki, or even in the comments of issues in the old issue tracker. It was frustrating searching and finding so much info all over the place when the best place is the wiki.

loddonlily
Junior
Posts: 40
Joined: Sun Mar 31, 2019 10:03 am
Great Britain

Re: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by loddonlily » Tue Jan 10, 2023 6:32 pm

@spearson ... many thanks for the responses, that was very helpful. That's pretty much what I've ended up with, apart from slightly different capability settings for my soundbar. Good to know that someone else is out there - it was feeling a bit lonely for a moment!

Seems to be working for now!

kwambs
Newcomer
Posts: 2
Joined: Fri Jan 20, 2023 11:44 pm
United States of America

Re: Solved: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by kwambs » Fri Jan 20, 2023 11:54 pm

Hi,

I too have the audio issues with mythtv using the cube TV as the frontend.

I even upgraded to V32 to see if the audio was better, the only change was that most of the time video did not go 2x speed, but the audio was lost when jumping forward. So, I unchecked the Dolby digital, and that stopped the audio loss. However, I don't thing I'm getting dolby audio pass thru to the receiver. I have the cube connected to the TV with ARC HDMI back to the receiver.

Since I used opensuse and there is not a provider of mythtv V32 right now, I had to build the source for the backend. I have not done this for the past 10 years. It was no fun!! I've been using Mythtv since 2004 and still going.....

Kevin

User avatar
jfabernathy
Senior
Posts: 514
Joined: Wed Feb 18, 2015 2:37 pm
Location: Raleigh, NC
United States of America

Re: Solved: Audio Sync issues - Nvidia Shield TV, mythfrontend

Post by jfabernathy » Sat Jan 21, 2023 12:15 pm

I have not had any success with mythfrontend on any Amazon device including the Cube. I also have a Nivida Shield 2017 version. It's barely usable there.

I find that at this point with all the modifications that MythTV Leanfront is the best application for viewing mythtv recordings. I keep mythfrontend installed for the few tasks that it performs well. However, I've forced myself to do most scheduling task with the Mythweb interface and with Leanfront. Now I prefer those methods.

I also have a combo mythtv system on an ASRock NUC 1165G7 which is a good 11th gen Intel Core i7, but sometimes I'll see a playback scene that looks odd and I'll watch that with Leanfront and it's correctly displayed there. So even a $800 PC can have issues with playback.

So IMHO, if you want a cheap high quality MythTV frontend use any Android device, FireTV, Google TV, Nvidia Shield TV, etc. but use Leanfront. Once you get use to it, it becomes the easiest to use. My wife never ask questions on it any more and she always had issues with Mythfrontend.

My experience is based on USA Over The Air TV which is all ATSC 1.0 MPEG2 720P or 1080i.

Post Reply