pi-utils/pi-setup_mythtv_31.sh

For discussion of topics specific to MythTV on Raspberry Pi devices
Post Reply
User avatar
jfabernathy
Senior
Posts: 296
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

pi-utils/pi-setup_mythtv_31.sh

Post by jfabernathy » Sat Jun 20, 2020 5:10 pm

I find all of the pi-utils very useful and thank MikeB for creating them.

Recently with changes happening I noticed that pi-setup_mythtv_31.sh has a small typo. If you choose to install mythplugins it fails due to the typo. The command should be sudo apt install mythplugins-light

I suggest trying these utilities as they have saved me lots of time. https://github.com/MikeB2013/pi-utils
Last edited by jfabernathy on Sat Jun 20, 2020 10:45 pm, edited 1 time in total.

MikeB2013
Senior
Posts: 519
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: pi-utils/pi-setup_mythtv_31.sh

Post by MikeB2013 » Sat Jun 20, 2020 5:37 pm

Jim,
Thanks, I have updated the script on github repository.

Mike.

User avatar
jfabernathy
Senior
Posts: 296
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: pi-utils/pi-setup_mythtv_31.sh

Post by jfabernathy » Thu Jun 25, 2020 4:22 pm

In testing pi-setup_mythtv_v31.sh I've found it works great on the standard PI OS Desktop version. If you want to start with PI OS Lite, you would need to add the following to the script:

Code: Select all

sudo apt install --no-install-recommends xserver-xorg
This may not affect many, but I found this out in testing for someone who wanted a barebones RPi3B+ installation of frontend only for v31.

User avatar
jfabernathy
Senior
Posts: 296
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: pi-utils/pi-setup_mythtv_31.sh

Post by jfabernathy » Sun Aug 02, 2020 3:53 pm

jfabernathy wrote:
Thu Jun 25, 2020 4:22 pm
In testing pi-setup_mythtv_v31.sh I've found it works great on the standard PI OS Desktop version. If you want to start with PI OS Lite, you would need to add the following to the script:

Code: Select all

sudo apt install --no-install-recommends xserver-xorg
This may not affect many, but I found this out in testing for someone who wanted a barebones RPi3B+ installation of frontend only for v31.
I found out something has changed. Today with the latest kernel 5.4.51 changes all I did was create a Raspberry PI OS Lite system, then clone the pi-utils from https://github.com/MikeB2013/pi-utils and run pi-utils/pi-setup_mythtv_31.sh, reboot, then run ./pi-mythbackend-helper.sh, followed by a reboot.

At that point I run ./run_mythsetup.sh and it went into mythtv-setup like you'd expect. No need to install xserver-xorg. Now all I have to do is move the system to a USB3 SSD for speed.

Post Reply