Page 1 of 1

mythtv light, RP4, and 4K resolution problem

Posted: Tue Aug 13, 2019 8:22 pm
by jfabernathy
I have a 4GB RP4 up and running Raspbian Buster. I'm connected to a 4K TV so as a desktop it's unusable from my chair. I can set it to 1080p using Preferences->Screen Configuration. However, that will not stay at 1080P if rebooted.

I tried sudo raspi-config to setup resolutions but I got this error:

/usr/bin/raspi-config: 1543: [: Illegal number: 16:9

I guess it could be a raspi-config bug, but it would be nice to have 1080P at boot.

Not sure if mythfrontend would like running at 4K. I know the content from OTA TV is still 1080i in the USA.

I'll still play with this but looking for recommendations.

Ultimately, the RP4 will be a combo FE/BE for mythtv and will only run the FE at boot. Not sure if that makes it simpler or what.

Re: mythtv light, RP4, and 4K resolution problem

Posted: Wed Aug 14, 2019 1:59 am
by pgbennett
MythTV should run fine at 4K resolution. Have you tried it? Does it cause problems? V30 setup has been updated to allow selection of screen size up to 4K. V29 will work on 4K TV if the setup is set to fuil-screen.

Re: mythtv light, RP4, and 4K resolution problem

Posted: Wed Aug 14, 2019 9:18 am
by stuartm
My personal experience is that performance wise, the UI @ 4k is not a smooth experience with the Pi 4 - this may vary depending on the theme you use and whether you use the QT or GL renderer.

Re: mythtv light, RP4, and 4K resolution problem

Posted: Wed Aug 14, 2019 1:59 pm
by jfabernathy
stuartm wrote:
Wed Aug 14, 2019 9:18 am
My personal experience is that performance wise, the UI @ 4k is not a smooth experience with the Pi 4 - this may vary depending on the theme you use and whether you use the QT or GL renderer.
I agree with your assessment. If I set the TV to work at 4K, mythtv-frontend works fine, but the UI is sluggish and there are short times where the whole UI flashes white. The only time I notice this when the TV is at 1080P is at the startup of the UI. I tried both setting of renderers Auto and QT; no differences

The HD video playback seems to be the same when the TV is set to 4K as 1080P, but since this will be a Mythtv combo FE/BE only, it makes more sense to set it to 1080P. No advantages for 1080i ATSC OTA content. Once the testing is done, I'll move this setup to my RV where the TVs are all 1080p only.