No OSD

User avatar
pgbennett
Developer
Posts: 264
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: No OSD

Post by pgbennett » Sun Apr 22, 2018 9:41 pm

The links should be created when you install mythtv-light, as follows

Code: Select all

pi@eagle2:~ $ ls -l /usr/share/mythtv/lib/
total 0
lrwxrwxrwx 1 root root 25 Feb  8 13:40 libEGL.so.1 -> /opt/vc/lib/libbrcmEGL.so
lrwxrwxrwx 1 root root 25 Feb  8 13:40 libEGL.so.1.0.0 -> /opt/vc/lib/libbrcmEGL.so
lrwxrwxrwx 1 root root 28 Feb  8 13:40 libGLESv2.so.2 -> /opt/vc/lib/libbrcmGLESv2.so
lrwxrwxrwx 1 root root 28 Feb  8 13:40 libGLESv2.so.2.0.0 -> /opt/vc/lib/libbrcmGLESv2.so
pi@eagle2:~ $ 
You should not need any other links. Linking EGL to GLES will likely cause problems.

I guess I should download the latest raspbian stretch and see if I can see the problems.

User avatar
pgbennett
Developer
Posts: 264
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: No OSD

Post by pgbennett » Sun Apr 22, 2018 11:42 pm

I created a new SD card based on April 18th 2018 version of raspbian stretch. I added the MPEG2 license and increased GPU memory to 256M. I installed mythtv-light version 29. Mythfrontend failed to start. I tried it from a console and saw the error message that libGLESv2.so was not found. I don't know why this is happening but I ran this command

Code: Select all

sudo ln -s /opt/vc/lib/libbrcmGLESv2.so /usr/share/mythtv/lib/libGLESv2.so
and after that mythfrontend was fine. Playback and OSD is also fine. (I had previously selected openmax advanced). The playback was a bit glitchy so I updated the governor as described in the wiki. I will update the package to create the missing link when the package is installed. I don't know why that suddenly started happening.

I suggest you try this on a new SD card. It only takes an hour or so. Don't do anything with the SD card other than the minimum (basic settings, GPU, MPEG2 license and install only mythtv-light, nothing else).

Merlin83b
Newcomer
Posts: 11
Joined: Fri Feb 07, 2014 3:37 pm
Great Britain

Re: No OSD

Post by Merlin83b » Sun Apr 29, 2018 9:37 am

Reinstallation did the trick, thanks. I didn't even need to do the GLES link.

I can't get the IEC958 audio to show up in setup/audio, but I'll work on that another time. Like in viewtopic.php?t=582 I had to choose a different audio device, but then ALSA:default vanished and hasn't come back. Using the other device I do get sound though, so not too bad!

Merlin83b
Newcomer
Posts: 11
Joined: Fri Feb 07, 2014 3:37 pm
Great Britain

Re: No OSD

Post by Merlin83b » Sun Apr 29, 2018 9:45 am

I should have fiddled before I posted :)

One of the entries in

Code: Select all

aplay -L
was:

Code: Select all

hw:CARD=ALSA,DEV=1
    bcm2835 ALSA, bcm2835 IEC958/HDMI
    Direct hardware device without any conversions
So I chose that and after using

Code: Select all

alsamixer
to put the volume up to full, that now works well.

DunnPenny
Newcomer
Posts: 1
Joined: Wed Oct 17, 2018 5:17 pm
United States of America

Re: No OSD

Post by DunnPenny » Wed Oct 17, 2018 5:24 pm

Hello, as per my knowledge you don't need more than 256 for GPU memory. Check by running top. You should see total memory if you have 256MB set. If you see something in the 900000 range, your setting of GPU memory did not take effect.

Post Reply