Border on Playback

Post Reply
philrosenberg
Newcomer
Posts: 6
Joined: Thu Apr 16, 2015 8:31 am
Great Britain

Border on Playback

Post by philrosenberg » Sun Aug 07, 2016 12:03 pm

Hi
I am running mythtv frontend v0.28 on an rpi3.

I have got stuff basically working, (I had to change the audio output device to ALSA:hwCARD=ALSA,DEV=0 and the video playback profile to OpenMax Normal to get sound output and smooth video), however I have black borders to the right and bottom of all my playback videos. this happens when watching recordings, live tv and videos. In the gui and normal rpi desktop the screen is correctly filled (although the farthest right both in the default skin is never rendered).

I am connected via hdmi to a Samsung UE40H6400 tv.

I've tried playing with the zoom settings. Setting this to full zooms in too much, using H.Stretch or V.Stretch only stretches in one direction and all other settings do nothing. I tried the screen setup wizard, but this crashed the rpi.

Another problem I have is that when I exit mythfrontend my screen goes black and I have to pull the power to reboot the rpi.

Any help with debugging would be very welcome. I don't know much about how the logging works. If submitting logs would be useful then please let me know how I can access them.

Thanks
Phil

User avatar
pgbennett
Developer
Posts: 321
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: Border on Playback

Post by pgbennett » Sun Aug 07, 2016 3:05 pm

Black Border
I suggest you turn off overscan with raspi-config or by editing the /boot/config.txt and uncommenting or adding the line

Code: Select all

disable_overscan=1
Reboot after changing the setting.
Also, turn off overscan in your TV if that is an option in the TV setup menu.
After this, use MythTV frontend appearance settings and set GUI width, height and both offsets to 0. Also set "Use GUI size for TV playback".
If the MythTV GUI is now too big (i.e. you cannot see all of it), adjust it by setting some values for the width, height and offsets. This is somewhat of a trial and error process.
Screen Blank after exiting
This is probably because MythTV is set to turn off your TV when exiting. You should not power off the RPI without first shutting down. Does powering on the TV again resolve it? This power off is done through the CEC feature of MythTV, which also allows you to use the TV remote to control MythTV.

philrosenberg
Newcomer
Posts: 6
Joined: Thu Apr 16, 2015 8:31 am
Great Britain

Re: Border on Playback

Post by philrosenberg » Sun Aug 07, 2016 3:44 pm

Thanks pgbennet
You were exactly correct with Mythtv turning off the TV via CEC when I exit. Do you know how to disable this feature?

Setting disable_overscan=1 seems to have fixed the border too.

I actually feel like it has reduced the quality a bit though, but I guess I will just have to play with settings to see if I can find a better one.

Thanks for that

Phil

User avatar
pgbennett
Developer
Posts: 321
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: Border on Playback

Post by pgbennett » Sun Aug 07, 2016 7:23 pm

Disabling the power-off feature. The following settings are available.
PowerOffTVAllowed
PowerOffTVOnExit
PowerOnTVAllowed
PowerOnTVOnStart

They all default to 1 (which means enabled). You can disable any of them by setting them to 0 on the command line for mythfrontend as follows

Code: Select all

mythfrontend -O PowerOffTVOnExit=0
or you can disable CEC entirely by setting the following option to 0:
libCECEnabled

TheCook
Newcomer
Posts: 8
Joined: Sun Jan 29, 2017 4:38 am
Australia

Re: Border on Playback

Post by TheCook » Tue Jan 31, 2017 10:51 pm

Changing overscan worked for me too. It is a bit hard to click any of the menus at the 'top' of the screen (they are there somewhere off the screen). I messed with no of pixels and offsets and scaling etc. but things look good now. I also ticked the box to say use a different screen size playback.

MythTV now fully functioning on my Pi now. :D

Post Reply