X11 library has been updated - mythtv-light install now fails

For discussion of topics specific to MythTV on Raspberry Pi devices
Post Reply
cliveb
Junior
Posts: 80
Joined: Fri Jan 08, 2016 9:59 am
Great Britain

X11 library has been updated - mythtv-light install now fails

Post by cliveb » Tue Jun 01, 2021 10:46 am

In my experiments with trying to find a version of the frontend that works reliably on a Pi4, I recently attempted to build a new 0.30 from scratch.
But when attempting to install the .deb file, it fails trying to get an X11 library file (libx11-xcb1_1.6.7-1+deb10u1_armhf.deb).
Poking around the raspbian mirrors, it looks as if this file was replaced on 24th May with libx11-xcb1_1.6.7-1+deb10u2_armhf.deb.
As far as I can tell, this change has broken not only the 0.30 install, but also the 0.31 and 0.32 installs.
I've been looking online for guides to amending .deb files in the hope I could change the dependency to the newer x11 library, but without success.
Any advice?

User avatar
jfabernathy
Senior
Posts: 366
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: X11 library has been updated - mythtv-light install now fails

Post by jfabernathy » Wed Jun 02, 2021 12:58 pm

I'm not seeing any issues. I just started with a clean SSD with Raspberry PI OS (Desktop) and followed my instructions at
https://mythtv-rp4.blogspot.com/2020/11 ... rpi-4.html

I got both the frontend and backend working using EPG from OTA before replying to this post. I'll do the XMLTV next, but I don't think that is your issue.

Let me know if you can't get the instructions to work. Since I wrote them, I can do this in my sleep, so I may not have documented something clearly enough.

Jim A

cliveb
Junior
Posts: 80
Joined: Fri Jan 08, 2016 9:59 am
Great Britain

Re: X11 library has been updated - mythtv-light install now fails

Post by cliveb » Fri Jun 04, 2021 5:25 pm

jfabernathy wrote:
Wed Jun 02, 2021 12:58 pm
I'm not seeing any issues. I just started with a clean SSD with Raspberry PI OS (Desktop) and followed my instructions at
https://mythtv-rp4.blogspot.com/2020/11 ... rpi-4.html
Thanks for the response. Maybe I need to re-download the mythtv-light install .deb files from orangedox.com - it's a bit of a pain to get them so I had kept copies from the last time I got them. Perhaps they've been updated to take account of the new X11 library.
(I guess the other possibility is that the UK mirror that I get packages from is different to the US one that I presume you use).
I'll give it another try without using the cached .deb files I have.

cliveb
Junior
Posts: 80
Joined: Fri Jan 08, 2016 9:59 am
Great Britain

[SOLVED] Re: X11 library has been updated - mythtv-light install now fails

Post by cliveb » Sun Jun 06, 2021 12:07 pm

OK, turns out it was nothing to do with the mythtv-light .deb file and I had just made a silly oversight.

I had previously done a full upgrade of raspbian and kept a copy of the image so I could restart experiments without having to go through the (somewhat lengthy) upgrade each time. But when the X11 library got updated, it put my copy out of date. So after doing another raspbian upgrade the install of mythtv-light completed successfully.

Post Reply