Mythweb on RPI4 mythtv backend failing

For discussion of topics specific to MythTV on Raspberry Pi devices
Post Reply
User avatar
jfabernathy
Senior
Posts: 331
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Mythweb on RPI4 mythtv backend failing

Post by jfabernathy » Sun Oct 18, 2020 11:09 am

I just did a fresh install of mythtv with a backend on a RPI 4 4GB using
Mike B's pi-utils.https://github.com/MikeB2013/pi-utils This usually works fine. However today, after I got
the backend working, I tried to use mythweb and got an error I have not
received before:
Bad Request
Your browser sent a request that this server could not understand.
Size of a request header field exceeds server limit.

If I look in the mythbackend log file I see this:

Code: Select all

Oct 13 11:48:24 rpi4-mythtv mythbackend: mythbackend[702]: E
WebSocketServer52 websocket.cpp:432 (ProcessHandshake)
WebSocketWorker::ProcessHandshake() - Missing or invalid
'sec-websocket-key' header
Oct 13 11:48:34 rpi4-mythtv mythbackend: mythbackend[702]: E
WebSocketServer47 websocket.cpp:675 (HandleDataFrame) WebSocketWorker -
Message is not valid UTF-8
Oct 13 11:48:44 rpi4-mythtv mythbackend: mythbackend[702]: E
WebSocketServer37 websocket.cpp:432 (ProcessHandshake)
WebSocketWorker::ProcessHandshake() - Missing or invalid
'sec-websocket-key' header
Oct 13 11:48:54 rpi4-mythtv mythbackend: mythbackend[702]: E
WebSocketServer47 websocket.cpp:432 (ProcessHandshake)
WebSocketWorker::ProcessHandshake() - Missing or invalid
'sec-websocket-key' header
Oct 13 11:49:04 rpi4-mythtv mythbackend: mythbackend[702]: E
WebSocketServer47 websocket.cpp:432 (ProcessHandshake)
WebSocketWorker::ProcessHandshake() - Missing or invalid
'sec-websocket-key' header
Oct 13 11:50:37 rpi4-mythtv mythbackend: mythbackend[702]: N Expire
autoexpire.cpp:244 (CalcParams) AutoExpire: CalcParams(): Max required Free
Space: 1.0 GB w/freq: 15 min
If I use webfrontend it works fine

I went back and edited the pi-mythbackend-helper.sh script from MikeB's pi-utils to make it run only the mythweb parts again and no errors on the install.
After having the same error, I went to the build from source wiki page and did those Mythweb instructions.

Still the same problem.

User avatar
jfabernathy
Senior
Posts: 331
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: Mythweb on RPI4 mythtv backend failing

Post by jfabernathy » Sun Oct 18, 2020 2:28 pm

I just started fresh again and installed Raspberry PI OS Lite and installed mythtv-light and mythplugins-light using pi-utils/pi-setup_mythtv_31.sh.

Then using pi-mythbackend-helper.sh, I installed the rest. After configuring my tuners, video sources, and input connections everything worked except for mythweb. Still getting the error described above.

User avatar
jfabernathy
Senior
Posts: 331
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

Re: Mythweb on RPI4 mythtv backend failing

Post by jfabernathy » Fri Nov 06, 2020 11:36 am

Here's the latest. This morning I tried once again to use mythtweb on my RPI4 backend from an Ubuntu 20.04 Chrome browser and the main page come up, strangely. I then tried something other than the Status screen and it failed with a dump of PHP logs with a link to post a bug report but on the old Trac system.
At that point I just did a sudo apt update/upgrade and rebooted, There were a lot up updates including mariadb.

Now mythweb on RPI4 is working again. I've updated my mythtv to fixes/31 (v31.0-118-...)

gedakc
Newcomer
Posts: 10
Joined: Fri Jul 18, 2014 1:28 am
Canada

Re: Mythweb on RPI4 mythtv backend failing

Post by gedakc » Mon Jan 11, 2021 8:08 pm

Recently I installed the mythtv-light and mythplugins-lite packages (31.0-54-g445cf1fe6b-0) onto 2020-12-02-raspios-buster-armhf-lite.zip running on an RPi4 4GB and mythweb works (http://my-ip-address/mythweb/). I was able to navigate the menus and even play a prior recording via Firefox.

Perhaps this latest version of Raspberry Pi OS fixed an underlying issue that caused mythweb to fail when you tested earlier.

EDIT: Thanks Jim for your instructions for How I installed MythTV v31 on my RPI 4. These have helped greatly! :-)

Post Reply