audio dropouts on v30 with Pi3 B+ as FE

For discussion of topics specific to MythTV on Raspberry Pi devices
Post Reply
oweiler
Newcomer
Posts: 2
Joined: Sun May 17, 2020 11:24 pm
United States of America

audio dropouts on v30 with Pi3 B+ as FE

Post by oweiler » Sun May 17, 2020 11:50 pm

I've got a test BE/FE combo setup running fairly well using v30. My Raspberry Pi4 is a BE but also has FE installed. OTA HD recordings play well on the Pi4. I'm introducing a Pi3 B+ as a FE because I plan on dedicating the Pi4 to BE-only as I may throw 3 or 4 simultaneous OTA HD recordings at it. Right now, everything is being run from the respective SD cards. Audio is being delivered through the HDMI port.

I set up a Pi3 B+ by doing the following:

create sd card from 2020-02-13-raspbian-buster-full.zip
On boot partition: type nul > ssh
boot SDcard
don't set up wifi, don't update OS, don't reboot
ssh in
sudo bash
raspi-config
change hostname to frontend1 (or rr)
memory split to 128
echo "deb h t t p://d l . b i n t r a y . c o m /bennettpeter/deb/ buster myth30" >> /etc/apt/sources.list
wget -O - h t t p s : / / b i n t r a y .c o m /user/downloadSubjectPublicKey?username=bintray | apt-key add -
apt update ; apt -y upgrade ; apt install -y mythtv-light mythplugins-light telnet nmon
reboot
Start mythfrontend, Search for backend, select v30 one, restart mythfrontend
mythfrontend setup
audio -> output device -> ALSA:default:CARD=ALSA
audio -> master mixer volume -> 100
audio -> pcm mixer volume -> 100
audio -> upconvert stereo to 5.1 surround -> off
video -> playback -> current video playback profile -> openmax normal

The dropouts vary but generally last a second or less. I hear the dropout no later than 30 seconds into the recording but the first dropout varies as to when it starts.

I run nmon while playback is occuring and I see that no resource I'm monitoring (disk, network, cpu) is anywhere close to maxing out. CPU is at about 25% usage, Network is at about 1.8MBytes/sec inbound, disk usage is pretty much non-existent.

I've tried:
  • With a hardware decoding license and without without about the same results.
  • I tried all "found" audio output devices (hw, plughw, etc), some don't work at all, others have the same problem listed above.
  • Using -v playback and while the logs show a few "Waiting for video buffers...", introducing the playback log seems to introduce video lag which could explain the video buffers.
  • Using v31 and couldn't get the RPi4 FE/BE combo to play HD video without video and audio stuttering, hence the reason why I'm asking about v30.
What can I do to try to diagnose this problem further?

oweiler
Newcomer
Posts: 2
Joined: Sun May 17, 2020 11:24 pm
United States of America

Re: audio dropouts on v30 with Pi3 B+ as FE

Post by oweiler » Mon May 18, 2020 2:22 am

Quick update: while I was trying out a FireTV Stick 4K that I saw pgbennett offer up and and that jfabernathy tried out in a couple posts, I saw the playback audio read-ahead advanced setting here:

https://www.mythtv.org/wiki/Android#Audio

The default seems to be 100ms. I can get totally clean audio if I set that value to 1000ms but I get significant video stutter. I back off a bit but can't find a sweet spot where neither audio nor video stutter. The best I can do seems to be about 700ms which I feel is in the "slightly annoying" category, not something I'd want to watch for more than 20 minutes.

I'm hoping that helps narrow down the list of possible issues so that somebody can offer some targeted diagnostic help.

Thanks in advance!
Last edited by Steve Goodey on Mon May 18, 2020 6:59 am, edited 1 time in total.
Reason: url amended as new user.

Post Reply