Okay, I need help getting this going.

Moderator: warpme

Post Reply
jmetal88
Newcomer
Posts: 7
Joined: Wed Feb 04, 2015 4:16 am
United States of America

Okay, I need help getting this going.

Post by jmetal88 » Thu Dec 01, 2016 5:30 am

It took me a while of wrangling with different options, but I've finally got MiniMyth2 loading via PXE using dnsmasq as a proxy DHCP and TFTP server and lighttpd as a web server (I am using LinHES and picked these two because they happen to be preinstalled). Since the image was loading up and booting, I thought I was in the clear, but at the splash screen, it gets up to "waiting for directory /minimyth to mount ..." and just sits there without seeming to do anything. What's it looking for here? What do I need to have set up for it to continue from this step?

jmetal88
Newcomer
Posts: 7
Joined: Wed Feb 04, 2015 4:16 am
United States of America

Re: Okay, I need help getting this going.

Post by jmetal88 » Thu Dec 01, 2016 1:29 pm

Well, I found this forum post on this same topic:

http://www.minimyth.org/forum/viewtopic.php?f=5&t=2261

Unfortunately, since I am not using dhcpd and additionally I am using dnsmasq in dchp proxy mode, I am not sure there is anything I can do to fix this with my current setup (and I would have to do a good amount of reconfiguration and cable swapping and have to buy another network card to be able to use my back end as a full DHCP server).

Is it possible to hard code that boot file path into the image? If it is, that would be my easiest way around this, assuming the issue I'm having has the same cause as the one in that other topic.

jmetal88
Newcomer
Posts: 7
Joined: Wed Feb 04, 2015 4:16 am
United States of America

Re: Okay, I need help getting this going.

Post by jmetal88 » Sat Dec 03, 2016 3:45 am

Ah, nevermind, this is just too much trouble. I'll just get a hard drive for this box.

Post Reply