XUbuntu 18.04 installed but Firefox NOT connecting

For discussions which are not directly related to MythTV.

Moderator: Forum Moderators

Post Reply
glen96
Newcomer
Posts: 11
Joined: Thu May 09, 2019 12:08 am
Australia

XUbuntu 18.04 installed but Firefox NOT connecting

Post by glen96 » Sat Jun 22, 2019 10:54 pm

I have reinstalled Xubuntu 18.04 64bit 3 or 4 time attempting to correct the problem that Firefox does not connect to the net automatically.

I have referred to the following posts that have a problem similar to mine: https://askubuntu.com/questions/1021884 ... 4-to-18-04, https://askubuntu.com/questions/1049302 ... untu-18-04 and https://askubuntu.com/questions/1098162 ... u-18-04lts. Attempted numerous methods to get a connection, but failed.

At the end of installation the Network Icon (top right) indicates PC is connected to the net via a created connection called "Wired Connection 1". This looks normal to me but a am not an expert.

When Firefox is called upon to connect, it fails to connect. I have tried following the posts to fix the problem but I have not succeeded.

This may help:
anita@Anita-MythTV-BE:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 00:24:81:15:94:3f brd ff:ff:ff:ff:ff:ff
I try to set a static IP using Netplan with "enp0s25" and various combinations but never found a solution.

I am at a loss to know what to do next. There must be a step by step procedure to debug this situation, but this is now beyond my knowledge.

cheers
Glen

glen96
Newcomer
Posts: 11
Joined: Thu May 09, 2019 12:08 am
Australia

Re: XUbuntu 18.04 installed but Firefox NOT connecting

Post by glen96 » Sun Jun 23, 2019 2:48 am

Been for a long walk thinking about this problem. Netplan seemed to be the most rational way to go. I will try it again.

Repeated ip link.
Edited file "/etc/netplan/01-network-manager-all.yaml" and saved:
network:
version: 2
renderer: networkd
ethernets:
enp0s25:
dhcp4: no
addresses:
- 192.168.1.44/24
gateway4: 192.168.1.1
nameservers:
addresses: [8.8.8.8, 1.1.1.1]
Applied sudo netplan apply.
Followed by:
anita@Anita-MythTV-BE:~$ ip addr show dev enp0s25
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 00:24:81:15:94:3f brd ff:ff:ff:ff:ff:ff
inet 192.168.1.44/24 brd 192.168.1.255 scope global enp0s25
valid_lft forever preferred_lft forever
inet6 fe80::224:81ff:fe15:943f/64 scope link
valid_lft forever preferred_lft forever
This appears to confirm static IP 192.168.1.44/24 was successful and Firefox did connect, but network icon (top right) indicated NOT connected!

Rebooted and Firefox was still connected but network icon not connected.

A connected network is a critical need for the OS to operate, unfortunately it appears very wobbly, sorry I cannot help to fix it.

Cheers
Glen

wesnewell
Senior
Posts: 492
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: XUbuntu 18.04 installed but Firefox NOT connecting

Post by wesnewell » Sun Jun 23, 2019 12:20 pm

While this is totally off topic. Chromium is the default browser for xunbuntu. How does it work for you? if neither works, you have a network problem. Perhaps a bad connection if wired. perhaps a bad wifi. How are you connected? What's the output of ifconfig <interface name>. ping localhost, etc.? Firewall in router? Internet provider? Type? BTW, an OS will work fine without a network connection. It will just be limited to local resources.What's you output of this? Exp:
wes@mythfe0:~$ dmesg|grep enp
[ 0.845875] r8169 0000:1e:00.0 enp30s0: renamed from eth0
[ 4.946765] r8169 0000:1e:00.0 enp30s0: Link is Down
[ 7.467953] r8169 0000:1e:00.0 enp30s0: Link is Up - 1Gbps/Full - flow control rx/tx
[ 7.467963] IPv6: ADDRCONF(NETDEV_CHANGE): enp30s0: link becomes ready
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

User avatar
Steve Goodey
Moderator
Posts: 80
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: XUbuntu 18.04 installed but Firefox NOT connecting

Post by Steve Goodey » Sun Jun 23, 2019 3:42 pm

Moved to Off-Topic as not MythTV related.

Post Reply