Mythfrontend crashes with nvidia drivers 334.21

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
User avatar
stuarta
Developer
Posts: 180
Joined: Wed Feb 05, 2014 5:13 pm
Great Britain

Mythfrontend crashes with nvidia drivers 334.21

Post by stuarta » Fri Mar 21, 2014 10:26 am

Hi,

There have been various reports on the distro forums and bugtrackers about
mythfrontend crashing after upgrading to nvidia drivers 334.21.

This has been fixed in
* master: https://code.mythtv.org/cgit/mythtv/com ... 5b7262d423
* fixes/0.27: https://code.mythtv.org/cgit/mythtv/com ... d0f188c12f

See also the trac ticket https://code.mythtv.org/trac/ticket/12098

Regards
Stuart

piper
Newcomer
Posts: 2
Joined: Sat Feb 15, 2014 1:26 pm
United States of America

Re: Mythfrontend crashes with nvidia drivers 334.21

Post by piper » Sat Mar 22, 2014 12:59 am

Thanks :)

I never had problems with those drivers, and I don't have problems with 331.49 either :)

Hopefully it helps others

Code: Select all

piper@x1:~$ inxi -F 
System:    Host: x1 Kernel: 3.13-6.towo-siduction-amd64 x86_64 (64 bit) 
           Desktop: KDE 4.12.3 Distro: siduction 13.2.0 December - kde - (201402231435)
Machine:   Mobo: Gigabyte model: GA-970A-UD3 version: x.x Bios: Award version: F7 date: 10/22/2012
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) 
           Clock Speeds: 1: 1400.00 MHz 2: 1400.00 MHz 3: 1400.00 MHz 4: 1400.00 MHz 5: 1400.00 MHz 6: 1400.00 MHz
Graphics:  Card: NVIDIA GF106 [GeForce GTS 450] X.Org: 1.15.0 driver: nvidia Resolution: 1920x1200@60.0hz 
           GLX Renderer: GeForce GTS 450/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.49
Audio:     Card-1: NVIDIA GF106 High Definition Audio Controller driver: snd_hda_intel 
           Card-2: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel 
           Sound: Advanced Linux Sound Architecture ver: k3.13-6.towo-siduction-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 90:2b:34:a5:99:2d
Drives:    HDD Total Size: 3820.8GB (20.5% used) 1: id: /dev/sda model: ST3500630AS size: 500.1GB 
           2: id: /dev/sdc model: ST3000DM001 size: 3000.6GB 3: id: /dev/sdb model: ST3320620AS size: 320.1GB 
Partition: ID: / size: 251G used: 39G (17%) fs: ext4 ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 23.1C mobo: N/A gpu: 34C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 184 Uptime: 1 day Memory: 1427.7/7973.2MB Client: Shell (bash) inxi: 1.9.18
apt-get into it | debian sid/siduction

User avatar
paulh
Developer
Posts: 300
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: Mythfrontend crashes with nvidia drivers 334.21

Post by paulh » Sat Mar 22, 2014 8:00 am

piper wrote:Thanks :)

I never had problems with those drivers, and I don't have problems with 331.49 either :)

Hopefully it helps others
The 331.xx drivers are OK it's the 334.xx drivers that have the problem or if Stuart is correct it's actually the way Myth is using them.

User avatar
stuarta
Developer
Posts: 180
Joined: Wed Feb 05, 2014 5:13 pm
Great Britain

Re: Mythfrontend crashes with nvidia drivers 334.21

Post by stuarta » Sat Mar 22, 2014 12:35 pm

The problem is we were blindly doing dynamic loading of libGLESv2 if it existed and trying to use it, even if we had opengles disabled. There is a possibiilty that there are bugs in the initial implementation of libGLESv2, but we should not have been using it just because it's there.

Post Reply