Can't connect remote frontend to backend

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Can't connect remote frontend to backend

Post by necbot » Sat Apr 11, 2015 12:46 pm

As the title says, I cannot connect a mythtv frontend to my backend. I did some reading and saw that this is a mysql permissions issue, right? I logged into mysql and ran the following...

GRANT ALL PRIVILEGES ON *.* TO 'mythtv'@'%' IDENTIFIED BY 'mythtv' WITH GRANT OPTION;
FLUSH PRIVILEGES;

I still cannot connect. Is there some other setting I have to change? Why is this default behavior?

EDIT:
After running that command I can no longer access mythtv web interface. When I enter my mythtv backend ip in the weburl I get..

Code: Select all

Fatal Error

!!NoTrans: Access denied for user 'mythtv'@'localhost' (using password: YES) [#1045]

Backtrace
Array
(
[0] => Array
(
[file] => /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php
[line] => 63
[function] => error
[class] => Database
[object] => Database_mysql Object
(
[dbh] => 
[error] => Access denied for user 'mythtv'@'localhost' (using password: YES) [#1045]
[err] => Access denied for user 'mythtv'@'localhost' (using password: YES)
[errno] => 1045
[last_sh] => Database_Query_mysql Object
(
[dbh] => 
[query] => Array
(
[0] => SET NAMES utf8;
)

[last_query] => SET NAMES utf8;
[warnings] => Array
(
)

[num_args_needed] => 0
[num_rows] => 
[affected_rows] => 
[insert_id] => 
[db] => Database_mysql Object
*RECURSION*
)

User avatar
bill6502
Developer
Posts: 1408
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Can't connect remote frontend to backend

Post by bill6502 » Sat Apr 11, 2015 8:28 pm

Hi,

Assuming that your backend is running, type: grep Password ~mythtv/.mythtv/config.xml
That's what you should use in the GRANT line. Also, the password used for mythweb
must match. If you use Mythbuntu, then this will show you what it's set to:
grep db_password /etc/apache2/sites-enabled/mythweb.conf

I've seen that "GRANT ALL PRIVILEGES ON *.*..." line too and disagree with it.
Change *.* to mythconverg.* (but that won't fix this problem.)

If that doesn't help, you should mention your distribution and MythTV version so that
others can contribute.

Post Reply