Mythwelcome causes Mythmote to fail

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
mikes
Newcomer
Posts: 5
Joined: Sat Feb 24, 2024 10:20 pm
United States of America

Mythwelcome causes Mythmote to fail

Post by mikes »

I am new to the MythTV community and have set up a MythTV frontend on a Raspberry Pi running Ubuntu 23.10. I would like to have the RPi be a dedicated board for MythTV and installed Mythwelcome on the RPi. I'm able to connect and control the frontend with Mythmote if I start the frontend from the desktop. However, if I start Mythwelcome and use it to start the frontend, Mythmote gives me a connection error. I am running MythTV 33.Any ideas? Thanks for any help you can provide.
blm-ubunet
Senior
Posts: 266
Joined: Sun Jun 15, 2014 1:08 am
Cambodia

Re: Mythwelcome causes Mythmote to fail

Post by blm-ubunet »

Been a long time since running mythmote.. but believe it worked on mythfrontend started by mythwelcome.
I wonder if your mythwelcome is starting FE as different user or with different cmd-line options.
I think mythmote requires UPnP enabled.

An aside does this work:
http://mythfrontend -IP:6547/MythFE/GetRemote
mikes
Newcomer
Posts: 5
Joined: Sat Feb 24, 2024 10:20 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by mikes »

Thanks for the reply.

The command does not work. It returns "bash: http://myth fronted: no such file or directory"
User avatar
bill6502
Developer
Posts: 2339
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by bill6502 »

The above isn't a command, you'd use your favorite browser. Replace
mythfrontend-IP with the hostname or IP address of your running
frontend.
mikes
Newcomer
Posts: 5
Joined: Sat Feb 24, 2024 10:20 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by mikes »

Oops. That's a little embarrassing.

The browser returns - "open the mythfrontend-192.168.0.156 link with system handler?". When I try following the link no app is found to open mythfrontend.
Last edited by mikes on Tue Feb 27, 2024 3:47 pm, edited 1 time in total.
User avatar
pgbennett
Developer
Posts: 510
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by pgbennett »

This is what you should be trying:

http://192.168.0.156:6547/MythFE/GetRemote
mikes
Newcomer
Posts: 5
Joined: Sat Feb 24, 2024 10:20 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by mikes »

Thanks for hanging in there with me. Hopefully the third time is a charm.

The browser is "unable to connect"
User avatar
bill6502
Developer
Posts: 2339
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by bill6502 »

FYI, that's a typical response if the frontend isn't running. I'm out of my league here 'cause I
don't run mythwelcome. Is there something that prevents running mythfrontend directly?
mikes
Newcomer
Posts: 5
Joined: Sat Feb 24, 2024 10:20 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by mikes »

The result with the frontend running i( :) )s that a screen with remote buttons is displayed.

Nothing prevents me from running it directly. I was hoping to have a setup that would auto start and only require mythmote running on my phone. I was planning to have Mythwelcome auto start on the RPi and go from there.

Again, thank you for all your help. You've been more than patient.
User avatar
bill6502
Developer
Posts: 2339
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Mythwelcome causes Mythmote to fail

Post by bill6502 »

If your host is setup to login automatically (with your user), then this systemd
service may be just what you want:

Code: Select all

[Unit]
Description=MythTV Frontend 
Wants=mythtv-backend.service
After=mythtv-backend.service graphical-session.target

[Service]
Environment=XDG_SESSION_TYPE=
ExecStart=/usr/bin/mythfrontend --loglevel info --jumppoint 'TV Recording Playback' --logpath /var/log/mythtv
Type=notify

[Install]
WantedBy=graphical-session.target
To add it, you'd type this command: systemctl --user edit --force --full mythfrontend.service
and add the above.

The system I'm using this on also has a backend. If your's doesn't, then remove the Wants= line
and mythtv-backend.service from the After= line.

To have it run whenever you login, do: systemctl --user enable mythfrontend.service

The directory /var/log/mythtv must be writable by your user, I believe *buntu systems automatically
add your user to the mythtv group.

Lots of moving parts in the above. Works a charm for me, but may be too tough to setup.
Last edited by bill6502 on Wed Feb 28, 2024 4:33 pm, edited 1 time in total.
Reason: Fix name of service (enable command)
Post Reply