LinHES8 perpetually "Waiting for connection to mythbackend"

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
Village_Idiot
Newcomer
Posts: 9
Joined: Fri Jan 22, 2021 6:44 pm
United States of America

LinHES8 perpetually "Waiting for connection to mythbackend"

Post by Village_Idiot » Mon Apr 19, 2021 9:46 pm

After several weeks of just plain working, upon a reboot, my frontend cannot get past the LinHES screen and the "Waiting for connection to mythbackend" message keeps dropping in from the top, with no connection established. From the terminal, I found in mythbackend log:

Code: Select all

Connection to master server timed out.
Failed to connect to (192.168.1.110:6543) Host unreachable
Either the server is down or the master server settings in mythtv-settings does not contain the proper IP address. 
But mythbackend is a clearly running process (my front and backend are on the same 'localhost' machine). I have not changed the backend settings since my fresh installation of LinHES8. I don't know what I set the IP address to, but I'm sure I accepted the default option. I don't know why this is suddenly a problem. Is it possible an external change from my router is causing the problem? The localhost machine has an ethernet connection to a router that has not had any intentional configuration changes.

Is there a way to diagnose or change the mythbackend settings manually? I cannot do anything through the mythfrontend as it is perpetually stuck "Waiting for connection to mythbackend" so any suggestions have to be achieved through the command line.

I will begrudgingly accept "start over with a fresh install" if I have to, but was hoping to resurrect this installation.

Thanks!

User avatar
paulh
Developer
Posts: 645
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: LinHES8 perpetually "Waiting for connection to mythbackend"

Post by paulh » Mon Apr 19, 2021 10:43 pm

Maybe your system is using DHCP and the IP address changed ?

Village_Idiot
Newcomer
Posts: 9
Joined: Fri Jan 22, 2021 6:44 pm
United States of America

Re: LinHES8 perpetually "Waiting for connection to mythbackend"

Post by Village_Idiot » Mon May 03, 2021 6:06 pm

I was finally able to find the frontend setting that I needed, with Alt+S in the General settings. There was an unchecked option to allow the frontend to connect on any local IP. After I checked it and restarted the backend, everything is working normally again.

User avatar
Steve Goodey
Moderator
Posts: 159
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: LinHES8 perpetually "Waiting for connection to mythbackend"

Post by Steve Goodey » Mon May 03, 2021 6:37 pm

If you're happy with the fix could you possibly added [Solved] to the subject line in the first post?

Ta.
Don't forget the Wiki.

Post Reply