AMD VAAPI deinterlacers, low/medium working, High does not?

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
mtvf2894
Newcomer
Posts: 13
Joined: Sat Apr 10, 2021 2:33 pm
Great Britain

AMD VAAPI deinterlacers, low/medium working, High does not?

Post by mtvf2894 » Sat Apr 10, 2021 3:10 pm

Hi,

Currently running a new install of v31 and using default VAAPI Normal configuration on an AMD iGPU.

When I use the Low or Medium single or double rate deinterlacer playback data shows that VAAPI Basic and VAAPI Adaptive is the active deinterlacer.

When I choose High deinterlacer playback data reports GLSL Kernel or 2x GLSL Kernel as the active deinterlacer.

Is this normal for AMD iGPUs (no support for driver High deinterlacer)?

I am assuming it is (incorrectly/not supported?) falling back to the OpenGL High deinterlacer?

Here are my https://www.mythtv.org/wiki/Release_Not ... nterlacing results:

Code: Select all

Decoder: VAAPI (AMD)

Software
Low: -
Medium: -
High: -

OpenGL
Low: Onefield
Medium: Linearblend
High: Kernel

Driver
Low: Basic
Medium: Adaptive
High: -
I can also post a VAAPI (Intel) summary also if anyone wants it.

Thanks
MythTV v31 / Ubuntu 20.10 / AMD APU

Post Reply