SOLVED file not fast-forwarding in Leanfront

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
Linuxgrrl
Junior
Posts: 63
Joined: Mon Oct 26, 2020 12:46 am
United States of America

SOLVED file not fast-forwarding in Leanfront

Post by Linuxgrrl » Tue Apr 06, 2021 6:22 pm

Generally I've had very good success with Leanfront playing back everything. On Sunday, though, I recorded the women's NCAA basketball final from cable (H.264 using a HDPVR). The file plays fine, but I am unable to fast forward or skip forward in it. At first I thought maybe it was being comm flagged because I was trying to watch it shortly after the game ended. But I just tried again today and FF / jump forward still do not work in this file.

I am running mythbackend v.31. I have the version of Leanfront just prior to the current one (sorry, can't find that info in the frontend, but it's just a few months old). I checked mythbackend.log and it had no evidence of what was/is happening. Suggestions welcome.
Last edited by Linuxgrrl on Mon Apr 26, 2021 8:50 pm, edited 1 time in total.

glenb
Junior
Posts: 17
Joined: Sun Nov 17, 2019 7:48 am
United States of America

Re: file not fast-forwarding in Leanfront

Post by glenb » Wed Apr 07, 2021 1:35 am

i run into this from time to time. i have to 'recreate' a seek that the xo player in android will work with. so i find the file in my storage and do this:

ffmpeg -i mythfilename.ts -c copy temp.ts (mythfilename is your filename for the recording)
then: rm mythfilename.ts
then: mv temp.ts mythfilename.ts

takes very little time and will correct your issue. i like the leanfront a lot and the xo player is really good, but i have gone back to kodi mostly in android to have commercial skips. i changed out the mythcommflag to comskip and its near perfect. give the ffmpeg recreate container and seek a try it will solve it on a per file/issue basis

User avatar
pgbennett
Developer
Posts: 401
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: file not fast-forwarding in Leanfront

Post by pgbennett » Wed Apr 07, 2021 4:15 pm

This should not happen.

There is a situation where the total length does not show and you cannot skip. It is related to a size parameter that can be set in the program. I have set a value that I thought would be sufficient for all cases. It is likely that this could be fixed with a small change.

When you are unable to skip, does the total playback time show in the OSD?

To fix it, can you give me a sample of a file that will not seek? Alternativley I can give you a test leanfront with a larger seek size for you to try to see if it fixes the problem.

User avatar
pgbennett
Developer
Posts: 401
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: file not fast-forwarding in Leanfront

Post by pgbennett » Wed Apr 07, 2021 5:10 pm

Are you using a recent version?
This was fixed on September 26, 2020 and an update was made November 11th 2020 to further increase the size of the seek buffer. If you are using an older version please upgrade.

Linuxgrrl
Junior
Posts: 63
Joined: Mon Oct 26, 2020 12:46 am
United States of America

Re: file not fast-forwarding in Leanfront

Post by Linuxgrrl » Wed Apr 07, 2021 8:58 pm

Thanks for the help. I will try the ffmpeg if i need to rescue a particular file.
glenb wrote:
Wed Apr 07, 2021 1:35 am
i changed out the mythcommflag to comskip and its near perfect.
I am unfamiliar enough with commercial flagging that I'm not sure what you mean. Is this a setting in mythbackend?

I'm responding to PBennett in a separate comment. ...

Linuxgrrl
Junior
Posts: 63
Joined: Mon Oct 26, 2020 12:46 am
United States of America

Re: file not fast-forwarding in Leanfront

Post by Linuxgrrl » Wed Apr 07, 2021 9:05 pm

pgbennett wrote:
Wed Apr 07, 2021 4:15 pm

When you are unable to skip, does the total playback time show in the OSD?

To fix it, can you give me a sample of a file that will not seek? Alternativley I can give you a test leanfront with a larger seek size for you to try to see if it fixes the problem.
Right you are, the playback time is not showing when I try (and fail) to skip in that file.
i'm not sure how to crop a myth file to give you, but if you can guide me as to animal, mineral, or vegetable I can figure it out. A test leanfront would also be lovely.

The leanfront version I have is Leanfront-release-v0-261-g92ab8a3.apk, downloaded in February 2021. So it should have included the fix. If there is a way from within Leanfront to validate that I am actually running that version please let me know. I installed it via adbconnect (at least i thought I did) as an upgrade to a prior version. EDIT: I have the ability to schedule recordings from within leanfront, so I'm pretty sure that means i have the latest version installed.

glenb
Junior
Posts: 17
Joined: Sun Nov 17, 2019 7:48 am
United States of America

Re: file not fast-forwarding in Leanfront

Post by glenb » Thu Apr 08, 2021 3:58 am

the commflagging discussion is off topic of your post, i only mentioned it because i am not using the leanfront as much as i found a way to improve commflagging, so i use kodi now mostly. but when i did use leanfront, peter was kind enough to help me with hdpvr content where i had the same issue. i later ran into the problem now and then and i just corrected it with ffmpeg. mainly i wanted a bookmark to work and the ability to move forward and backward through a file.

User avatar
pgbennett
Developer
Posts: 401
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: file not fast-forwarding in Leanfront

Post by pgbennett » Thu Apr 08, 2021 3:49 pm

1. You can see what version of leanfront you have installed by going to android settings, going to apps, finding the app and selecting it. The version number is displayed.

2. I have today released a new apk (leanfront-release-v0-277-g9d091b2.apk) that has a section "Tweaks" in Settings. Try increasing the "TS Search Packets" value. I have also added some information on the tweaks to the documentation on github
(https://github.com/bennettpeter/android ... ont#tweaks)

Linuxgrrl
Junior
Posts: 63
Joined: Mon Oct 26, 2020 12:46 am
United States of America

Re: file not fast-forwarding in Leanfront

Post by Linuxgrrl » Mon Apr 26, 2021 12:10 am

pgbennett wrote:
Thu Apr 08, 2021 3:49 pm

2. I have today released a new apk (leanfront-release-v0-277-g9d091b2.apk) that has a section "Tweaks" in Settings. Try increasing the "TS Search Packets" value. I have also added some information on the tweaks to the documentation on github
(https://github.com/bennettpeter/android ... ont#tweaks)
Sorry about the delay in replying - I was rebuilding a new backend. I have tried version 277 and made the tweak, and the file now behaves properly. Thank you!

Post Reply