One channel has its audio mix mixed up (ATSC, Happauge 4 USB Tuner, HDMI output)

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
thormj
Newcomer
Posts: 2
Joined: Mon Mar 08, 2021 4:07 am
United States of America

One channel has its audio mix mixed up (ATSC, Happauge 4 USB Tuner, HDMI output)

Post by thormj » Mon Mar 08, 2021 4:22 am

It's working... it's actually kinda amazing the low bitrate on a lot of shows, but it seems to be the same with normal tv vs myth.
System Config:
Happauge ATSC 4 tuner USB
Nvidia GeForce2MX with HDNI output -- Using Alsa DMix (Alsa CARD says 2.0 only?), Amplified to 140% in the mixer
Vidao TV, input #4, outputting optical, optical signal = RAW
Onkyo 7.1 surround decoder amp, optical input #1, mode = PCM 5.1

Most channels work, and PBS has amazing sound with concerts...
Fox5 has proper surround and echo on the basketball courts.

But... CBS46.1 Atlanta...

Their audio mix on MythTV is bonkers -- i hear the "emphasis" and "surround" but not the main L/R/C channels.
Listening to the news, you get "whoos, whip, bang!" but no voices.
Listening to "Eats in Atlanta," you get the theme music (very loud!) but small/no voices. It's almost like the map is SL->L, SR->R, C->SUB, and L/R went... missing.

Info says HD1080 Mpeg2, DD, 5.1... same as Fox5.

On the normal (Vidao TV) Tuner, it's working fine.
Any idea how to troubleshoot what's going on here (record a program, play it back and pick the individual sound streams to be played on headphone jack L only)?

thormj
Newcomer
Posts: 2
Joined: Mon Mar 08, 2021 4:07 am
United States of America

Re: One channel has its audio mix mixed up (ATSC, Happauge 4 USB Tuner, HDMI output)

Post by thormj » Tue Mar 09, 2021 5:21 pm

But... if you configure the ALSA audio out to be 2ch stereo... the mix works.
So alternatively... is there a way I can can say "for programs recorded on this channel, record in stereo or downmix to stereo on playback"?
For that matter, if you can do that as part of the transcode, that would work... my transcode isn't working yet, but...

User avatar
heyted
Senior
Posts: 194
Joined: Sun Jun 08, 2014 2:14 am
Location: South Florida
Contact:
United States of America

Re: One channel has its audio mix mixed up (ATSC, Happauge 4 USB Tuner, HDMI output)

Post by heyted » Thu Mar 11, 2021 1:36 am

Does VLC play the recording okay using two channel stereo? I have never tried it, but I think the MythTV video library can be set to play videos using a player (external player) other than MythTV Frontend as explained here. You could try copying the recording to the video library, and set it to use VLC. Using MythArchive is one method of copying a recording to the video library.
Ted | My blog

Post Reply