HDPVR color is off [SOLVED]

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
Linuxgrrl
Junior
Posts: 66
Joined: Mon Oct 26, 2020 12:46 am
United States of America

HDPVR color is off [SOLVED]

Post by Linuxgrrl » Wed Jan 13, 2021 10:23 pm

I just installed a HDVPR model1212. To solve the known problem with color, I've upgraded the firmware to the latest version (3/11/2012).
The hue is off. It's a combination of too pink, too dark, and washed-out.
As suggested in the wiki, I've tried using various commands to adjust the picture. But, even though the commands report no error (see below), the color looks exactly the same. It's as if the commands are not "taking" somehow.
Possibly related, if I run "vrl2-ctl --all" it does not list my device.
To test the color adjustments, I'm running the v4l2-ctl command and then I switch directly into mythfrontend and watch live. Nothing changes.
What am I doing wrong?

Example:

Code: Select all

mary@mythbox:/etc/modprobe.d$ sudo v4l2-ctl --verbose --device=/dev/video1 --set-ctrl brightness=0x80 --set-ctrl contrast=0x40 --set-ctrl hue=0x80 --set-ctrl saturation=0x40
VIDIOC_QUERYCAP: ok
VIDIOC_S_CTRL: ok
VIDIOC_S_CTRL: ok
VIDIOC_S_CTRL: ok
VIDIOC_S_CTRL: ok
Last edited by Linuxgrrl on Sat Jan 16, 2021 12:37 pm, edited 1 time in total.

Linuxgrrl
Junior
Posts: 66
Joined: Mon Oct 26, 2020 12:46 am
United States of America

Re: HDPVR color is off

Post by Linuxgrrl » Thu Jan 14, 2021 8:53 pm

Update: I can now change the picture settings. Apparently "v4l2-ctl --device /dev/video1" silently failed to select my device, but "v4l2-ctl -d1" selects it fine.

The problem is that the colors still look terrible. I have played with a bunch of combinations of hue, sharpness, brightness, saturation, and contrast. Although I can see the changes take effect in LiveTV, they are all in a range of just a not very good picture. Rich greens and blues seem to be missing from the spectrum, with the picture mostly darkish/greyish/pinkish. DS wants to watch golf and I want to watch football, so green is critical path.

The wiki suggests settings like:

Code: Select all

brightness=0x80 --set-ctrl contrast=0x40 --set-ctrl hue=0xf --set-ctrl saturation=0x40 --set-ctrl sharpness=0x80
But when I print the help from v4l2-ctl, it offers a numerical range for each setting (like 0 to 128) and reports the setting as an integer within the range.

How does the "0x80" type of setting relate to the integer that v4l is asking for? Is this part of my problem?
Any advice on how to get greens/blues from my HDPVR would be great. I see so many of you report getting a great picture with it. My video source is an Arris STB using component video.
TIA.

Gribnif
Junior
Posts: 75
Joined: Wed May 14, 2014 12:46 pm
United States of America

Re: HDPVR color is off

Post by Gribnif » Thu Jan 14, 2021 9:24 pm

I recently upgraded the firmware on both of my units, and I found that the default values work just fine, where I had previously been using a hack to change them to suit the old firmware.

"0x80" is hexadecimal for 128 decimal. I think v4l2-ctl will understand either format. So here are the defaults, represented in hex:

Code: Select all

v4l2-ctl  -d /dev/video0 --set-ctrl brightness=0x80 --set-ctrl contrast=0x40 --set-ctrl hue=0xf --set-ctrl saturation=0x40 --set-ctrl sharpness=0x80

Linuxgrrl
Junior
Posts: 66
Joined: Mon Oct 26, 2020 12:46 am
United States of America

Re: HDPVR color is off

Post by Linuxgrrl » Thu Jan 14, 2021 11:36 pm

Thanks for the explanation.
I'm trying those settings, and they are a little better, but there is still a pinkish/grayish overlay. Greens still look washed out.
Suggestions welcome.

Gribnif
Junior
Posts: 75
Joined: Wed May 14, 2014 12:46 pm
United States of America

Re: HDPVR color is off

Post by Gribnif » Fri Jan 15, 2021 4:00 pm

Before you do any more tinkering with the settings, if you have another cable, try swapping it out. It could just be that your current one isn't making good contact or is frayed. Or even just try swapping the three parts of the cable you have now, the same at both ends. (So, for instance, connect red to blue, blue to green, and green to red at both ends.) If the symptoms change, then you know the cable is at fault.

Linuxgrrl
Junior
Posts: 66
Joined: Mon Oct 26, 2020 12:46 am
United States of America

Re: HDPVR color is off

Post by Linuxgrrl » Fri Jan 15, 2021 8:56 pm

Right you were! I'm not sure how, but one of the blue cables had worked itself all the way out in the back of the cabinet. Didn't even think to check.
Thank you! Golf and everything else looks great now.

User avatar
Steve Goodey
Moderator
Posts: 159
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: HDPVR color is off

Post by Steve Goodey » Fri Jan 15, 2021 9:41 pm

If you're happy with the fix could you possibly added [Solved] to the subject line in the first post?

Ta.
Don't forget the Wiki.

Post Reply