Page 1 of 1

[Solved] Struggling with LIRC after a 31 install / upgrade

Posted: Tue Aug 25, 2020 2:35 am
by whosmatt
I use "install / upgrade" because I didn't technically upgrade but I did bring my database over from 0.28. I think I've gotten everything ironed out *except* LIRC and my Streamzap remote.

So, my OS (Xubuntu 20.04) sees and uses the Streamzap on its own, without LIRC installed. In that way some of the buttons work in mythfrontend but not enough of them.

I installed LIRC and configured it and it seems to see my remote and I've brought over my old lircrc and also tried creating one per the documentation but no change in behavior.

I went meddling around with the remote settings in mythfrontend; it was set to /dev/lircd which doesn't exist on my system. I changed it to the default of /var/run/lirc/lircd and bam -- now it doesn't work at all, not in mythfrontend and not in xfce.******

***** I initially thought this was true but the remote in fact still works in xfce even though the enable slider is off:

Image

My thought is that xfce and mythfrontend are fighting over the remote but not sure how to resolve.
Thoughts?
Apologies if this has been hashed over before but searching didn't turn up anything that seemed relevant.

Re: Struggling with LIRC after a 31 install / upgrade

Posted: Tue Aug 25, 2020 3:02 am
by whosmatt
Eh, the slider in xfce seems to disable it only as a pointing device. Stuff like the volume control still works in the OS.

I just changed the lirc daemon socket in mythfrontend from /var/run/lirc/lircd to /dev/lirc0 and the limited input started working again. (I get the four directional keys only in mythfrontend).

I decided to deliberately change the lirc daemon socket to /dev/splat and it keeps "working." So I'm surmising that the working input is coming from the pointing device settings screenshotted above in xfce and has nothing to do with LIRC

Re: Struggling with LIRC after a 31 install / upgrade

Posted: Tue Aug 25, 2020 10:45 am
by wesnewell
Sounds like it's using ir-keytable and the default keymap file for your remote. in terminal type ir- and hit the tab key. If it inserts keytable then that's what's happening and you will have to remove one or the other and fix the control files. man ir-keytable if installed.

Re: Struggling with LIRC after a 31 install / upgrade

Posted: Tue Aug 25, 2020 2:26 pm
by whosmatt
ir-keytable isn't installed.

Since I'm gathering that IR remote support is now built in to the OS, can / should I just ditch LIRC and use ir-keytable? I only need input; I'm not doing a blaster.

Re: Struggling with LIRC after a 31 install / upgrade

Posted: Tue Aug 25, 2020 3:28 pm
by wesnewell
Up to you, but I switched to ir-keytable a few years back and haven't regretted it. Although when I installed 20.04 I had to redo the control files. here's where I figured that out.
viewtopic.php?f=29&t=3729&hilit=ir+keyt ... =30#p18556

Re: Struggling with LIRC after a 31 install / upgrade

Posted: Tue Aug 25, 2020 8:34 pm
by whosmatt
https://twosortoftechguys.wordpress.com ... ntu-18-04/

Got it. I wasn't doing anything wrong, it's just that lirc 0.10.0 doesn't work right. I grabbed 0.9.0 from the xenial repository and it just works.

Re: Struggling with LIRC after a 31 install / upgrade

Posted: Wed Aug 26, 2020 8:05 am
by Steve Goodey
Hello,

If you're happy with the fix could you possibly added [Solved] to the subject line in the first post?

Ta.

Re: [SOLVED] Struggling with LIRC after a 31 install / upgrade

Posted: Wed Aug 26, 2020 1:48 pm
by whosmatt
Done. Thanks all!