Problems changing to schedules direct json... [solved]

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Problems changing to schedules direct json... [solved]

Post by raydude » Sat May 02, 2020 9:24 pm

Sorry if this has been beaten to death, but I have a basic problem:

In mythtv-setup, under video source, I don't have an option to choose external xmltv json script or what ever it's called. All I have are the internal schedules direct, OTA and none options.

I'm running gentoo and mythtv should be built with xmltv enabled (the use flag is set).

I'm only running version 30 at this point, I'll try 31 after this is a success.

Can someone give me a nudge? I can't run the xmltv setup script until the xmltv file is created by mythtv-setup...

Perhaps I should try 31 first?
Last edited by raydude on Sun May 03, 2020 6:11 am, edited 1 time in total.

User avatar
paulh
Developer
Posts: 542
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: Problems changing to schedules direct json...

Post by paulh » Sat May 02, 2020 9:37 pm

Sounds like you need to install xmltv.

raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Problems changing to schedules direct json...

Post by raydude » Sat May 02, 2020 9:47 pm

Thanks. I should have mentioned. xmltv is installed. (version 5.7)

raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Problems changing to schedules direct json...

Post by raydude » Sat May 02, 2020 9:59 pm

I don't know if this is the problem (I'm rebuilding mythtv at the moment) but I was missing this package: dev-python/simplejson-3.17.0

I found that out by running configure on a fresh tar xf of mythtv-31.

User avatar
paulh
Developer
Posts: 542
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: Problems changing to schedules direct json...

Post by paulh » Sat May 02, 2020 10:02 pm

tv_find_grabbers should give you a list of available grabbers.

User avatar
bill6502
Developer
Posts: 1723
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Problems changing to schedules direct json...

Post by bill6502 » Sat May 02, 2020 10:35 pm

@raydude,

As to the "Perhaps I should try 31 first?" question. No, and the intent is that
you can switch to the SD JSON before going to v31 (so that you won't need
to go though this after upgrading).

Note that there should be a success/failure message in the mythtv-setup log
when tv_find_grabbers is tried.

simplejson is used by some Python tools and not for SD.

raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Problems changing to schedules direct json...

Post by raydude » Sat May 02, 2020 11:24 pm

tv_find_grabbers does not find anything. I must be missing some piece of the puzzle.

The first step is to just the xmltv json in mythtv-setup, right?

raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Problems changing to schedules direct json...

Post by raydude » Sat May 02, 2020 11:42 pm

I turned on verbose messaging for mythtv-setup -v xmltv. It announced verbose messaging, but didn't say anything.

Could this be because xmltv is installed in /usr/bin instead of /usr/local/bin?

User avatar
bill6502
Developer
Posts: 1723
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Problems changing to schedules direct json...

Post by bill6502 » Sat May 02, 2020 11:46 pm

My grabbers are in /usr/bin.

To be clear, you tried to select the grabber in: Video sources -> Listings Grabber: and pressed Return to
get the list.

Vaska
Junior
Posts: 42
Joined: Fri Sep 01, 2017 11:09 pm
Canada

Re: Problems changing to schedules direct json...

Post by Vaska » Sun May 03, 2020 1:33 am

raydude - I'm on Gentoo as well but only moved to xmltv/json after I moved to v31 so I can't speak to your v30, but I'll be you just need to enable the zz-sdjson use flag for media-tv/xmltv.

What does "equery u media-tv/xmltv" show you?

I had to specicically enable zz-sdjson before I could see this:

" + + zz-sdjson : Grabber for schedulesDirect.org SD-JSON service (many countries)"

Create this file:
/etc/portage/package.use/xmltv

Put this in it:
media-tv/xmltv zz-sdjson

Re-emerge xmltv with N --> emerge -vDaNq media-tv/xmltv

Then give it another try. If it still fails then maybe you need to re-emerge or re-compile MythTV after the new use flag for xmltv.

raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Problems changing to schedules direct json...

Post by raydude » Sun May 03, 2020 6:09 am

I figured it out. xmltv has a use option for all sources. I had none set, so none installed.

My bad.

It's up and running now...

raydude
Junior
Posts: 16
Joined: Sat Sep 02, 2017 8:08 pm
United States of America

Re: Problems changing to schedules direct json...

Post by raydude » Sun May 03, 2020 6:11 am

Vaska wrote:
Sun May 03, 2020 1:33 am
raydude - I'm on Gentoo as well but only moved to xmltv/json after I moved to v31 so I can't speak to your v30, but I'll be you just need to enable the zz-sdjson use flag for media-tv/xmltv.

What does "equery u media-tv/xmltv" show you?

I had to specicically enable zz-sdjson before I could see this:

" + + zz-sdjson : Grabber for schedulesDirect.org SD-JSON service (many countries)"

Create this file:
/etc/portage/package.use/xmltv

Put this in it:
media-tv/xmltv zz-sdjson

Re-emerge xmltv with N --> emerge -vDaNq media-tv/xmltv

Then give it another try. If it still fails then maybe you need to re-emerge or re-compile MythTV after the new use flag for xmltv.
Thanks. That was the problem. I meant to post earlier, but got distracted.

Once I enabled that use flag and re-emerged xmltv, the option showed up in mythtv.

Post Reply