Job queue is backed up

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Job queue is backed up

Post by necbot » Thu May 23, 2019 12:08 am

My job queue has a lot of stuff backed up on it. It seems to be stalled on a commercial flag job. When I run...

Code: Select all

mysql -u mythtv -p mythconverg -e "SELECT id,chanid,starttime,comment,status FROM jobqueue"
I get this...

+-----+--------+---------------------+---------------------------+--------+
| id | chanid | starttime | comment | status |
+-----+--------+---------------------+---------------------------+--------+
| 189 | 10651 | 2019-05-20 01:00:00 | | 1 |
| 190 | 10651 | 2019-05-20 00:00:00 | | 1 |
| 191 | 10651 | 2019-05-20 02:00:00 | | 1 |
| 185 | 10651 | 2019-05-19 23:00:00 | | 1 |
| 186 | 10621 | 2019-05-19 23:00:00 | | 1 |
| 173 | 10651 | 2019-05-19 22:00:00 | Metadata Lookup Complete. | 272 |
| 376 | 10621 | 2019-05-23 00:00:00 | | 1 |
| 188 | 10621 | 2019-05-20 00:00:00 | | 1 |
| 187 | 10651 | 2019-05-20 00:00:00 | | 1 |
| 235 | 10624 | 2019-05-20 22:30:00 | | 1 |
| 234 | 10624 | 2019-05-20 23:00:00 | | 1 |
| 183 | 10611 | 2019-05-19 23:30:00 | | 1 |
| 178 | 10651 | 2019-05-19 23:00:00 | | 1 |
| 179 | 10621 | 2019-05-19 22:00:00 | | 1 |
| 180 | 10611 | 2019-05-19 23:00:00 | | 1 |
| 233 | 10621 | 2019-05-20 23:00:00 | | 1 |
| 184 | 10621 | 2019-05-20 00:00:00 | | 1 |
| 182 | 10611 | 2019-05-19 23:00:00 | | 1 |
| 181 | 10611 | 2019-05-19 23:30:00 | | 1 |
| 175 | 10651 | 2019-05-19 21:00:00 | Searching for Logo | 4 |
| 172 | 10621 | 2019-05-19 22:00:00 | Metadata Lookup Complete. | 272 |

ID 175 is stuck. What does status 4 mean?

Gribnif
Junior
Posts: 56
Joined: Wed May 14, 2014 12:46 pm
United States of America

Re: Job queue is backed up

Post by Gribnif » Thu May 23, 2019 6:54 pm

This happens to me every month or two, as well. Simply restarting the backend is enough to get it running again.

necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Re: Job queue is backed up

Post by necbot » Thu May 23, 2019 10:16 pm

I restarted and things seem to be moving again. I'm not sure why it stalled. I should have restarted sooner, I have a lot of commercial flagging job on the queue. Can I clear those somehow?

User avatar
bill6502
Developer
Posts: 1408
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Job queue is backed up

Post by bill6502 » Thu May 23, 2019 10:34 pm

To your original question: https://www.mythtv.org/wiki/Jobqueue_table. 4=Running.

Or: https://code.mythtv.org/cgit/mythtv/tre ... jobqueue.h if you like.

'Searching for Logo' sounds like commercial flagging. If you add type to the initial
query, you can prove that(JOB_COMMFLAG=0x0002.)

necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Re: Job queue is backed up

Post by necbot » Fri May 24, 2019 10:38 pm

bill6502 wrote:
Thu May 23, 2019 10:34 pm
To your original question: https://www.mythtv.org/wiki/Jobqueue_table. 4=Running.

Or: https://code.mythtv.org/cgit/mythtv/tre ... jobqueue.h if you like.

'Searching for Logo' sounds like commercial flagging. If you add type to the initial
query, you can prove that(JOB_COMMFLAG=0x0002.)
Thanks! That page was very useful. One more question. After I restarted it stalled again. When it stalls, I see that it is stuck on a commercial flagging job and the message says "Searching for Logo". The latest job has been stalled for about 16 hours now.

necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Re: Job queue is backed up

Post by necbot » Mon May 27, 2019 6:26 pm

Okay I give up. Whenever I clear the stalled job another takes it's place. My job queue is backed up with over a weeks worth of jobs! Commercial flagging is clearly too buggy and doesn't work. How do I turn commercial flagging off?

User avatar
pvr4me
Senior
Posts: 660
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Job queue is backed up

Post by pvr4me » Mon May 27, 2019 9:58 pm

Commercial flagging works for me 99.99% of the time. I think the only time I've had stuck commflag jobs was when the recording was subtly damaged. It seems to abort on severely damaged recordings. What is the source of your recordings and have you noticed any glitches?

Craig
The MacPorts guy.

User avatar
bill6502
Developer
Posts: 1408
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Job queue is backed up

Post by bill6502 » Mon May 27, 2019 10:29 pm

/var/log/mythtv/mythcommflag.log may have a clue about why it's hanging.

To turn flagging off, edit each recording rule. To turn it off for future rules,
edit the Default template (or others you may have created.)

Another option would be to change the Commercial detection method in
the frontend Setup->Video->General->General (Jobs) to a method that
doesn't use Logo Detection.

necbot
Junior
Posts: 21
Joined: Thu Mar 05, 2015 5:16 pm
United States of America

Re: Job queue is backed up

Post by necbot » Tue May 28, 2019 12:40 am

bill6502 wrote:
Mon May 27, 2019 10:29 pm
/var/log/mythtv/mythcommflag.log may have a clue about why it's hanging.

To turn flagging off, edit each recording rule. To turn it off for future rules,
edit the Default template (or others you may have created.)

Another option would be to change the Commercial detection method in
the frontend Setup->Video->General->General (Jobs) to a method that
doesn't use Logo Detection.
Thanks bill6502. That worked!

Post Reply